summaryrefslogtreecommitdiff
path: root/dev-python/pyspf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pyspf
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pyspf')
-rw-r--r--dev-python/pyspf/Manifest3
-rw-r--r--dev-python/pyspf/metadata.xml11
-rw-r--r--dev-python/pyspf/pyspf-2.0.12.ebuild34
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/pyspf/Manifest b/dev-python/pyspf/Manifest
new file mode 100644
index 000000000000..9b708ef67aa4
--- /dev/null
+++ b/dev-python/pyspf/Manifest
@@ -0,0 +1,3 @@
+DIST pyspf-2.0.12t.tar.gz 67189 BLAKE2B 40ddecf6e9717da9e496c5852866259f28af11c5e9ef581ef1188b07896bce7abc3ba901063bfea2ec9f89d70e17275b0e2619f23f9dc334628ebb0af084b79c SHA512 1ad23b5dea4aa8edd03b3fd9fc675685bcb0e216474534563c55988df040abd4e2bbc8488bba80d26466877e8b2ec88cbadc2f67eb8c4bf6f26f975d8af81d8d
+EBUILD pyspf-2.0.12.ebuild 972 BLAKE2B ff3fe1ce1838f273f40d1b40c34cd22524866b8888af405e7431667d26d347be71138825ec05a9b094e52f9bd157cd2c03b4858b8f70b68bf3990cb6d6b7f8cf SHA512 84206fe62d5b139a8f2de59f1a992d1c8de5c9696f3ecc95a0973274ce7fae4f191c45643802b3e6cc2fd7c879ce17b3260c87f92e8505f89a58cf591b38368a
+MISC metadata.xml 318 BLAKE2B 428f1f97b1e20927edbd26d3cb405e242e2bdc4c2cd301b9dd7999570b0ffb5af1c786a6cf596917d6d2694e29cf47c3809d3af97adb078064dc3562fe2690e1 SHA512 561cbdd0b14a8fb091ba9943987d93c8c1323a4b5f8f2b32f094284d683eec5562153a5a8ec77412a0806bac56c5667ec6e9e8d99e77bc2e45a5b7d517c8c483
diff --git a/dev-python/pyspf/metadata.xml b/dev-python/pyspf/metadata.xml
new file mode 100644
index 000000000000..d9d5ab63ea89
--- /dev/null
+++ b/dev-python/pyspf/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pyspf</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyspf/pyspf-2.0.12.ebuild b/dev-python/pyspf/pyspf-2.0.12.ebuild
new file mode 100644
index 000000000000..abad4d2aa821
--- /dev/null
+++ b/dev-python/pyspf/pyspf-2.0.12.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_REQ_USE="ipv6?"
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of the Sender Policy Framework (SPF) protocol"
+HOMEPAGE="https://pypi.org/project/pyspf/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}t.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="ipv6 test"
+
+# >=python-3.3 comes with the built-in ipaddress module
+RDEPEND="dev-python/authres[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/ipaddr-2.1.10[${PYTHON_USEDEP}]' python2_7)
+ $(python_gen_cond_dep 'dev-python/pydns:2[${PYTHON_USEDEP}]' python2_7)
+ $(python_gen_cond_dep 'dev-python/pydns:3[${PYTHON_USEDEP}]' 'python3*')"
+
+DEPEND="test? ( ${RDEPEND}
+ dev-python/pyyaml[${PYTHON_USEDEP}] )"
+
+REQUIRED_USE="test? ( ipv6 )"
+
+python_test() {
+ pushd test &> /dev/null
+ "${PYTHON}" testspf.py || die
+ popd &> /dev/null
+}