summaryrefslogtreecommitdiff
path: root/dev-python/pyspf/pyspf-2.0.14.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /dev-python/pyspf/pyspf-2.0.14.ebuild
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'dev-python/pyspf/pyspf-2.0.14.ebuild')
-rw-r--r--dev-python/pyspf/pyspf-2.0.14.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pyspf/pyspf-2.0.14.ebuild b/dev-python/pyspf/pyspf-2.0.14.ebuild
new file mode 100644
index 000000000000..0a05ece1b7d0
--- /dev/null
+++ b/dev-python/pyspf/pyspf-2.0.14.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
+PYTHON_REQ_USE="ipv6?"
+
+DISTUTILS_USE_SETUPTOOLS=no
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of the Sender Policy Framework (SPF)"
+HOMEPAGE="https://pypi.org/project/pyspf/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ipv6 test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/authres[${PYTHON_USEDEP}]
+ || ( dev-python/pydns:3[${PYTHON_USEDEP}]
+ dev-python/dnspython[${PYTHON_USEDEP}] )"
+
+DEPEND="test? ( ${RDEPEND}
+ dev-python/pyyaml[${PYTHON_USEDEP}] )"
+
+REQUIRED_USE="test? ( ipv6 )"
+
+python_test() {
+ pushd test &> /dev/null
+ "${PYTHON}" testspf.py || die
+ popd &> /dev/null
+}