summaryrefslogtreecommitdiff
path: root/dev-python/pyspelling
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /dev-python/pyspelling
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'dev-python/pyspelling')
-rw-r--r--dev-python/pyspelling/Manifest3
-rw-r--r--dev-python/pyspelling/metadata.xml28
-rw-r--r--dev-python/pyspelling/pyspelling-2.7.0.ebuild54
3 files changed, 85 insertions, 0 deletions
diff --git a/dev-python/pyspelling/Manifest b/dev-python/pyspelling/Manifest
new file mode 100644
index 000000000000..9cea24378912
--- /dev/null
+++ b/dev-python/pyspelling/Manifest
@@ -0,0 +1,3 @@
+DIST pyspelling-2.7.0.tar.gz 149425 BLAKE2B f8e600a41ebd4ec290562307306e7fd5c67d384b9186de037b98d50d58016ded19c426caa892497ca44e309fb3db04292b890612afbe25a34f9f6b06985d3740 SHA512 2fcd225a66cb02fff10d5ca652e523a01bd0488a005dafa32ba1151fba9afe73809781501c957d6df00927baa9fb6779872973b32e2d3fe8a09306fdc4191995
+EBUILD pyspelling-2.7.0.ebuild 1339 BLAKE2B 02605cc438f1292b803cf477d9ece6ee8ac5acf66c3fa51b813f3edae8faf57033e13547a08704a9f8a1ecdffced770d40c180770031c1ed16396357ad2f4e07 SHA512 2bfc52570bac76a50854f4ff3a6aafbc9f82894a16c7a1096d8b3e25d07f6dc33806068f815b2c8d982f62b14a62762b56f781f56625dd4aa84401347b8f9325
+MISC metadata.xml 1868 BLAKE2B 06a6aada2ff7c6634c7baff2eb5ebbe5e6f884a44cd9828b6aac350bcdae480b6ff3fae5a3060721db386e80558167ebb50937afe209ff2cf2cb5296cdadf4f8 SHA512 89c47e531f6aa5a2e7525732a30d3b9e62be48598a6ea61ccd3588223e01ca4f54fd6cd9359ccc6d1fe9a269cd865fabf960d18cf084feb0c7368f5beb0fc446
diff --git a/dev-python/pyspelling/metadata.xml b/dev-python/pyspelling/metadata.xml
new file mode 100644
index 000000000000..6299093ac738
--- /dev/null
+++ b/dev-python/pyspelling/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lssndrbarbieri@gmail.com</email>
+ <name>Alessandro Barbieri</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>andrewammerlaan@riseup.net</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">facelessuser/pyspelling</remote-id>
+ <remote-id type="pypi">pyspelling</remote-id>
+ </upstream>
+ <longdescription lang="en">
+PySpelling is a module to help with automating spell checking in a project with Aspell or
+Hunspell. It is essentially a wrapper around the command line utility of these two spell
+checking tools, and allows you to setup different spelling tasks for different file types.
+You can apply specific and different filters and options to each task. PySpelling can also
+be used in CI environments to fail the build if there are misspelled words.
+Aspell and Hunspell are very good spell checking tools. Aspell particularly comes with a couple of filters, but the filters are limited in types and aren't extremely flexible. PySpelling was created to work around Aspell's and Hunspell's filtering shortcomings by creating a wrapper around them that could be extended to handle more kinds of file formats and provide more advanced filtering. If you need to filter out specific HTML tags with specific IDs or class names, PySpelling can do it. If you want to scan Python files for docstrings, but also avoid specific content within the docstring, you can do that as well. If PySpelling doesn't have a filter you need, with access to so many available Python modules, you can easily write your own.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/pyspelling/pyspelling-2.7.0.ebuild b/dev-python/pyspelling/pyspelling-2.7.0.ebuild
new file mode 100644
index 000000000000..8aea32458614
--- /dev/null
+++ b/dev-python/pyspelling/pyspelling-2.7.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+DOCS_BUILDER="mkdocs"
+DOCS_DEPEND="
+ ~dev-python/mkdocs_pymdownx_material_extras-1.1.3
+ dev-python/mkdocs-git-revision-date-localized-plugin
+ dev-python/mkdocs-minify-plugin
+"
+
+inherit distutils-r1 docs
+
+DESCRIPTION="Spell checker automation tool"
+HOMEPAGE="https://github.com/facelessuser/pyspelling"
+SRC_URI="https://github.com/facelessuser/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ || ( app-text/aspell app-text/hunspell )
+
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/soupsieve-1.8[${PYTHON_USEDEP}]
+ >=dev-python/wcmatch-6.0.3[${PYTHON_USEDEP}]
+"
+
+BDEPEND="test? ( dev-vcs/git )"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # mkdocs-git-revision-date-localized-plugin needs git repo
+ if use doc; then
+ git init || die
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ git add . || die
+ git commit -m 'init' || die
+ fi
+
+ distutils-r1_python_prepare_all
+}