summaryrefslogtreecommitdiff
path: root/dev-python/pysol-cards
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-05 14:04:26 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-05 14:04:26 +0000
commit8fd9d385e5bc3c01115ec2ddcb2227607eb90861 (patch)
treeaba1e6ef6b95e94172c009394cd1fcbc383e7d6e /dev-python/pysol-cards
parent1ddcee0bd115d2f843f82061cb0d1741bf90151d (diff)
gentoo auto-resync : 05:01:2024 - 14:04:25
Diffstat (limited to 'dev-python/pysol-cards')
-rw-r--r--dev-python/pysol-cards/Manifest5
-rw-r--r--dev-python/pysol-cards/metadata.xml16
-rw-r--r--dev-python/pysol-cards/pysol-cards-0.14.3.ebuild26
-rw-r--r--dev-python/pysol-cards/pysol-cards-0.16.0.ebuild26
4 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/pysol-cards/Manifest b/dev-python/pysol-cards/Manifest
new file mode 100644
index 000000000000..298833c59672
--- /dev/null
+++ b/dev-python/pysol-cards/Manifest
@@ -0,0 +1,5 @@
+DIST pysol_cards-0.14.3.tar.gz 18322 BLAKE2B 730da3d597377305c86e528606edd3db9f07390d333283a228c2411d35f2e19da61d27f21e3d2650b84ba0f4b0d48e87cf7004d518845fe2a40b041e286d5a28 SHA512 00bb25393eab855d7444324b33e0561bfbcc86ae53306b58623fa15ea005378aff6af51846aab4634b43fdba5497c3872c32baf3a51013ee01d5ab2d7a7a9d51
+DIST pysol_cards-0.16.0.tar.gz 18987 BLAKE2B 5f4174462aaadd75b325a6c3e7e16bcc8e9694bb2e9a45eab3caa325959b1870531b71332728851bcbffba8f5a2022ae0a5b2fd81b75212a77e3fce8177d128f SHA512 728e76017cab27b5e67ed234951bff0608285caf1a79ab5f60a72d58530f4107fdb28749c4a2b4744830ecabaade1f413ad657149afa6aee8cb792b5dbcc8bce
+EBUILD pysol-cards-0.14.3.ebuild 535 BLAKE2B 2a33ccf7f1d9f6a03d5ee26bddb17fc8f2247e7b48c99c4e14df19ba71cf3f1b36a745c772943f911ece5ee358ae41ce703e56cb4fe4855a9469858adc6c659b SHA512 02767095ee5360ed68caac030fae36cecdfb207e12f92a96e028aaf5ab4048bbc032140b29314695f659382a7b82fb4f884d019839eca5d9c3fd0ad25a01af80
+EBUILD pysol-cards-0.16.0.ebuild 538 BLAKE2B fe35acca668f17c6e906adf329e4d718a89e487089ed0841096c4637af13d7f589c7cfaee2404b5e7328f62f2c05143d8274e2d4f5caaf4aae0efaa9928cc548 SHA512 918feabb13cfbe78699c9287351c93bb5867b85a34fb357b98c7f6854ca4d5692773ee1676e812bc37737cf4e591dc451ecbab292e774d44889e4f070cfbe973
+MISC metadata.xml 474 BLAKE2B 47398a90962b1059e1d2725f7b20dbc10586cee53ab27eff6a9d0c8d93cde1b103580494a38aad77a3ae04c7f7a95bcbe52722ce18476a77994e49cb64076e58 SHA512 b8cba71875a546d130fbc94e3a76a3e0dd27552ce14de46a8b6bd79f12584b59ea8e9354fadd272c4e21ac9df7f43e9c1db9087338acfbed3dc680a6d812ffa6
diff --git a/dev-python/pysol-cards/metadata.xml b/dev-python/pysol-cards/metadata.xml
new file mode 100644
index 000000000000..474258121ee8
--- /dev/null
+++ b/dev-python/pysol-cards/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>kde@gentoo.org</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pysol-cards</remote-id>
+ <remote-id type="github">shlomif/pysol_cards</remote-id>
+ </upstream>
+ <stabilize-allarches/>
+</pkgmetadata>
diff --git a/dev-python/pysol-cards/pysol-cards-0.14.3.ebuild b/dev-python/pysol-cards/pysol-cards-0.14.3.ebuild
new file mode 100644
index 000000000000..fc9fbb72135f
--- /dev/null
+++ b/dev-python/pysol-cards/pysol-cards-0.14.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Deal PySol FreeCell cards"
+HOMEPAGE="
+ https://github.com/shlomif/pysol_cards/
+ https://pypi.org/project/pysol-cards/
+"
+
+LICENSE="Apache-2.0 MIT"
+SLOT="0"
+KEYWORDS="amd64 arm64 ~loong ~riscv x86"
+
+RDEPEND="
+ dev-python/random2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
diff --git a/dev-python/pysol-cards/pysol-cards-0.16.0.ebuild b/dev-python/pysol-cards/pysol-cards-0.16.0.ebuild
new file mode 100644
index 000000000000..277d07d6becc
--- /dev/null
+++ b/dev-python/pysol-cards/pysol-cards-0.16.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Deal PySol FreeCell cards"
+HOMEPAGE="
+ https://github.com/shlomif/pysol_cards/
+ https://pypi.org/project/pysol-cards/
+"
+
+LICENSE="Apache-2.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
+
+RDEPEND="
+ dev-python/random2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest