summaryrefslogtreecommitdiff
path: root/dev-python/pysnmp/pysnmp-4.4.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /dev-python/pysnmp/pysnmp-4.4.12.ebuild
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'dev-python/pysnmp/pysnmp-4.4.12.ebuild')
-rw-r--r--dev-python/pysnmp/pysnmp-4.4.12.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/pysnmp/pysnmp-4.4.12.ebuild b/dev-python/pysnmp/pysnmp-4.4.12.ebuild
deleted file mode 100644
index 4fd27129e43d..000000000000
--- a/dev-python/pysnmp/pysnmp-4.4.12.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
-inherit distutils-r1
-
-DESCRIPTION="Python SNMP library"
-HOMEPAGE="http://snmplabs.com/pysnmp/ https://pypi.org/project/pysnmp/ https://github.com/etingof/pysnmp"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~ia64 ppc ~sparc x86"
-IUSE="doc examples"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-"
-RDEPEND="
- >=dev-python/pyasn1-0.2.3[${PYTHON_USEDEP}]
- dev-python/pysmi[${PYTHON_USEDEP}]
- || (
- dev-python/pycryptodome[${PYTHON_USEDEP}]
- dev-python/pycrypto[${PYTHON_USEDEP}]
- )
-"
-
-python_compile_all() {
- default
-
- if use doc; then
- touch docs/source/conf.py
- emake -C docs html
- fi
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/build/html/* )
- docinto examples
- use examples && dodoc -r examples/* docs/mibs
-
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- elog "You may also be interested in the following packages: "
- elog "dev-python/pysnmp-apps - example programs using pysnmp"
- elog "dev-python/pysnmp-mibs - IETF and other mibs"
- elog "dev-python/pysmi - to dump MIBs in python format"
-}