summaryrefslogtreecommitdiff
path: root/dev-python/pysmi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /dev-python/pysmi
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'dev-python/pysmi')
-rw-r--r--dev-python/pysmi/Manifest4
-rw-r--r--dev-python/pysmi/metadata.xml1
-rw-r--r--dev-python/pysmi/pysmi-0.3.4.ebuild8
3 files changed, 8 insertions, 5 deletions
diff --git a/dev-python/pysmi/Manifest b/dev-python/pysmi/Manifest
index 8c8ae8c4a2be..586958e4c087 100644
--- a/dev-python/pysmi/Manifest
+++ b/dev-python/pysmi/Manifest
@@ -1,3 +1,3 @@
DIST pysmi-0.3.4.tar.gz 93985 BLAKE2B 71b0ed936c196381f895b4f56e8e2e328ac274b08801a77b404b964201e00f8da2cbce2719414da358a4feb7992a3d04e732942f6e7006a0cceea4496f96b758 SHA512 720c8948a590130583d6ea388f0ade5d3bfe9e845821add7ffbf1b5495b5fe00b768ffb94f67b82465c6d86234f5306c6e1a5c2e49f4825bb9c31a0df629f7bd
-EBUILD pysmi-0.3.4.ebuild 425 BLAKE2B 231f9ced0b626eb3f136aa6d7ff77241f561b33629f4a57e60cbc971743906ee5b2bf9ba35533cbd5e9ca2bbe87eae4a9e24bc466015fadc495c81cc42a480a6 SHA512 3b99ed4b515b163111680d66b3e86d70baea52009a7fe4fb4eee9e9b1293b870385f741fc923f007c52ffd2f74727f5d73cb3375daeed8b765d63771e1654b86
-MISC metadata.xml 414 BLAKE2B 6b43ab72d3bbd00cba2f58ee65d9f567f4a1012e2d691074f5b4fc436ca2a51e24bf4088027fe0b439a6e0391b0e05f3fc20902634b86d1b72a682fca7b7461f SHA512 6fbc62e3f60b75e2bd6ad20e5c66d790d03764154bcface954d9a38486e0914ccf19922c0f7bc75c37cbebc48480750e6024f15062f23fc2b253e287475befaa
+EBUILD pysmi-0.3.4.ebuild 495 BLAKE2B 763e018cd1e7c9bc407b110380f1e1de531fbd1d84c1e10e1cce58531bcf0760790a617e03beb691a7c9b698bd9e9cee2418539096d3d95a79f4568e4af8c343 SHA512 ba9a6fff7dc8b13487db0807b6abdb8a8973b5f0882442f7ce9c43bf601606b97342680763fa94dff71d1c9cbfbbe00ff851f5b5bd116294cbb98a9a2eaabf56
+MISC metadata.xml 438 BLAKE2B 3ac74ce8f327d154727a24a60523b2eda0c0b8398c872d676cf4a934d1243eda303c240a9f2d6c9f017d3dcdc4e5c3a38b6ea2f80056abd91642a2d85c7dc960 SHA512 78238201b20bd896e945967f8d1e65117ccfc1126554828a67865ef676f223b346d40cce66c6b4a1e15107690449856c3680870152b62dc2e79811442a3cd9a5
diff --git a/dev-python/pysmi/metadata.xml b/dev-python/pysmi/metadata.xml
index 6a5f21bdfe8d..701159a49f16 100644
--- a/dev-python/pysmi/metadata.xml
+++ b/dev-python/pysmi/metadata.xml
@@ -9,6 +9,7 @@
<email>python@gentoo.org</email>
<name>Python</name>
</maintainer>
+ <stabilize-allarches/>
<upstream>
<remote-id type="pypi">pysmi</remote-id>
</upstream>
diff --git a/dev-python/pysmi/pysmi-0.3.4.ebuild b/dev-python/pysmi/pysmi-0.3.4.ebuild
index a25f52054908..65ae6d0c5a5b 100644
--- a/dev-python/pysmi/pysmi-0.3.4.ebuild
+++ b/dev-python/pysmi/pysmi-0.3.4.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2017-2020 Gentoo Authors
+# Copyright 2017-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1
DESCRIPTION="Python Lex & Yacc"
@@ -15,4 +15,6 @@ SLOT="0"
KEYWORDS="amd64 ~arm ~ia64 ppc ~sparc x86"
RDEPEND="dev-python/ply[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
+BDEPEND="test? ( dev-python/pysnmp[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests unittest