summaryrefslogtreecommitdiff
path: root/dev-python/pysmi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-31 03:04:18 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-10-31 03:04:18 +0000
commitb846e1a1ef5685462a20abbc77cf57ead9064b85 (patch)
treeebf4581a96d87fbd1b7ab6cce8689ba4caa40e3b /dev-python/pysmi
parentfb57e01054259b1160d01c3c7ed9efab7902ed7d (diff)
gentoo auto-resync : 31:10:2024 - 03:04:18
Diffstat (limited to 'dev-python/pysmi')
-rw-r--r--dev-python/pysmi/Manifest2
-rw-r--r--dev-python/pysmi/pysmi-1.5.6.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pysmi/Manifest b/dev-python/pysmi/Manifest
index 7823eabb7abf..462b1def0a40 100644
--- a/dev-python/pysmi/Manifest
+++ b/dev-python/pysmi/Manifest
@@ -1,4 +1,6 @@
AUX pysmi-1.5.0-py313.patch 1750 BLAKE2B ad4a49c9e8e37728a0b07fdcc561b0933681abee0a8759f47039a519d7104d7508835a7f1add3c7eb5375075ab027133e490a4f07426439c1ee831456e514823 SHA512 3c7d9dbf97ed9f284fef69253095a7ffe0e5bae7a36ece7c5ddb0fbd2d7e9055748aabbf461ced5d68eecf670baabb699e97dc570e2b327e77acb67cdb74a4ff
DIST pysmi-1.5.0.tar.gz 124064 BLAKE2B 763501b0fd575e356944372f0f173857d8a982a1cc7342636807d7147f7b6615d9c9518f099fb3071356957f0775e7bbd6b5f37d2110947ad22585cc44dff461 SHA512 f99fbc186b2fd481b16269e5b3622821b932459ec97023968ce8e0ae5c2d863702122a44fafb26d901b8a0b03c02f97e60c6999bdde0f19d551a61daf4e926b5
+DIST pysmi-1.5.6.tar.gz 123690 BLAKE2B bd5ca7b8bb5e9eaa3e16f59e4c32eed3cc80a0d17e7834fd0512271ea1b24dfc473d3b63943c4e621d6ba4e469eb5005fe1855387bed831e314e1e349a655d84 SHA512 86522b72726cd6f279a8259ed1037f23b2c03b302c0981e6a89f5a7e93b602a65b2bc8e3a264dea738f10710280a618b93f24563c89e66a30cc0661a90e79549
EBUILD pysmi-1.5.0.ebuild 970 BLAKE2B 5959f351947871cf379564dc91b8b19611ec63f866160248714958b1ee0c3e0c49ba3f038de5b76e54bc9395edffc257dfe0a06f646991f99a1cb807d21732c2 SHA512 836cb0e629d5faf63102e6d63ef416d86c35cb5f48ff92b43ac58401219d04470920b3e0371210cca6194a3669acd3b49ee8befea938b61d6cafa43866ac081c
+EBUILD pysmi-1.5.6.ebuild 933 BLAKE2B 4dc31a73eadc00f69139b47c1301329b97b33c89d710decea5c9588712345c2bc61d210257a3984a2ae4b89421c3027ed0f30ba0fa6ce7a9e565d14df740c55f SHA512 f888489bb47bfbbc5220a1d354b710350c2dc637657b62c47085e52647b7f93f9b0f2e40d2ab2aedc06f44d7205349cdfc3c52cd7ac75cc1d4f3bff90f95e4ca
MISC metadata.xml 387 BLAKE2B 3435c6cc7ebd04242a6529a751eeacc132dbdf473c3b5f68558e97457376e81175f51e3bee10b315b4bbf4c5ac0ddc31ed16ee6a7e8ef92ac1f5b51ce70c11b0 SHA512 15561667591496522b4662368bc9db35327bd7483e3d7411fb4d227129b02f67e042299af44203baea4a1bbd4ba3fe6c74aabb4a598a748788f2077a51571f14
diff --git a/dev-python/pysmi/pysmi-1.5.6.ebuild b/dev-python/pysmi/pysmi-1.5.6.ebuild
new file mode 100644
index 000000000000..8dc08d8ad203
--- /dev/null
+++ b/dev-python/pysmi/pysmi-1.5.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2017-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..13} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pure-Python implementation of SNMP/SMI MIB parsing and conversion library"
+HOMEPAGE="
+ https://github.com/lextudio/pysmi/
+ https://pypi.org/project/pysmi/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/jinja-3.1.3[${PYTHON_USEDEP}]
+ >=dev-python/ply-3.11[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.26.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/pysnmp-6.1.0[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # incompatibility with pysnmp >= 7
+ tests/test_objecttype_smiv2_pysnmp.py::ObjectTypeBitsTestCase::testObjectTypeSyntax
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}