summaryrefslogtreecommitdiff
path: root/dev-python/pysimdjson
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-14 06:50:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-14 06:50:14 +0000
commitafa8da78d8135ca28150730e9c60af9d875f0a5b (patch)
tree65e94479f29d7591a1bc1d09d1fc1913d785fe6b /dev-python/pysimdjson
parent4828c25c25aacf399de429d381288982fd7e0d0e (diff)
gentoo auto-resync : 14:11:2022 - 06:50:13
Diffstat (limited to 'dev-python/pysimdjson')
-rw-r--r--dev-python/pysimdjson/Manifest2
-rw-r--r--dev-python/pysimdjson/pysimdjson-5.0.1.ebuild53
2 files changed, 0 insertions, 55 deletions
diff --git a/dev-python/pysimdjson/Manifest b/dev-python/pysimdjson/Manifest
index 98451d1d1969..c278b92068e0 100644
--- a/dev-python/pysimdjson/Manifest
+++ b/dev-python/pysimdjson/Manifest
@@ -1,5 +1,3 @@
-DIST pysimdjson-5.0.1.gh.tar.gz 3827732 BLAKE2B e42d3fd2ef857ab7c22a5afa6abc3313ff1ea0aabc8a6e8213df3eaef65eb3df501bbcdba2d0de501fdec310aba00c110a30814d548255401fa0b51ca7ee03d4 SHA512 4ace2feca976afdf113b92dd263918f88f7be32156ab6f3b6fe4b798d83bb7c66029bdd7e63fb1bb3bf6568e85b14ad227934114fa7e0da0961888cdfdca8943
DIST pysimdjson-5.0.2.gh.tar.gz 3828487 BLAKE2B 6197fa9adaa353df82def9f56f821e8b7f9ec955769e9ac28d990542fc0661f3afbe9cd8f7abfc55cdce8eac94c0e5fc78dba9102c7dcfc4e3c4307d0a6fc5bf SHA512 bd7ba4d6f95967f3cd086077406a2c65b895016c9baf16fa9be6dbf77d31487ad5c40e9e3dd2496070605ef37c6a1dc75f3c1b4c96ddc8465132fbcdbde77fd3
-EBUILD pysimdjson-5.0.1.ebuild 1023 BLAKE2B 9650e4c0badaad29593dd959a6910e0d117468b664be910acca5f1346cbeb134c51eb1516280f2970d4292b57ee0fad9abff1d13d0ff86ef4e6d077f708d0d9a SHA512 512fb2427e871a8e6ed1d62dc8330d31355248b6a084b375415690f6b9b32688b1cd729a3c6a7ed06a924b85d36137a06b015a01f1e4517410d79b297968878e
EBUILD pysimdjson-5.0.2.ebuild 1023 BLAKE2B 9650e4c0badaad29593dd959a6910e0d117468b664be910acca5f1346cbeb134c51eb1516280f2970d4292b57ee0fad9abff1d13d0ff86ef4e6d077f708d0d9a SHA512 512fb2427e871a8e6ed1d62dc8330d31355248b6a084b375415690f6b9b32688b1cd729a3c6a7ed06a924b85d36137a06b015a01f1e4517410d79b297968878e
MISC metadata.xml 481 BLAKE2B 003dcb11f0a4855cd8dd86dad350442af6d410e7e1a9eb73ed986f970f12296c9fb48534c15b838a782eef814c2525e26cebf1de3e8cc31fc985d0d7d266d985 SHA512 4bfb851c32fbe0691f89e9fe18e03a96d54bb165e6853b75cef1c03645d562c8ebd33bf220966fe3e645d807cc68944a7d9732f363eb9e8fc686e9056c33c4d7
diff --git a/dev-python/pysimdjson/pysimdjson-5.0.1.ebuild b/dev-python/pysimdjson/pysimdjson-5.0.1.ebuild
deleted file mode 100644
index 16140f582754..000000000000
--- a/dev-python/pysimdjson/pysimdjson-5.0.1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 2020-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python bindings for simdjson"
-HOMEPAGE="
- https://github.com/TkTech/pysimdjson/
- https://pypi.org/project/pysimdjson/
-"
-SRC_URI="
- https://github.com/TkTech/${PN}/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="
- >=dev-libs/simdjson-2.0.1:=
-"
-RDEPEND="
- ${DEPEND}
-"
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # benchmarks aren't run
- sed -i -e 's:pytest-benchmark:: ; /license_file/ d' setup.cfg || die
- # force regen
- rm simdjson/csimdjson.cpp || die
- # unbundle
- > simdjson/simdjson.cpp || die
- echo "#include_next <simdjson.h>" > simdjson/simdjson.h || die
-
- distutils-r1_src_prepare
-
- export BUILD_WITH_CYTHON=1
-}
-
-python_compile() {
- distutils-r1_python_compile --libraries simdjson
-}