summaryrefslogtreecommitdiff
path: root/dev-python/pyside6-tools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-22 00:16:23 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-22 00:16:23 +0000
commit4c5bd80830992553e02f099442277e10ee97372d (patch)
treebeeb8ff1f9d6f5b48418cc2134cec247aaade4e4 /dev-python/pyside6-tools
parentdb653baf275126269bb89ea0d2bdb8e50497a94c (diff)
gentoo auto-resync : 22:02:2025 - 00:16:22
Diffstat (limited to 'dev-python/pyside6-tools')
-rw-r--r--dev-python/pyside6-tools/Manifest3
-rw-r--r--dev-python/pyside6-tools/metadata.xml15
-rw-r--r--dev-python/pyside6-tools/pyside6-tools-6.8.1.1.ebuild80
3 files changed, 0 insertions, 98 deletions
diff --git a/dev-python/pyside6-tools/Manifest b/dev-python/pyside6-tools/Manifest
deleted file mode 100644
index 937acf48985d..000000000000
--- a/dev-python/pyside6-tools/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST pyside-pyside-setup-6.8.1.1.gh.tar.gz 18699613 BLAKE2B 2c16f305a746106edc770c267900b31fe480b167a615adc82496e0604cc618982bb787a0c173b069c258749364d7d2cac900d8d8b82244fc3b916744b7339537 SHA512 bd258be6e4c5f0b6b4bbdf8887e5f8ab16a90117deb00f9c46c4acb7f6bbcc36fb9f6b6e7c201403556e0ee269947a5f5b2611ff1b05e48f231f81b1eeac7bce
-EBUILD pyside6-tools-6.8.1.1.ebuild 1886 BLAKE2B 4121a04f4e1cc343006ff9224fa24e818c163f82c9f0f5c669dc21b81e69e2ee86dd05d7d68368267eb3f0914858332cba2ee656054c42ff8cd0dcd684d85a2a SHA512 e050ca61a5a945645014293884952027959ae2807b71ef1a4194545d67e5c63b83304ce7974f690e4d72171ef5a826e319b6de835fe2dcbccbb65af9d9ea11d7
-MISC metadata.xml 483 BLAKE2B 785ec6695ce4cb4592d4db9f16f59fcba9cd048792cceb1dcd42176d69283970c2eab379fb9c35a54379c93cd530c26d4c5a2369d117fe7a410820f241d23813 SHA512 db6a02d19b70d71640367eae23b15ab67798cb3e960c0cbd59429d05c45b50466502c96bf610f0716aadb4ac47c01357cc0976bbd0103e201069976cfd1d2609
diff --git a/dev-python/pyside6-tools/metadata.xml b/dev-python/pyside6-tools/metadata.xml
deleted file mode 100644
index 9ede7ac09c48..000000000000
--- a/dev-python/pyside6-tools/metadata.xml
+++ /dev/null
@@ -1,15 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person" proxied="proxy">
- <email>nowa@gentoo.org</email>
- <name>Nowa Ammerlaan</name>
- </maintainer>
- <maintainer type="person" proxied="yes">
- <email>waebbl-gentoo@posteo.net</email>
- <name>Bernd Waibel</name>
- </maintainer>
- <upstream>
- <remote-id type="github">qtproject/pyside-pyside-setup</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/pyside6-tools/pyside6-tools-6.8.1.1.ebuild b/dev-python/pyside6-tools/pyside6-tools-6.8.1.1.ebuild
deleted file mode 100644
index 45435d0e5d3f..000000000000
--- a/dev-python/pyside6-tools/pyside6-tools-6.8.1.1.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2025 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# TODO: Add PyPy once officially supported. See also:
-# https://bugreports.qt.io/browse/PYSIDE-535
-PYTHON_COMPAT=( python3_{10..13} )
-LLVM_COMPAT=( {16..18} )
-
-inherit cmake llvm-r1 python-r1
-
-MY_PN=pyside-pyside-setup
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="PySide development tools (pyside6-lupdate with support for Python)"
-HOMEPAGE="https://wiki.qt.io/PySide6"
-SRC_URI="https://github.com/qtproject/${MY_PN}/archive/refs/tags/v${PV}.tar.gz -> ${MY_P}.gh.tar.gz"
-S="${WORKDIR}/${MY_P}/sources/pyside-tools"
-
-LICENSE="GPL-2"
-SLOT="6/${PV}"
-KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv ~x86"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-# Minimal supported version of Qt.
-QT_PV="$(ver_cut 1-3)*:6"
-
-RDEPEND="${PYTHON_DEPS}
- ~dev-python/shiboken6-${PV}[${PYTHON_USEDEP},${LLVM_USEDEP}]
- ~dev-python/pyside-${PV}[quick,${PYTHON_USEDEP},${LLVM_USEDEP}]
- !dev-python/pyside6-tools:0
-"
-DEPEND="${RDEPEND}
- $(llvm_gen_dep '
- llvm-core/clang:${LLVM_SLOT}
- llvm-core/llvm:${LLVM_SLOT}
- ')
-"
-
-src_prepare() {
- cmake_src_prepare
-
- python_copy_sources
-}
-
-src_configure() {
- pyside-tools_configure() {
- local mycmakeargs=(
- # If this is enabled cmake just makes copies of /lib64/qt6/bin/*
- -DNO_QT_TOOLS=yes
- )
- cmake_src_configure
- }
-
- python_foreach_impl pyside-tools_configure
-}
-
-src_compile() {
- pyside-tools_compile() {
- cmake_src_compile
- }
-
- python_foreach_impl pyside-tools_compile
-}
-
-src_install() {
- pyside-tools_install() {
- # This replicates the contents of the PySide6 pypi wheel
- DESTDIR="${BUILD_DIR}" cmake_build install
- cp __init__.py "${BUILD_DIR}/usr/bin" || die
- rm -r "${BUILD_DIR}/usr/bin/qtpy2cpp_lib/tests" || die
- python_moduleinto PySide6/scripts
- python_domodule "${BUILD_DIR}/usr/bin/."
- }
-
- python_foreach_impl pyside-tools_install
-
- einstalldocs
-}