summaryrefslogtreecommitdiff
path: root/dev-python/pyside2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-27 15:10:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-27 15:10:20 +0100
commitc268590c556cb766e1ca3f55fde8a40cdde19c44 (patch)
tree7ebbcf748f02d29ba96741221f2e1919db85cdf9 /dev-python/pyside2
parent2be230a2a252e8e744f11a8b38e9a0097ddc9b25 (diff)
gentoo auto-resync : 27:09:2022 - 15:10:20
Diffstat (limited to 'dev-python/pyside2')
-rw-r--r--dev-python/pyside2/Manifest2
-rw-r--r--dev-python/pyside2/pyside2-5.15.6.ebuild224
2 files changed, 226 insertions, 0 deletions
diff --git a/dev-python/pyside2/Manifest b/dev-python/pyside2/Manifest
index 6fcb9e7aeb3c..f62839b194d1 100644
--- a/dev-python/pyside2/Manifest
+++ b/dev-python/pyside2/Manifest
@@ -2,5 +2,7 @@ AUX pyside2-5.15.2-python310.patch 508 BLAKE2B bdfc33975d1dd0c9eb73d1bae3ec2aff8
AUX pyside2-5.15.2-python311-fixups.patch 1962 BLAKE2B 37d91352ea09eaef6d36c600165e4fea74145b0fa05620e739254d3983acc501455154fc51ce3448aa4f60a00cd377f0896cb3dc14f1a921d6948dc53c500784 SHA512 39e999c80ed2717eaf59b47c12e64208d1b54d3d61daacf7a8ebeb4586f3b7312dd5db3fc53d4d2f3c426d80729e5d655e9b612153c704b40b7d261ddd57e580
AUX pyside2-5.15.2-python311.patch 1777 BLAKE2B 1afa7c39755c4f91b4b4c951f59e1a3190f924d8b20cf2140ad5342c2fa046ff7e6bec540bea9d7652116894e0cb7f5fa5ea73067212ca5b631382e7139d7786 SHA512 b88f300e4944cbb9adc8ac887e263e74e088a1b291000c86f6677a01241939e612fa5eebba3807fb2318477e68de241914832cc92ed0470726804d3098486120
DIST pyside-setup-opensource-src-5.15.5.tar.xz 3577972 BLAKE2B ee16ce18ec4103add41ad89b658012cb2e8695bda51269d3cd1614c2b6d029c0eaba5e592d5e58b6267e1ddc020a938d3ccd2fbc9461cc5bf202f3bdbf6b5d62 SHA512 61b987ec823e9a89f2a07a1991d47f36eb45e3ce416aa6e0032a58ba3d623ac26224cb0f43a2db76850bce7290d12fae610de06405350362caac7860ba99f0c3
+DIST pyside-setup-opensource-src-5.15.6.tar.xz 3580388 BLAKE2B 8a3b15d073bcbb0c6734f500ca906e56387cb8fc4bfcfd996304d71b54edd5f4568976049519ed26aa718bee9e43f59a0c4ef53837d5a341219b991a8527a800 SHA512 99a0c1a05e722cbf33128cf25742e61b92e151fdc05b79db9bafe778e024a0c6fc2886ee3d0b923ff681c55916f5c0eea4197f174432587fd662fba4390b26f4
EBUILD pyside2-5.15.5.ebuild 9114 BLAKE2B acf0acd94e58949465895e7771fc771aed19dcb3dd4d319e575c8c2edf3820a7aea4b1793fb3627e26593e27a7d36ebe571d372f6e5e78670f49aac9fd609180 SHA512 ecb43e1bd5b621c3fe4d2db0b21b7ff7650bea5cc38e579527eda8ce3a59dffabb25e56a2424c0d0e3533d6e501c9f7af48aed7f15977abf179856445e4bb6b8
+EBUILD pyside2-5.15.6.ebuild 9117 BLAKE2B c33aee0626590a1d211a150cc00921898f4f52a16e3e335850978ba68ff1b88e53a38e9b3cd806501af4cd3f6b9eabf3be1161ade01225a46594dbedb1e6857f SHA512 0c82bd415a44a691b6f053903aca03ed0b6a67e0b8add3d4e151e30c7d629711aba6e708030ea43b914c8811892b25f0a84f25fda7b7e370e2264deb3cec1fb6
MISC metadata.xml 2255 BLAKE2B 00982d17109b327ce063f5ba53474603cc73ffb013268ec9f6b751a73792a790f56de285291e70ad12147c27ba97b516be1318df312483d67d72509f8e8d8655 SHA512 830f9510f5e141422cbbab356d34a34b631f948eea14bcc96badbef65ce10f56c648748edc4ddf06be77b1c597a7d12d4552bde122937eb4cda01b304a3193c7
diff --git a/dev-python/pyside2/pyside2-5.15.6.ebuild b/dev-python/pyside2/pyside2-5.15.6.ebuild
new file mode 100644
index 000000000000..4959c6c0e286
--- /dev/null
+++ b/dev-python/pyside2/pyside2-5.15.6.ebuild
@@ -0,0 +1,224 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# TODO: Add PyPy once officially supported. See also:
+# https://bugreports.qt.io/browse/PYSIDE-535
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit cmake python-r1 virtualx
+
+# TODO: Add conditional support for "QtRemoteObjects" via a new "remoteobjects"
+# USE flag after an external "dev-qt/qtremoteobjects" package has been created.
+# TODO: Add conditional support for apidoc generation via a new "doc" USE flag.
+# Note that doing so requires the Qt source tree, sphinx, and graphviz. Once
+# ready, pass the ${QT_SRC_DIR} variable to cmake to enable this support.
+# TODO: Disable GLES support if the "gles2-only" USE flag is disabled. Note
+# that the "PySide2/QtGui/CMakeLists.txt" and
+# "PySide2/QtOpenGLFunctions/CMakeLists.txt" files test for GLES support by
+# testing whether the "Qt5::Gui" list property defined by
+# "/usr/lib64/cmake/Qt5Gui/Qt5GuiConfig.cmake" at "dev-qt/qtgui" installation
+# time contains the substring "opengles2". Since cmake does not permit
+# properties to be overridden from the command line, these files must instead
+# be conditionally patched to avoid these tests. An issue should be filed with
+# upstream requesting a CLI-settable variable to control this.
+
+MY_P=pyside-setup-opensource-src-${PV}
+
+DESCRIPTION="Python bindings for the Qt framework"
+HOMEPAGE="https://wiki.qt.io/PySide2"
+SRC_URI="https://download.qt.io/official_releases/QtForPython/pyside2/PySide2-${PV}-src/${MY_P}.tar.xz"
+S="${WORKDIR}/${MY_P}/sources/pyside2"
+
+# See "sources/pyside2/PySide2/licensecomment.txt" for licensing details.
+# Shall we allow essential modules to be disabled? They are:
+# (core), gui, widgets, printsupport, sql, network, testlib, concurrent,
+# x11extras (for X)
+LICENSE="|| ( GPL-2 GPL-3+ LGPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="
+ 3d charts +concurrent datavis designer gles2-only +gui help location
+ multimedia +network positioning +printsupport qml quick script scripttools
+ scxml sensors speech +sql svg test +testlib webchannel webengine websockets
+ +widgets +x11extras xml xmlpatterns
+"
+
+# Manually reextract these requirements on version bumps by running the
+# following one-liner from within "${S}":
+# $ grep 'set.*_deps' PySide2/Qt*/CMakeLists.txt
+# Note that the "designer" USE flag corresponds to the "Qt5UiTools" module.
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ 3d? ( gui network )
+ charts? ( gui widgets )
+ datavis? ( gui )
+ designer? ( widgets xml )
+ gles2-only? ( gui )
+ help? ( widgets )
+ location? ( positioning )
+ multimedia? ( gui network widgets )
+ printsupport? ( widgets )
+ qml? ( gui network )
+ quick? ( gui network qml widgets )
+ scripttools? ( gui script widgets )
+ speech? ( multimedia )
+ sql? ( widgets )
+ svg? ( widgets )
+ testlib? ( widgets )
+ webengine? (
+ network
+ widgets? ( gui printsupport webchannel )
+ )
+ websockets? ( network )
+ widgets? ( gui )
+ x11extras? ( gui )
+"
+
+# Tests fail pretty bad and I'm not fixing them right now
+RESTRICT="test"
+
+# Minimal supported version of Qt.
+QT_PV="$(ver_cut 1-2):5"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-python/shiboken2-${PV}[${PYTHON_USEDEP}]
+ dev-qt/qtcore:5
+ dev-qt/qtopengl:5[gles2-only=]
+ dev-qt/qtserialport:5
+ 3d? ( >=dev-qt/qt3d-${QT_PV}[qml?,gles2-only=] )
+ charts? ( >=dev-qt/qtcharts-${QT_PV}[qml?] )
+ concurrent? ( >=dev-qt/qtconcurrent-${QT_PV} )
+ datavis? ( >=dev-qt/qtdatavis3d-${QT_PV}[qml?,gles2-only=] )
+ designer? ( >=dev-qt/designer-${QT_PV} )
+ gui? ( >=dev-qt/qtgui-${QT_PV}[jpeg,gles2-only=] )
+ help? ( >=dev-qt/qthelp-${QT_PV} )
+ location? ( >=dev-qt/qtlocation-${QT_PV} )
+ multimedia? ( >=dev-qt/qtmultimedia-${QT_PV}[qml?,gles2-only=,widgets?] )
+ network? ( >=dev-qt/qtnetwork-${QT_PV} )
+ positioning? ( >=dev-qt/qtpositioning-${QT_PV}[qml?] )
+ printsupport? ( >=dev-qt/qtprintsupport-${QT_PV}[gles2-only=] )
+ qml? ( >=dev-qt/qtdeclarative-${QT_PV}[widgets?] )
+ quick? (
+ >=dev-qt/qtdeclarative-${QT_PV}[widgets?]
+ >=dev-qt/qtquickcontrols2-${QT_PV}[widgets?]
+ )
+ script? ( >=dev-qt/qtscript-${QT_PV}[scripttools?] )
+ scxml? ( >=dev-qt/qtscxml-${QT_PV} )
+ sensors? ( >=dev-qt/qtsensors-${QT_PV}[qml?] )
+ speech? ( >=dev-qt/qtspeech-${QT_PV} )
+ sql? ( >=dev-qt/qtsql-${QT_PV} )
+ svg? ( >=dev-qt/qtsvg-${QT_PV} )
+ testlib? ( >=dev-qt/qttest-${QT_PV} )
+ webchannel? ( >=dev-qt/qtwebchannel-${QT_PV}[qml] )
+ webengine? ( >=dev-qt/qtwebengine-${QT_PV}[widgets?] )
+ websockets? ( >=dev-qt/qtwebsockets-${QT_PV}[qml?] )
+ widgets? ( >=dev-qt/qtwidgets-${QT_PV}[gles2-only=] )
+ x11extras? ( >=dev-qt/qtx11extras-${QT_PV} )
+ xml? ( >=dev-qt/qtxml-${QT_PV} )
+ xmlpatterns? ( >=dev-qt/qtxmlpatterns-${QT_PV}[qml?] )
+"
+DEPEND="${RDEPEND}
+ test? ( x11-misc/xvfb-run )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-5.15.2-python310.patch"
+ "${FILESDIR}/${PN}-5.15.2-python311.patch"
+ "${FILESDIR}/${PN}-5.15.2-python311-fixups.patch"
+)
+
+src_configure() {
+ # See COLLECT_MODULE_IF_FOUND macros in CMakeLists.txt
+ local mycmakeargs=(
+ -DBUILD_TESTS=$(usex test)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt53DAnimation=$(usex !3d)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt53DCore=$(usex !3d)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt53DExtras=$(usex !3d)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt53DInput=$(usex !3d)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt53DLogic=$(usex !3d)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt53DRender=$(usex !3d)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Charts=$(usex !charts)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Concurrent=$(usex !concurrent)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt5DataVisualization=$(usex !datavis)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Designer=$(usex !designer)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Gui=$(usex !gui)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Help=$(usex !help)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Location=$(usex !location)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Multimedia=$(usex !multimedia)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt5MultimediaWidgets=$(usex !multimedia yes $(usex !widgets))
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Network=$(usex !network)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Positioning=$(usex !positioning)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt5PrintSupport=$(usex !printsupport)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Qml=$(usex !qml)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Quick=$(usex !quick)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt5QuickControls2=$(usex !quick)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt5QuickWidgets=$(usex !quick yes $(usex !widgets))
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Script=$(usex !script)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt5ScriptTools=$(usex !scripttools)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Scxml=$(usex !scxml)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Sensors=$(usex !sensors)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt5TextToSpeech=$(usex !speech)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Sql=$(usex !sql)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Svg=$(usex !svg)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Test=$(usex !testlib)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt5UiTools=$(usex !designer)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt5WebChannel=$(usex !webchannel)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt5WebEngine=$(usex !webengine)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt5WebEngineCore=$(usex !webengine)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt5WebEngineWidgets=$(usex !webengine yes $(usex !widgets))
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt5WebSockets=$(usex !websockets)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Widgets=$(usex !widgets)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt5X11Extras=$(usex !x11extras)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt5Xml=$(usex !xml)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt5XmlPatterns=$(usex !xmlpatterns)
+ )
+
+ pyside2_configure() {
+ local mycmakeargs=(
+ "${mycmakeargs[@]}"
+ -DPYTHON_CONFIG_SUFFIX="-${EPYTHON}"
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ -DPYTHON_SITE_PACKAGES="$(python_get_sitedir)"
+ -DSHIBOKEN_PYTHON_SHARED_LIBRARY_SUFFIX="-${EPYTHON}"
+ )
+ cmake_src_configure
+ }
+ python_foreach_impl pyside2_configure
+}
+
+src_compile() {
+ python_foreach_impl cmake_src_compile
+}
+
+src_test() {
+ local -x PYTHONDONTWRITEBYTECODE
+ python_foreach_impl virtx cmake_src_test
+}
+
+src_install() {
+ pyside2_install() {
+ cmake_src_install
+ python_optimize
+
+ # Uniquify the shiboken2 pkgconfig dependency in the PySide2 pkgconfig
+ # file for the current Python target. See also:
+ # https://github.com/leycec/raiagent/issues/73
+ sed -i -e 's~^Requires: shiboken2$~&-'${EPYTHON}'~' \
+ "${ED}/usr/$(get_libdir)"/pkgconfig/${PN}.pc || die
+
+ # Uniquify the PySide2 pkgconfig file for the current Python target,
+ # preserving an unversioned "pyside2.pc" file arbitrarily associated
+ # with the last Python target. (See the previously linked issue.)
+ cp "${ED}/usr/$(get_libdir)"/pkgconfig/${PN}{,-${EPYTHON}}.pc || die
+ }
+ python_foreach_impl pyside2_install
+
+ # CMakeLists.txt installs a "PySide2Targets-gentoo.cmake" file forcing
+ # downstream consumers (e.g., pyside2-tools) to target one
+ # "libpyside2-*.so" library linked to one Python interpreter. See also:
+ # https://bugreports.qt.io/browse/PYSIDE-1053
+ # https://github.com/leycec/raiagent/issues/74
+ sed -i -e 's~pyside2-python[[:digit:]]\+\.[[:digit:]]\+~pyside2${PYTHON_CONFIG_SUFFIX}~g' \
+ "${ED}/usr/$(get_libdir)/cmake/PySide2-${PV}/PySide2Targets-${CMAKE_BUILD_TYPE,,}.cmake" || die
+}