summaryrefslogtreecommitdiff
path: root/dev-python/pyshark
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
commiteccb70a7f91b2d22582587f26d1a28bb31408b45 (patch)
tree3223e1fd54201bcf4ebecac6fbe87361cbe643e2 /dev-python/pyshark
parenta2810985afabcc31d3eace5e61d8ea25b852ba17 (diff)
gentoo resync : 18.05.2019
Diffstat (limited to 'dev-python/pyshark')
-rw-r--r--dev-python/pyshark/Manifest4
-rw-r--r--dev-python/pyshark/pyshark-0.3.7.2-r1.ebuild (renamed from dev-python/pyshark/pyshark-0.3.7.2.ebuild)2
-rw-r--r--dev-python/pyshark/pyshark-0.4.2.3.ebuild49
3 files changed, 53 insertions, 2 deletions
diff --git a/dev-python/pyshark/Manifest b/dev-python/pyshark/Manifest
index 8b9e1dd78eb1..1617c26eb08e 100644
--- a/dev-python/pyshark/Manifest
+++ b/dev-python/pyshark/Manifest
@@ -1,3 +1,5 @@
DIST pyshark-0.3.7.2.tar.gz 27232 BLAKE2B b93ee24fb29990b0ab455935e773e4844c26761c2515d1254c8e72d24d70be95aa17a590cc1f5b39bb5f76db624fb7c40d06e64731948ee75a5b8e2008830968 SHA512 dbd97665fae7d3067582bf7616e025b0c5e5fa14cacdaca59c89b4e70feb3017f2d8c7d899a70c0c8707589e4735b9283914bb6ccbf432e9072c64d7e957bc15
-EBUILD pyshark-0.3.7.2.ebuild 1252 BLAKE2B ce89faace2871ae899004f63bf901dda8094ec691527ee9aef3036d798c050804c1801574fce7774cac2394726f5c170f530a77c89256595a7833de940932cf9 SHA512 79a3455bf95a21ad43879980fcf3d428cea059e202208e2d658ab45f5ddea2af780bf35961ace65a5a84399f3db9d0de0954f4887ac021aa7596da5fbf61b5da
+DIST pyshark-0.4.2.3.tar.gz 29363 BLAKE2B 91463f725eb893c3c7f7442eec5e0a8304bb8f2ecbd0ea80582c49bfd8538a5fcdb1d5d1ab2373f8e67684c78c8852af697dadf8ff041d42f8ff18a8954a6248 SHA512 bbef857dad5e5141e0ec7c04dba9faca81b17d67a7151959e9935577428cd1415e173e9c7ededff46f8621bcbbdfbe7a96ca5cfd65d7143fb6f235c0167964b6
+EBUILD pyshark-0.3.7.2-r1.ebuild 1260 BLAKE2B b04a56e9be00e69efc4b9d5f81d3489228c80751d7d76f79740c1dead7e68c248d05ee804694b348b0e6078612d61ede5c7c2668a07fe87ee590a2ac26ffedf8 SHA512 99750ec58a54b8406d71e9cfda2c5cc215720d8459ba59de6b1976439ad2e69808f035fa8a2f3c2a819a86faeaf01fede0f25b284875fdcb0415e232b8f28c89
+EBUILD pyshark-0.4.2.3.ebuild 1254 BLAKE2B af7967d5505ff0868095d3b42a07c6ed98eee807d64f1bb46d4124e7cd60fa633a4b956648340389981cb3d4771ad10e4c7974562b87fc33a891e7efdc7040a6 SHA512 ca662e1ffe01335bd11863de673321076690993096a5497614f319204e316ce40e78c8b97d8f0b8f4552bdf25f8188a437810b0d407fc80c031fa2709cde61ab
MISC metadata.xml 378 BLAKE2B b5d298f634ff4c3ef0921697ba6ad85d6704effd115e130075507d4ab5e7cfefcd3db393f044f1607dfc6b6442363c58b9ac693281334bc981c3462c0f1a775d SHA512 17d2661a631633ebf347dfc4def34aa070c4ad5713f6124b668c3ed5336a59b639c30474e4b4cb294661648ef186797144c161a390c0d93a21de82ae8d51d8c7
diff --git a/dev-python/pyshark/pyshark-0.3.7.2.ebuild b/dev-python/pyshark/pyshark-0.3.7.2-r1.ebuild
index a2ebdaf0d066..761cfea65af2 100644
--- a/dev-python/pyshark/pyshark-0.3.7.2.ebuild
+++ b/dev-python/pyshark/pyshark-0.3.7.2-r1.ebuild
@@ -25,7 +25,7 @@ RDEPEND="
dev-python/lxml[${PYTHON_USEDEP}]
dev-python/trollius[${PYTHON_USEDEP}]
virtual/python-futures[${PYTHON_USEDEP}]
- net-analyzer/wireshark"
+ net-analyzer/wireshark[tshark]"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
diff --git a/dev-python/pyshark/pyshark-0.4.2.3.ebuild b/dev-python/pyshark/pyshark-0.4.2.3.ebuild
new file mode 100644
index 000000000000..5e6234567d6c
--- /dev/null
+++ b/dev-python/pyshark/pyshark-0.4.2.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{5,6} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A Python wrapper for tshark output parsing"
+HOMEPAGE="https://pypi.org/project/pyshark/ https://github.com/KimiNewt/pyshark"
+# pypi tarball is missing tests
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/KimiNewt/pyshark/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# See pyshark.egg-info/requires.txt
+RDEPEND="
+ dev-python/py[${PYTHON_USEDEP}]
+ dev-python/logbook[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/trollius[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+ net-analyzer/wireshark[tshark]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${P}/src"
+
+python_prepare_all() {
+ # Test fails unless portage can execute /usr/bin/dumpcap
+ # https://github.com/KimiNewt/pyshark/issues/197
+ rm "${WORKDIR}/${P}/tests/capture/test_inmem_capture.py" || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cd "${WORKDIR}/${P}/tests" || die
+ py.test -v || die
+}