summaryrefslogtreecommitdiff
path: root/dev-python/pyshark
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pyshark
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pyshark')
-rw-r--r--dev-python/pyshark/Manifest3
-rw-r--r--dev-python/pyshark/metadata.xml12
-rw-r--r--dev-python/pyshark/pyshark-0.3.7.2.ebuild49
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/pyshark/Manifest b/dev-python/pyshark/Manifest
new file mode 100644
index 000000000000..e36dc2ced54b
--- /dev/null
+++ b/dev-python/pyshark/Manifest
@@ -0,0 +1,3 @@
+DIST pyshark-0.3.7.2.tar.gz 27232 BLAKE2B b93ee24fb29990b0ab455935e773e4844c26761c2515d1254c8e72d24d70be95aa17a590cc1f5b39bb5f76db624fb7c40d06e64731948ee75a5b8e2008830968 SHA512 dbd97665fae7d3067582bf7616e025b0c5e5fa14cacdaca59c89b4e70feb3017f2d8c7d899a70c0c8707589e4735b9283914bb6ccbf432e9072c64d7e957bc15
+EBUILD pyshark-0.3.7.2.ebuild 1259 BLAKE2B 76643ad6042d7a3bf46f10afbfe44583339ff0e94550aa3d7a3a2638fe742e907ef69a08ccc748de98663cd0f0e98e8b4b684abb21b6bfda0b781c74cc486735 SHA512 85480efcb9644c1e24bfbf241d7218968b627bd3b078479eb8a0284e5bbbca4b29d5cee7eb2c551860a8296580eda525162e1ff68a5e1ca1cccb41cd88ecdbb7
+MISC metadata.xml 378 BLAKE2B b5d298f634ff4c3ef0921697ba6ad85d6704effd115e130075507d4ab5e7cfefcd3db393f044f1607dfc6b6442363c58b9ac693281334bc981c3462c0f1a775d SHA512 17d2661a631633ebf347dfc4def34aa070c4ad5713f6124b668c3ed5336a59b639c30474e4b4cb294661648ef186797144c161a390c0d93a21de82ae8d51d8c7
diff --git a/dev-python/pyshark/metadata.xml b/dev-python/pyshark/metadata.xml
new file mode 100644
index 000000000000..667dc8a5fb8b
--- /dev/null
+++ b/dev-python/pyshark/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pyshark</remote-id>
+ <remote-id type="github">KimiNewt/pyshark</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyshark/pyshark-0.3.7.2.ebuild b/dev-python/pyshark/pyshark-0.3.7.2.ebuild
new file mode 100644
index 000000000000..ba7ed02e4c9c
--- /dev/null
+++ b/dev-python/pyshark/pyshark-0.3.7.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A Python wrapper for tshark output parsing"
+HOMEPAGE="https://pypi.org/project/pyshark/ https://github.com/KimiNewt/pyshark"
+# pypi tarball is missing tests
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/KimiNewt/pyshark/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# See pyshark.egg-info/requires.txt
+RDEPEND="
+ dev-python/py[${PYTHON_USEDEP}]
+ dev-python/logbook[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/trollius[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+ net-analyzer/wireshark"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${P}/src"
+
+python_prepare_all() {
+ # Test fails unless portage can execute /usr/bin/dumpcap
+ # https://github.com/KimiNewt/pyshark/issues/197
+ rm "${WORKDIR}/${P}/tests/capture/test_inmem_capture.py" || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cd "${WORKDIR}/${P}/tests" || die
+ py.test -v || die
+}