summaryrefslogtreecommitdiff
path: root/dev-python/pysha3
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pysha3
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pysha3')
-rw-r--r--dev-python/pysha3/Manifest3
-rw-r--r--dev-python/pysha3/metadata.xml15
-rw-r--r--dev-python/pysha3/pysha3-1.0.2-r1.ebuild32
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/pysha3/Manifest b/dev-python/pysha3/Manifest
new file mode 100644
index 000000000000..d1f00f2ac8fc
--- /dev/null
+++ b/dev-python/pysha3/Manifest
@@ -0,0 +1,3 @@
+DIST pysha3-1.0.2.tar.gz 829192 BLAKE2B ff0c0e1cc35f5e2efc0a7d3074022aaa1e05fa72cc151560180fe08958c8f83ec2b0f50f9e1bf772fd386647f3d44e8b4139f5593f6d0d678412eabe4829e939 SHA512 57476d24b9d399471cf56c8c1413f58dbc863c16d4fe9ebd2cf65df8092e139e2505252605e3fccd68978f5ee3fffdfeeedee6788aab38a54c918a452fc19720
+EBUILD pysha3-1.0.2-r1.ebuild 1015 BLAKE2B 1bcec331184664cad1e43d1b175851dcad6c5c71d2d194706db0827d1054ab397548efa235de531fbefaebbbaf70a943f0c38211af1e794dd1c0906420ed48d7 SHA512 2cd6ee494cdbc2cf92e422ba0d0910ec480b933dde998e53d36a5590beffc23cbd214105e78dbf54267e622ce09cac45fb9825b8a0b65639aca2d88dae96aca7
+MISC metadata.xml 447 BLAKE2B b29243faa53b7068fce5b86ff8ffeaef920340c92bee35620fb2977b02a1f543fb6cfbd5509fbe784753d9e1b123bb1ed594dfd59e2ba611b9ce0e1df6319174 SHA512 e29bf7eb65b03e9190be49df6e924da2e8a6d30eb74bad5cd5b3551df5184c720c9666a11c0cf4afe4626a3d433edd0989507583d97aa24cf5b8bb9ffb535b9d
diff --git a/dev-python/pysha3/metadata.xml b/dev-python/pysha3/metadata.xml
new file mode 100644
index 000000000000..410617d33dce
--- /dev/null
+++ b/dev-python/pysha3/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tiran/pysha3</remote-id>
+ <remote-id type="pypi">pysha3</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pysha3/pysha3-1.0.2-r1.ebuild b/dev-python/pysha3/pysha3-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..f73124da954d
--- /dev/null
+++ b/dev-python/pysha3/pysha3-1.0.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+inherit distutils-r1
+
+DESCRIPTION="SHA-3 (Keccak) for Python 2.7 - 3.5"
+HOMEPAGE="https://github.com/tiran/pysha3 https://pypi.org/project/pysha3/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="CC0-1.0 PSF-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sparc x86 ~x64-cygwin ~amd64-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ # Remove meaningless AttributeError checks. They don't really test
+ # the implementation but Python implementation behavior, and they
+ # fail with PyPy. Oh yes, and this doesn't affect correctly written
+ # programs.
+ sed -i -e '/AttributeError/d' tests.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+}