summaryrefslogtreecommitdiff
path: root/dev-python/pysha3
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-31 20:30:04 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-31 20:30:04 +0000
commit4650985dd0e898b82e0d2ec225931297d4fadccf (patch)
treeeb0e8002cf3ebf1009110b6fec47fa90f873d824 /dev-python/pysha3
parent67f76a858f1ac826bd8a550d756d9ec6e340ed4f (diff)
gentoo resync : 31.01.2018
Diffstat (limited to 'dev-python/pysha3')
-rw-r--r--dev-python/pysha3/Manifest1
-rw-r--r--dev-python/pysha3/pysha3-1.0.2-r1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pysha3/Manifest b/dev-python/pysha3/Manifest
index 8729a521f937..8fb02e5a62af 100644
--- a/dev-python/pysha3/Manifest
+++ b/dev-python/pysha3/Manifest
@@ -1,3 +1,4 @@
DIST pysha3-1.0.2.tar.gz 829192 BLAKE2B ff0c0e1cc35f5e2efc0a7d3074022aaa1e05fa72cc151560180fe08958c8f83ec2b0f50f9e1bf772fd386647f3d44e8b4139f5593f6d0d678412eabe4829e939 SHA512 57476d24b9d399471cf56c8c1413f58dbc863c16d4fe9ebd2cf65df8092e139e2505252605e3fccd68978f5ee3fffdfeeedee6788aab38a54c918a452fc19720
+EBUILD pysha3-1.0.2-r1.ebuild 999 BLAKE2B 911d7f4b142921c6989c7ad7d1d82c1dfe7c72527df04045054e9cbc7e063178f9eb5b07a96084501850aab024a1f855864c7b852d8f1c7b2647a23edb256081 SHA512 cda1b7bb745ba1a17bf32f34953f262b8e414f39eec14af39c408ecbe7b0b7f038d8c2beb17687f26e0708ed2eb13be4fdafb00358db2c60f5b2545f0324b536
EBUILD pysha3-1.0.2.ebuild 670 BLAKE2B 63824f1f7e6627ad0af8d413df4dce5c5cd54d5b9dca196f22bdd6ec884368c06b69076fdb579cf3f53ef8af6d79cc92ff1e26ca986e011751d4969aea46690e SHA512 97caa72029014f15540d6e398f299a0605cdc65eb6835246634f60020c0b4772fdf3fb2c7f8c89be4f2164414410ed7012cfd73c58adca4711c8fe02183e5a33
MISC metadata.xml 447 BLAKE2B b29243faa53b7068fce5b86ff8ffeaef920340c92bee35620fb2977b02a1f543fb6cfbd5509fbe784753d9e1b123bb1ed594dfd59e2ba611b9ce0e1df6319174 SHA512 e29bf7eb65b03e9190be49df6e924da2e8a6d30eb74bad5cd5b3551df5184c720c9666a11c0cf4afe4626a3d433edd0989507583d97aa24cf5b8bb9ffb535b9d
diff --git a/dev-python/pysha3/pysha3-1.0.2-r1.ebuild b/dev-python/pysha3/pysha3-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..2ce78133003c
--- /dev/null
+++ b/dev-python/pysha3/pysha3-1.0.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+inherit distutils-r1
+
+DESCRIPTION="SHA-3 (Keccak) for Python 2.7 - 3.5"
+HOMEPAGE="https://github.com/tiran/pysha3 https://pypi.python.org/pypi/pysha3"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="CC0-1.0 PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ # Remove meaningless AttributeError checks. They don't really test
+ # the implementation but Python implementation behavior, and they
+ # fail with PyPy. Oh yes, and this doesn't affect correctly written
+ # programs.
+ sed -i -e '/AttributeError/d' tests.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+}