summaryrefslogtreecommitdiff
path: root/dev-python/pysha3/pysha3-1.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-20 17:35:36 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-20 17:35:36 +0100
commitb620fb1b0929ff9657a2588aaa42b85e3021c102 (patch)
tree5c4e9e39b5d3ea7fc569c26b0d4ba6db582249e6 /dev-python/pysha3/pysha3-1.0.2.ebuild
parentd473a706836012853193afc7000922601e4ada61 (diff)
gentoo resync : 20.10.2017
Diffstat (limited to 'dev-python/pysha3/pysha3-1.0.2.ebuild')
-rw-r--r--dev-python/pysha3/pysha3-1.0.2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/pysha3/pysha3-1.0.2.ebuild b/dev-python/pysha3/pysha3-1.0.2.ebuild
new file mode 100644
index 000000000000..2f9172ea7855
--- /dev/null
+++ b/dev-python/pysha3/pysha3-1.0.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+inherit distutils-r1
+
+DESCRIPTION="SHA-3 (Keccak) for Python 2.7 - 3.5"
+HOMEPAGE="https://github.com/tiran/pysha3 https://pypi.python.org/pypi/pysha3"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="CC0-1.0 PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}