summaryrefslogtreecommitdiff
path: root/dev-python/pyserial
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/pyserial
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/pyserial')
-rw-r--r--dev-python/pyserial/Manifest3
-rw-r--r--dev-python/pyserial/pyserial-3.5-r1.ebuild34
-rw-r--r--dev-python/pyserial/pyserial-3.5.ebuild4
3 files changed, 38 insertions, 3 deletions
diff --git a/dev-python/pyserial/Manifest b/dev-python/pyserial/Manifest
index a50fe2416877..b8be9adb2801 100644
--- a/dev-python/pyserial/Manifest
+++ b/dev-python/pyserial/Manifest
@@ -1,3 +1,4 @@
DIST pyserial-3.5.tar.gz 159125 BLAKE2B 6be1930afc6cfecad54cd7a116a0e93085d166907acb4c2fa5b7b9485ec28cfb6dc9e7ffc13ae5628c344ef0f78c15bdd828b8d51048a484548538cf14b9da20 SHA512 c8df5e50d952d5a6dcf1d9253a6ba953e9763c545a867da66c22c90dfa015aba0194f2a8f29a229d0a5f4dc8bfeeaaab8bcfda4066ed78a18b151bc05e6ae327
-EBUILD pyserial-3.5.ebuild 833 BLAKE2B 4a041c5262d88f1807804edfa1205c1d7c16202ee8d7e00096888c43009e404f075104a296c0ea81d40fa2c6196d91f9728914bded1efa4667dc1a790a7a42df SHA512 c07b8cf00be8b4d084186b15fbd61d1926d1a8b75af77be3d3f88301f98c9e7d65e2225123c23b3752c257a8d8c4d53a97413c023d918c135a65173aa9d1af80
+EBUILD pyserial-3.5-r1.ebuild 880 BLAKE2B b67d09a93dc5746ff60197f475514008f64db9ed73df464e1592ce1681f8075b97adea89cdf7159e4e0c1512fe7bcd1f6a9501ddf9091ce969ea91760df19624 SHA512 adacd99fae2df609e2793e071bdb539130daa599ca53d5440f25bea3c5d6a5841236ed5b8c3814ab9b2b523c9ea9e647d6ae43f1c470cd7a5a4b50f2a6f8f7f7
+EBUILD pyserial-3.5.ebuild 839 BLAKE2B 28d6e30c3f319f61ebe5cdf70442bb181d2ed8c6e3a22f25545bcf4c807abcec39a1687ccc187f66397cd9b3d6dd9501fee939ad81a23966f882de5fe9be124f SHA512 dfa8f9bd87e7f8339b138e2ab526b4874610333acf9b1f52f5c514a60e3a274d3f02fbc5746c1cdc1874b57990550a0a60c9a6df3ae3ce95cd8de91ef30971f2
MISC metadata.xml 446 BLAKE2B 9242526e2474443c6bb0cc1849dcbd28ae0eaa6ce835b28c99059ef40b3bde19486e6bbc68793b1edffae5e12029b4cb613fe6446df11b976eb49c0ee6889ca4 SHA512 d05a16f86a16a3f6a7d53117f5497fdc9d792171fde7af865b3a126494794251b8b9feddb80e221f21ac66443a90b3ae9d4ea64fae24f1c27dd269299714ba2e
diff --git a/dev-python/pyserial/pyserial-3.5-r1.ebuild b/dev-python/pyserial/pyserial-3.5-r1.ebuild
new file mode 100644
index 000000000000..605d44552619
--- /dev/null
+++ b/dev-python/pyserial/pyserial-3.5-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Serial Port extension"
+HOMEPAGE="https://github.com/pyserial/pyserial https://pypi.org/project/pyserial/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="examples"
+
+DOCS=( CHANGES.rst README.rst )
+
+distutils_enable_sphinx documentation --no-autodoc
+
+python_test() {
+ "${EPYTHON}" test/run_all_tests.py loop:// -v || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-python/pyserial/pyserial-3.5.ebuild b/dev-python/pyserial/pyserial-3.5.ebuild
index e1edf4d0bc81..793b5b1df0be 100644
--- a/dev-python/pyserial/pyserial-3.5.ebuild
+++ b/dev-python/pyserial/pyserial-3.5.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..10} )
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
inherit distutils-r1
DESCRIPTION="Python Serial Port extension"