summaryrefslogtreecommitdiff
path: root/dev-python/pyserial
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-python/pyserial
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-python/pyserial')
-rw-r--r--dev-python/pyserial/Manifest2
-rw-r--r--dev-python/pyserial/pyserial-3.4.ebuild24
2 files changed, 9 insertions, 17 deletions
diff --git a/dev-python/pyserial/Manifest b/dev-python/pyserial/Manifest
index 47ee88a7c98b..d8074bccfa03 100644
--- a/dev-python/pyserial/Manifest
+++ b/dev-python/pyserial/Manifest
@@ -2,5 +2,5 @@ AUX mapping.patch 495 BLAKE2B f9a2493c2ed0f522000b2ddc774c931138adda0c7d6f8d5387
DIST pyserial-3.2.1.tar.gz 147338 BLAKE2B 6c377d1527183fc48e1369f206f409d312e4488bdb15ae1d1ed93249073ffc56529a9e6059ef57c8f2ebb867cb6d9c0b7dc3a74eafbf653463a05e603b25d69c SHA512 8d3e580cc7781fc6549ab6e408642f4321eb90aafbe593f5dcf953001730f89ee32ce6592728764027a7944bfe4a0ebe2cfac1fce071777aac7c4f27ac94ab7f
DIST pyserial-3.4.tar.gz 151657 BLAKE2B cf47aba4a6f3bb2fe39d99e72907496faa1c9f37857810fef4d826cca72c361d0e43dbc33d9cf2291a589bf0193d17355d149e6eb61b4f9e28250207708ef09a SHA512 d71dffc330704e41caac6054adf192bee2f1c119691faf2ea93fe22e8e3ba000dc4a1434293f6f80d05a5577d85b96791f656e28d5c63fb0ce6a6605467a117f
EBUILD pyserial-3.2.1.ebuild 1116 BLAKE2B 64d1776c61ee456c51cec28befce8530f06b102bb141abbb52c845df294b64bbd1347a379b1438d9ea5d74681b8e52262e57eebcff42067858d8d8873997e570 SHA512 2a5c8a98fc89aff6f46da8cd0145b59458e198dc7113f3cfd861ab0a8152a2fa9b1b87709a5a6ddc968b352c41acff98f0885ef9f25100c6cfa170d620c19be1
-EBUILD pyserial-3.4.ebuild 1129 BLAKE2B c4a78202a84eb383ff1fdbf43cb39cedac0760b3f5de8786a233531d425e15778d2769991360614087075eb16863630ae62b07f08e26f03f18fa7f38e1d47ff2 SHA512 d0e1e128cb8fcfe3a503b1a59822de58d6c3c45ca6b63eb93979520c57cd86c7cf02daaca9fd8b04b97d5ab4d0f96f6944a8338cd2d994fa757b9c60cd7f88dd
+EBUILD pyserial-3.4.ebuild 896 BLAKE2B 978df640318fee11594f305f6e70fb0a3775f6dfef11f99bbcf806ad11877d9e79fe4bbec1a81e89c90a47de64d3de52b7c5edaf2548e722b278b452b635f4c8 SHA512 83d816bce0f69d4e078dd0b112d58ad575fa1a782939650cf38a592edd00ca0d4d68fe5409fd25e646257f8aae716a6feb528e40ba121ee27a7b96fe9f2d6531
MISC metadata.xml 421 BLAKE2B f3c94b0b72c3df17d9c539e8b76e1f644e0b4ae1bb3d905652b568084e449bf11cab07f27e7775031eee857095671debd28bf1d2eb8c1992c6b980620b32109b SHA512 30c1232aed930c665c2603443cbff9efbb843b1866d6a4d034a517e0669f28f1e6e7562103a8badbd8fb1efd9e69b058870b9c4fcea8fa5e74e7a1ec8ba17fde
diff --git a/dev-python/pyserial/pyserial-3.4.ebuild b/dev-python/pyserial/pyserial-3.4.ebuild
index 42b285e7b178..35aaf81c6337 100644
--- a/dev-python/pyserial/pyserial-3.4.ebuild
+++ b/dev-python/pyserial/pyserial-3.4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy )
inherit distutils-r1
@@ -12,33 +12,25 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="PSF-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="doc examples"
+KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="examples"
-DEPEND="
+BDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
"
-# Usual avoid d'loading un-needed objects.inv file
-PATCHES=( "${FILESDIR}"/mapping.patch )
-
DOCS=( CHANGES.rst README.rst )
-python_compile_all() {
- use doc && emake -C documentation html
-}
+distutils_enable_sphinx documentation --no-autodoc
python_test() {
- ${EPYTHON} test/run_all_tests.py || die "Testing failed with ${EPYTHON}"
+ "${EPYTHON}" test/run_all_tests.py loop:// -v || die "Testing failed with ${EPYTHON}"
}
python_install_all() {
- use doc && local HTML_DOCS=( documentation/_build/html/. )
distutils-r1_python_install_all
if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
+ dodoc -r examples
docompress -x /usr/share/doc/${PF}/examples
fi
}