summaryrefslogtreecommitdiff
path: root/dev-python/pyscreenshot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-12 18:13:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-12 18:13:14 +0000
commitf1ced5f5f09c4d27185e6986a465f7bc3b828c65 (patch)
treebb4a65f6889f3cbcc2f8e5053b624f23291d7921 /dev-python/pyscreenshot
parent70d27c1344f6a6a51e11c610966542333b6f432a (diff)
gentoo auto-resync : 12:03:2023 - 18:13:14
Diffstat (limited to 'dev-python/pyscreenshot')
-rw-r--r--dev-python/pyscreenshot/Manifest2
-rw-r--r--dev-python/pyscreenshot/pyscreenshot-3.1.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/pyscreenshot/Manifest b/dev-python/pyscreenshot/Manifest
index d34e25e127c1..9ff8ef6fc21f 100644
--- a/dev-python/pyscreenshot/Manifest
+++ b/dev-python/pyscreenshot/Manifest
@@ -1,3 +1,5 @@
DIST pyscreenshot-3.0.tar.gz 32865 BLAKE2B b39d338be4f1dc23fc30fe84a6f8ee6b6346761b023222438e8ff33e01beafc347d34118332efb053057c54383f5468e73049041889a6140a70c0f928c655661 SHA512 f8070941ade2bc710157238f47c9575df1504ef63152980b2bc0edd1f69c9ca4aeec3f738929de1c81a51fed79838053674626981ec61d95dafa7b9998004606
+DIST pyscreenshot-3.1.gh.tar.gz 36860 BLAKE2B fff930ad784da3e800d7c85bba2ea03db8f91011083b437f31c0d62037df9fa8921f9572d2271c258bdafa5d4c0b9d3ff93a7b8ab53db2cc24373f971fb6dc54 SHA512 9cbb58ddf2248548fb8b3519b41646e6f00d635ddaac69cc20a41b57e8693466c2b93947d72cf3a0caa0ee20f9d42f70587079a919b1c1d156212d6f942285ee
EBUILD pyscreenshot-3.0-r1.ebuild 1023 BLAKE2B f499e273328929cb25dd204e9011afc2a265d658682470ce681b2c441c28b0cf1c86936ca1355b2f3b2f1809cad64d225ed2eada000d3d86867c4dccaa41a5cb SHA512 8b12e4f11de653426203e7c33177c9cf15f25190c881ebacff00235b4db0a092e39ee6bc6f20f9b2e90f350fe65302a07d132092f5e763906fc74989df85f6d0
+EBUILD pyscreenshot-3.1.ebuild 1250 BLAKE2B d8044dd002d1d98c483b52f60cf8d166acd6d94d74a54b7473420d7cf79e454d898d121ff08f8e5fd5120f4eb97d4a57ff4cd807e232deca846fb453b12994e7 SHA512 a6dda7017de6f33975184d41a5017878790131fbff226dc3472d7d9dc77e5d249c79ce1c4405219c13203df7a0ae691ffd1066e3764abfbb7203afc5260db096
MISC metadata.xml 517 BLAKE2B d76772ddeef8328b34da232460ea50b4d5028c4bb4a10249bc505d41260e2d99ddf6cd75b4c3a757d3184cf95a283f69cbef7823715848119c118cc6dbcecbbd SHA512 55968d60cdb0a300a5a733a3d1e1ae1ccaa828691cadf2c36cd0e4e7c56c665f16e3ab82c3c22e7d39419ae2e1ef1d83e754567b576d160bba1384ae0e3c820e
diff --git a/dev-python/pyscreenshot/pyscreenshot-3.1.ebuild b/dev-python/pyscreenshot/pyscreenshot-3.1.ebuild
new file mode 100644
index 000000000000..47b82756e769
--- /dev/null
+++ b/dev-python/pyscreenshot/pyscreenshot-3.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Python screenshot library"
+HOMEPAGE="
+ https://github.com/ponty/pyscreenshot/
+ https://pypi.org/project/pyscreenshot/
+"
+SRC_URI="
+ https://github.com/ponty/pyscreenshot/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/easyprocess[${PYTHON_USEDEP}]
+ dev-python/entrypoint2[${PYTHON_USEDEP}]
+ dev-python/jeepney[${PYTHON_USEDEP}]
+ dev-python/mss[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/python-xlib[${PYTHON_USEDEP}]
+ dev-python/pyvirtualdisplay[${PYTHON_USEDEP}]
+ media-gfx/imagemagick
+ media-gfx/pqiv
+ x11-apps/xdpyinfo
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ tests/test_check.py::test_speedtest
+ )
+
+ # skip GNOME/KDE tests that require D-BUS
+ local -x XDG_CURRENT_DESKTOP=none
+ # nonfatal is already implied by virtx, make it explicit though
+ nonfatal epytest || die "Tests failed with ${EPYTHON}"
+}