summaryrefslogtreecommitdiff
path: root/dev-python/pyscard
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-01 11:14:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-01 11:14:56 +0100
commitc952bf4dc186a298c5ef1596e2c52642072db500 (patch)
tree0b0b9cc4cdda7b2f9d62548ba883329cf6c15274 /dev-python/pyscard
parent97c0860d9b4db72365710e1b8ed20644d6f5e926 (diff)
gentoo auto-resync : 01:04:2023 - 11:14:56
Diffstat (limited to 'dev-python/pyscard')
-rw-r--r--dev-python/pyscard/Manifest2
-rw-r--r--dev-python/pyscard/pyscard-2.0.7.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/pyscard/Manifest b/dev-python/pyscard/Manifest
index d0bd3b95aa48..f29a61681624 100644
--- a/dev-python/pyscard/Manifest
+++ b/dev-python/pyscard/Manifest
@@ -1,3 +1,5 @@
DIST pyscard-2.0.5.tar.gz 150803 BLAKE2B c7d5ab17c3471b050a321c687e5faf33b5faad5a1afc60462b759280cff31bc55d86decdcb16dda9a4afe47848bc06f303c9697941dc212f01b28db6a8469a5e SHA512 bb2ef725e7dccefa640fe1568d1fee016bc5c639769d1b0d099067108e1369b8f7ccd3e48f985d657c5c7c33730eae891624f2c0ee2deaed491826b8c0eae2a5
+DIST pyscard-2.0.7.tar.gz 152304 BLAKE2B 8be34283b85b830597f051fedcdbe4437b81ad6ecf9dc0304e5bbb74f9af4fec36acc8d843802d59a204d75a4792f74827b5f422a9452cb0d84fe0ed51e4c2b3 SHA512 d30a2d0fe9b410f277a4a1e45ae88a30eb3aa7ef6cac683a80d2bb3cfe38aeafe6a483dfd42c50017c46ee0d26da13f7226e25e783176587eafce1988127bb67
EBUILD pyscard-2.0.5.ebuild 801 BLAKE2B 4b28e4f26020e68678cb67fefda84ba7c4a9610f66e633eb6552ea95ffaa241c021a506e0286ec5db4ac012a62045c6febeab7665dd655c1f9e79649ad46a551 SHA512 09a8aae09b268081c1c2cc9aa00b5a6a300356afa72b1f1cc082ce7e3dbfa85349374cc097aafe27e0fbd1dd374d00b9f4c2aeeb59394413632f4f1565efc346
+EBUILD pyscard-2.0.7.ebuild 853 BLAKE2B 5526713d662749a085d4750d83a8233ec91293a86734fbedca93c7dcfdc3b6d9c6e6688b56dce4c0fd749151f00241104e56bbc622bce4c526495277971a1d15 SHA512 e9f3562b06bf297338514e59a2d27b68f987e42f0b82c4176417b8d3e42d46ee40cb2b54afd8851f6e236b0c16682ef7115c76152297c12bc7face2c1fa0b7f8
MISC metadata.xml 426 BLAKE2B a4819bd37d610cf785d4b0e5ba2a709c941000d5cea8e20c8d49e513e7167b55e8e149da9e318281dce7b4eb92cb61e355054c273e3758262c6c25a0757ffba3 SHA512 82e759791154362704f4d7a1a1c72d53710e405c21bf791d0ec609ddfee4b8c04e3490a3f33f8d0e6e295f3b8433520f328dd71bc91cde2926a89a76803fd63d
diff --git a/dev-python/pyscard/pyscard-2.0.7.ebuild b/dev-python/pyscard/pyscard-2.0.7.ebuild
new file mode 100644
index 000000000000..9fc120662e2d
--- /dev/null
+++ b/dev-python/pyscard/pyscard-2.0.7.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Smart card support in python"
+HOMEPAGE="
+ https://pyscard.sourceforge.io/
+ https://github.com/LudovicRousseau/pyscard/
+ https://pypi.org/project/pyscard/
+"
+SRC_URI="
+ https://downloads.sourceforge.net/project/pyscard/pyscard/pyscard%20${PV}/${P}.tar.gz
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ sys-apps/pcsc-lite
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-lang/swig
+"
+
+distutils_enable_tests unittest
+
+pkg_postinst() {
+ optfeature "Gui support" dev-python/wxpython
+ optfeature "Support of remote readers with Pyro" dev-python/Pyro4
+}
+
+python_test() {
+ cd test || die
+ eunittest
+}