summaryrefslogtreecommitdiff
path: root/dev-python/pyscaffold/pyscaffold-2.4.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pyscaffold/pyscaffold-2.4.4.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pyscaffold/pyscaffold-2.4.4.ebuild')
-rw-r--r--dev-python/pyscaffold/pyscaffold-2.4.4.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/pyscaffold/pyscaffold-2.4.4.ebuild b/dev-python/pyscaffold/pyscaffold-2.4.4.ebuild
new file mode 100644
index 000000000000..48ecd4c466d1
--- /dev/null
+++ b/dev-python/pyscaffold/pyscaffold-2.4.4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+MY_PN="PyScaffold"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Tool for easily putting up the scaffold of a Python project"
+HOMEPAGE="https://pypi.org/project/PyScaffold/ https://pyscaffold.readthedocs.io/en/latest/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ >=dev-python/pbr-1.6[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.7[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ sed \
+ -e 's: + pytest_runner::g' \
+ -i setup.py || die
+
+ # Creates all sort of mem problem due to fetch restrictions
+ rm tests/test_install.py || die
+
+ # Online tests
+ sed \
+ -e 's:test_api_with_cookiecutter:_&:g' \
+ -e 's:test_pyscaffold_keyword:_&:g' \
+ -i tests/*py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ git config --global user.email "you@example.com"
+ git config --global user.name "Your Name"
+
+ TRAVIS=False py.test -v -v || die
+}