summaryrefslogtreecommitdiff
path: root/dev-python/pyrsistent/pyrsistent-0.15.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-python/pyrsistent/pyrsistent-0.15.6.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-python/pyrsistent/pyrsistent-0.15.6.ebuild')
-rw-r--r--dev-python/pyrsistent/pyrsistent-0.15.6.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pyrsistent/pyrsistent-0.15.6.ebuild b/dev-python/pyrsistent/pyrsistent-0.15.6.ebuild
new file mode 100644
index 000000000000..52a06a76ca60
--- /dev/null
+++ b/dev-python/pyrsistent/pyrsistent-0.15.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Persistent/Functional/Immutable data structures"
+HOMEPAGE="https://github.com/tobgu/pyrsistent/ https://pypi.org/project/pyrsistent/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/hypothesis[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest