summaryrefslogtreecommitdiff
path: root/dev-python/pyroute2/pyroute2-0.7.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-05 15:17:03 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-05 15:17:03 +0000
commit8afe4133ba3d8586301516885427809020a3cafa (patch)
treed82e1b009614ffe9efc4767af2297efd6365303f /dev-python/pyroute2/pyroute2-0.7.4.ebuild
parenta0c1504c093bc6abe04f9d96018f6252f81cd9ab (diff)
gentoo auto-resync : 05:02:2023 - 15:17:02
Diffstat (limited to 'dev-python/pyroute2/pyroute2-0.7.4.ebuild')
-rw-r--r--dev-python/pyroute2/pyroute2-0.7.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pyroute2/pyroute2-0.7.4.ebuild b/dev-python/pyroute2/pyroute2-0.7.4.ebuild
new file mode 100644
index 000000000000..094f6662512b
--- /dev/null
+++ b/dev-python/pyroute2/pyroute2-0.7.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="A pure Python netlink and Linux network configuration library"
+HOMEPAGE="https://github.com/svinota/pyroute2"
+
+SRC_URI="
+ https://github.com/svinota/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+"
+
+# tests need root access
+RESTRICT="test"