summaryrefslogtreecommitdiff
path: root/dev-python/pyro5
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-24 03:02:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-24 03:02:55 +0000
commit530a5a826feeb71085fb8a01927f4d775a0b131b (patch)
treeb7669c45ea3f2a3a37b2437817a370226bb1c819 /dev-python/pyro5
parent71dd9d29cdaf7cc0ecdb9ea37d128726a941c630 (diff)
gentoo auto-resync : 24:11:2024 - 03:02:54
Diffstat (limited to 'dev-python/pyro5')
-rw-r--r--dev-python/pyro5/Manifest4
-rw-r--r--dev-python/pyro5/files/pyro5-5.15-fix-test-on-ipv6.patch36
-rw-r--r--dev-python/pyro5/metadata.xml17
-rw-r--r--dev-python/pyro5/pyro5-5.15-r1.ebuild44
4 files changed, 101 insertions, 0 deletions
diff --git a/dev-python/pyro5/Manifest b/dev-python/pyro5/Manifest
new file mode 100644
index 000000000000..5d412a991b61
--- /dev/null
+++ b/dev-python/pyro5/Manifest
@@ -0,0 +1,4 @@
+AUX pyro5-5.15-fix-test-on-ipv6.patch 1408 BLAKE2B eeede9ff9c4e41227f2fa0d4411cf04520ab9e28ea3926566f3ecb0403a91d08faad581d66cf33291f98343532585fd6dbb0abe5be02afe1919f95b5ddd8486e SHA512 c729ba79294e7252e1a0cc71e7eba5c2992b6d5f5b35a865bb9a6c91f1f3f314c0cf566a1be87fb0e5bc6672025a466d64b7fb203096478ba0a30ef83f829783
+DIST Pyro5-5.15.tar.gz 447559 BLAKE2B e8831a4321205a8affef5cf0b986b3a10480296b03ac132cb5faa5508a1dbe0ba59a8dfb9a7ec284483d0736224291d033a02061b277078b26c1f71b1fd6bcc8 SHA512 bafed86363b0fd94900f0c708ffb6aa664587a7c032aa974b766556ec86d5db0eb89a8ceffa0a1e7dd043be8d0a1d8826fa79e1ca95002dbe380213c367684a3
+EBUILD pyro5-5.15-r1.ebuild 904 BLAKE2B dbaca4e8ac453afd039910d8c03aff421737da8b79faa989011a43b29833c2f47bd60f56ca719a03d6eaa046e0260baa8b8e6246f20ce834bc64458e4366646c SHA512 1b55bcb3da44baedf01b60aa7b9fe34287b1522f9e5e3f82f7c1269d789060505096787cf1649f2b95e51bb65c9f44bab85d76e8b1453f97cecbec7d77f7cdca
+MISC metadata.xml 493 BLAKE2B ea9085bad0bb57990414da69338f19a323a421b73719c9917287ff386267949b0f8d7dcdee86b21e7806a71a30ce576784de44d2e6e083a93c0ce4266639f91a SHA512 139a23e2bdf10955b3e672fccce18496116247057c4d6df47a4333151c3a6c35312d0e73e1899e8c78a6969f4e6fd048a065751ba0ea2df68603871f9b24f3c0
diff --git a/dev-python/pyro5/files/pyro5-5.15-fix-test-on-ipv6.patch b/dev-python/pyro5/files/pyro5-5.15-fix-test-on-ipv6.patch
new file mode 100644
index 000000000000..fb92d88b6f4f
--- /dev/null
+++ b/dev-python/pyro5/files/pyro5-5.15-fix-test-on-ipv6.patch
@@ -0,0 +1,36 @@
+https://github.com/irmen/Pyro5/commit/8db91b617dd08508053e54dea2a781749a00ffc8.patch
+https://bugs.gentoo.org/915997
+
+From 8db91b617dd08508053e54dea2a781749a00ffc8 Mon Sep 17 00:00:00 2001
+From: Irmen de Jong <irmen@razorvine.net>
+Date: Sat, 21 Oct 2023 21:48:56 +0200
+Subject: [PATCH] made getGetInterface test work with ipv6 localhost
+
+---
+ tests/test_socketutil.py | 13 +++++++++----
+ 1 file changed, 9 insertions(+), 4 deletions(-)
+
+diff --git a/tests/test_socketutil.py b/tests/test_socketutil.py
+index ef0720d..c9467ae 100644
+--- a/tests/test_socketutil.py
++++ b/tests/test_socketutil.py
+@@ -56,10 +56,15 @@ def testGetIP6(self):
+
+ def testGetInterface(self):
+ addr = socketutil.get_interface("localhost")
+- assert addr.version == 4
+- assert str(addr).startswith("127.")
+- assert str(addr.ip).startswith("127.0")
+- assert str(addr.network).startswith("127.0")
++ if addr.version == 6:
++ assert str(addr).startswith("::1")
++ assert str(addr.ip) == "::1"
++ assert str(addr.network).startswith("::1")
++ else:
++ assert addr.version == 4
++ assert str(addr).startswith("127.")
++ assert str(addr.ip).startswith("127.0")
++ assert str(addr.network).startswith("127.0")
+ if has_ipv6:
+ addr = socketutil.get_interface("::1")
+ assert addr.version == 6
diff --git a/dev-python/pyro5/metadata.xml b/dev-python/pyro5/metadata.xml
new file mode 100644
index 000000000000..7a9a2bcc2903
--- /dev/null
+++ b/dev-python/pyro5/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ceamac@gentoo.org</email>
+ <name>Viorel Munteanu</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">irmen/Pyro5</remote-id>
+ <remote-id type="pypi">Pyro5</remote-id>
+ </upstream>
+ <stabilize-allarches/>
+</pkgmetadata>
diff --git a/dev-python/pyro5/pyro5-5.15-r1.ebuild b/dev-python/pyro5/pyro5-5.15-r1.ebuild
new file mode 100644
index 000000000000..2a46b1e14588
--- /dev/null
+++ b/dev-python/pyro5/pyro5-5.15-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN^}
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Distributed object middleware for Python (RPC)"
+HOMEPAGE="
+ https://pyro5.readthedocs.io/
+ https://github.com/irmen/Pyro5/
+ https://pypi.org/project/Pyro5/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/serpent-1.40[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-test-on-ipv6.patch
+)
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs/source \
+ dev-python/sphinx-rtd-theme
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # https://github.com/irmen/Pyro5/issues/83 (pypy3 specific)
+ tests/test_server.py::TestServerOnce::testRegisterWeak
+ )
+
+ epytest -m 'not network'
+}