summaryrefslogtreecommitdiff
path: root/dev-python/pyrfc3339
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /dev-python/pyrfc3339
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'dev-python/pyrfc3339')
-rw-r--r--dev-python/pyrfc3339/Manifest2
-rw-r--r--dev-python/pyrfc3339/pyrfc3339-1.1.ebuild15
2 files changed, 5 insertions, 12 deletions
diff --git a/dev-python/pyrfc3339/Manifest b/dev-python/pyrfc3339/Manifest
index 437b5da95a6d..52bfc17cc589 100644
--- a/dev-python/pyrfc3339/Manifest
+++ b/dev-python/pyrfc3339/Manifest
@@ -1,3 +1,3 @@
DIST pyRFC3339-1.1.tar.gz 5290 BLAKE2B d3094a22b6903937ae5cfee1210f04b65eb05dd606fe1d3245dca8ec0719ca1a079b720568d8c8e87fea691cebe1944098f99913b97a04570f06354a883e5694 SHA512 958b7761fab590aa42bb57a955c5d834441f717796a452b60df21663099dcf2fc046afe60f8157fd0f1edfd95c5e9c9c5349ab10ca4078d210fc63d848496a2f
-EBUILD pyrfc3339-1.1.ebuild 689 BLAKE2B c270ad73d3d4c7432f99b7894f32bb337d2cbf538769aeb9f3f1289125f4db0acef9d86950e3e9cb88d58d8f7e91a9bdabec77a1aeda12327ec127db65d1efc8 SHA512 8d6884cfbeb25344e2ae797e411d92596637a96ec305dc7e052e498d1853b4e3591a987c04beea971b23794c31a1816661795a3d51d27149b43bed7d2d382247
+EBUILD pyrfc3339-1.1.ebuild 532 BLAKE2B c3532fb63933bc5aa3c9b10b4c05c7a77dfeb2c070f8718fe1e12c061d89c8a51226b1097c39389a7ddb287cfacbd3b32dee580859d6982208ec86541eec0922 SHA512 31993c72c62642f2919770d862fe72dd98bd0a5e4114387f05c05c8f6f609611d6146fabd85400d418c982384f4ae6bdf30510639c3f131ad69f5c5a0ebbda6d
MISC metadata.xml 373 BLAKE2B c047241275de0ee6411fa663ffe331d1fa4cbccb622680120d5c1b96b4fe07ffdde9b36a67bd2708dfc086e893c14f071b51b3f1b292e63c9a7a054ea841a6b4 SHA512 0f0ef1e95f7cf557a90cbf2493f0f1ba51c29cbe10769dc40b1dd56eb24e91c7ca6579feaa3afc65c9d90724c726f6d1bb4f978d6485018e19f39ecf81782a87
diff --git a/dev-python/pyrfc3339/pyrfc3339-1.1.ebuild b/dev-python/pyrfc3339/pyrfc3339-1.1.ebuild
index 1fe1a474587b..ab4cd2d80629 100644
--- a/dev-python/pyrfc3339/pyrfc3339-1.1.ebuild
+++ b/dev-python/pyrfc3339/pyrfc3339-1.1.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=(python{3_6,3_7,3_8})
+
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1
MY_PN=pyRFC3339
@@ -11,20 +12,12 @@ MY_P=${MY_PN}-${PV}
DESCRIPTION="Generates and parses RFC 3339 timestamps"
HOMEPAGE="https://github.com/kurtraschke/pyRFC3339"
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]"
-DEPEND="test? ( ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}] )
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-S=${WORKDIR}/${MY_P}
-python_test() {
- nosetests || die
-}
+distutils_enable_tests nose