summaryrefslogtreecommitdiff
path: root/dev-python/pyrate-limiter
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
commitebc282ef4dfa408accac685565b8ee5f6faec119 (patch)
treec0a4f713228cda0ab17eed46f0bb7ca8cb8be2f6 /dev-python/pyrate-limiter
parent6c8694a707151d59555b0e4e48235f085ce166c3 (diff)
gentoo auto-resync : 12:02:2023 - 09:56:54
Diffstat (limited to 'dev-python/pyrate-limiter')
-rw-r--r--dev-python/pyrate-limiter/Manifest2
-rw-r--r--dev-python/pyrate-limiter/pyrate-limiter-2.8.2.ebuild38
2 files changed, 27 insertions, 13 deletions
diff --git a/dev-python/pyrate-limiter/Manifest b/dev-python/pyrate-limiter/Manifest
index ac3a609cf6ce..1b36027d3fa8 100644
--- a/dev-python/pyrate-limiter/Manifest
+++ b/dev-python/pyrate-limiter/Manifest
@@ -1,3 +1,3 @@
DIST pyrate-limiter-2.8.2.gh.tar.gz 51233 BLAKE2B a9a8bbf123596c7c64f60ae2c9d4e23a394dae6d18a8d09c0ec0b289bbbfce9dacee523726b906a30cf17fd7243b3fa1d1f2dc60af1bec67dc242d944535a5fd SHA512 3ff703347a86f6a91cf6b9c8edce3017cf88f2373961ba235c2f521d0112b0116951be7314b95d737ef0bec5cb6bae9908874fafe4060eb773cf0577e2ddbdb3
-EBUILD pyrate-limiter-2.8.2.ebuild 1399 BLAKE2B eb99d1c1469078a31ae39d77af1a50e5e7bdc7346b6105bdf2cc3a9ac8cd839374bba68cf7c218ff288cca6e29e0ed19f87571d3fe42b8bdbc0708bbb5adb96b SHA512 0bce335df58e6ed51eba962a7ef4d44bcd3a3d037deed7fd46495fb8d2e76aec5e7748f64d1d3e201eebe698daedce949d1b4ae338e8e1ad695c7c66ca215041
+EBUILD pyrate-limiter-2.8.2.ebuild 1610 BLAKE2B 513df54bd30e8ebd64b58ca7d997a05a122606535f4b6d188a21d2b5e30380cccac7c435b017a0211eb9fc97af17d822d0e1cc1d66a20244ac9d666fbf5ada8f SHA512 ef0281396688a2985620780e736ddd2056db16b7d6be6eb11e32c381a7440dd992f639d6ea3e31479b3a1850c486e1d984e89bdf880919fb14fd9262c4d2a43d
MISC metadata.xml 525 BLAKE2B 8daa0c59b247c8ec215a3868315f383614b24bf36a80950f3a94968856a27ee2eb90cedba36784355926c509a26b530f3de44be729beeee0f22595cc0b9467b5 SHA512 429e23f33cd2889a7e989333a03ee374cbec2e264d354bf1c299263f2c9167059eb17f1c975b67cd4af7011843c3478d5296033666566bca97749ca85dfcab44
diff --git a/dev-python/pyrate-limiter/pyrate-limiter-2.8.2.ebuild b/dev-python/pyrate-limiter/pyrate-limiter-2.8.2.ebuild
index f04b57aebe33..b8c9c6a33c68 100644
--- a/dev-python/pyrate-limiter/pyrate-limiter-2.8.2.ebuild
+++ b/dev-python/pyrate-limiter/pyrate-limiter-2.8.2.ebuild
@@ -9,8 +9,14 @@ PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1
DESCRIPTION="Python Rate-Limiter using Leaky-Bucket Algorimth Family"
-HOMEPAGE="https://github.com/vutran1710/PyrateLimiter"
-SRC_URI="https://github.com/vutran1710/PyrateLimiter/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+HOMEPAGE="
+ https://github.com/vutran1710/PyrateLimiter/
+ https://pypi.org/project/pyrate-limiter/
+"
+SRC_URI="
+ https://github.com/vutran1710/PyrateLimiter/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
S="${WORKDIR}/PyrateLimiter-${PV}"
LICENSE="MIT"
@@ -19,18 +25,20 @@ KEYWORDS="~amd64"
RDEPEND="
dev-python/filelock[${PYTHON_USEDEP}]
- dev-python/redis-py[${PYTHON_USEDEP}]
+ dev-python/redis[${PYTHON_USEDEP}]
"
-BDEPEND="test? (
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/django[${PYTHON_USEDEP}]
- dev-python/django-redis[${PYTHON_USEDEP}]
- dev-python/fakeredis[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
-)"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/django-redis[${PYTHON_USEDEP}]
+ dev-python/fakeredis[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+"
EPYTEST_DESELECT=(
# Optional dependency redis-py-cluster not packaged
@@ -46,3 +54,9 @@ EPYTEST_DESELECT=(
# dev-python/myst_parser \
# dev-python/sphinxcontrib-apidoc
distutils_enable_tests pytest
+
+src_prepare() {
+ # workaround installing LICENSE into site-packages
+ sed -i -e 's:^include:exclude:' pyproject.toml || die
+ distutils-r1_src_prepare
+}