summaryrefslogtreecommitdiff
path: root/dev-python/pyrate-limiter
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-26 09:56:20 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-26 09:56:20 +0000
commit9b55c1bd600df28af7b9f6ee044b714873e19b49 (patch)
tree9c6d86e5e38b0aed45d07dc73907e9f818783a4d /dev-python/pyrate-limiter
parent61044571b76d87a2eec42d36c9b7addf3e66e000 (diff)
gentoo auto-resync : 26:02:2023 - 09:56:20
Diffstat (limited to 'dev-python/pyrate-limiter')
-rw-r--r--dev-python/pyrate-limiter/Manifest2
-rw-r--r--dev-python/pyrate-limiter/pyrate-limiter-2.9.1.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/pyrate-limiter/Manifest b/dev-python/pyrate-limiter/Manifest
index 1b36027d3fa8..bd6df17c8196 100644
--- a/dev-python/pyrate-limiter/Manifest
+++ b/dev-python/pyrate-limiter/Manifest
@@ -1,3 +1,5 @@
DIST pyrate-limiter-2.8.2.gh.tar.gz 51233 BLAKE2B a9a8bbf123596c7c64f60ae2c9d4e23a394dae6d18a8d09c0ec0b289bbbfce9dacee523726b906a30cf17fd7243b3fa1d1f2dc60af1bec67dc242d944535a5fd SHA512 3ff703347a86f6a91cf6b9c8edce3017cf88f2373961ba235c2f521d0112b0116951be7314b95d737ef0bec5cb6bae9908874fafe4060eb773cf0577e2ddbdb3
+DIST pyrate-limiter-2.9.1.gh.tar.gz 71544 BLAKE2B 2f87f998abdb891673931f91a9980f5876f58a2225ca41af6ec390e59bd326e8614162549946552b22fea093f89f5c2a219eaa9223719dd4db9023944f040da2 SHA512 461b1627574ce09817b434ce0d47e3bbcb549fcd8176623b87640089c1dd9bb45030ae1c944ffd7906b04f9b1ba2977c841c1da9483619bc092570b86a49bcd6
EBUILD pyrate-limiter-2.8.2.ebuild 1610 BLAKE2B 513df54bd30e8ebd64b58ca7d997a05a122606535f4b6d188a21d2b5e30380cccac7c435b017a0211eb9fc97af17d822d0e1cc1d66a20244ac9d666fbf5ada8f SHA512 ef0281396688a2985620780e736ddd2056db16b7d6be6eb11e32c381a7440dd992f639d6ea3e31479b3a1850c486e1d984e89bdf880919fb14fd9262c4d2a43d
+EBUILD pyrate-limiter-2.9.1.ebuild 1610 BLAKE2B 513df54bd30e8ebd64b58ca7d997a05a122606535f4b6d188a21d2b5e30380cccac7c435b017a0211eb9fc97af17d822d0e1cc1d66a20244ac9d666fbf5ada8f SHA512 ef0281396688a2985620780e736ddd2056db16b7d6be6eb11e32c381a7440dd992f639d6ea3e31479b3a1850c486e1d984e89bdf880919fb14fd9262c4d2a43d
MISC metadata.xml 525 BLAKE2B 8daa0c59b247c8ec215a3868315f383614b24bf36a80950f3a94968856a27ee2eb90cedba36784355926c509a26b530f3de44be729beeee0f22595cc0b9467b5 SHA512 429e23f33cd2889a7e989333a03ee374cbec2e264d354bf1c299263f2c9167059eb17f1c975b67cd4af7011843c3478d5296033666566bca97749ca85dfcab44
diff --git a/dev-python/pyrate-limiter/pyrate-limiter-2.9.1.ebuild b/dev-python/pyrate-limiter/pyrate-limiter-2.9.1.ebuild
new file mode 100644
index 000000000000..b8c9c6a33c68
--- /dev/null
+++ b/dev-python/pyrate-limiter/pyrate-limiter-2.9.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Rate-Limiter using Leaky-Bucket Algorimth Family"
+HOMEPAGE="
+ https://github.com/vutran1710/PyrateLimiter/
+ https://pypi.org/project/pyrate-limiter/
+"
+SRC_URI="
+ https://github.com/vutran1710/PyrateLimiter/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/PyrateLimiter-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/filelock[${PYTHON_USEDEP}]
+ dev-python/redis[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/django-redis[${PYTHON_USEDEP}]
+ dev-python/fakeredis[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_DESELECT=(
+ # Optional dependency redis-py-cluster not packaged
+ "tests/test_02.py::test_redis_cluster"
+ # Python 3.11 is slightly faster, leading to a non-critical failure here
+ "tests/test_concurrency.py::test_concurrency[ProcessPoolExecutor-SQLiteBucket]"
+)
+
+# TODO: package sphinx-copybutton
+# distutils_enable_sphinx docs \
+# dev-python/sphinx-autodoc-typehints \
+# dev-python/furo \
+# dev-python/myst_parser \
+# dev-python/sphinxcontrib-apidoc
+distutils_enable_tests pytest
+
+src_prepare() {
+ # workaround installing LICENSE into site-packages
+ sed -i -e 's:^include:exclude:' pyproject.toml || die
+ distutils-r1_src_prepare
+}