summaryrefslogtreecommitdiff
path: root/dev-python/pyqwt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pyqwt
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pyqwt')
-rw-r--r--dev-python/pyqwt/Manifest3
-rw-r--r--dev-python/pyqwt/metadata.xml18
-rw-r--r--dev-python/pyqwt/pyqwt-5.2.0-r2.ebuild90
3 files changed, 111 insertions, 0 deletions
diff --git a/dev-python/pyqwt/Manifest b/dev-python/pyqwt/Manifest
new file mode 100644
index 000000000000..aa148d242a23
--- /dev/null
+++ b/dev-python/pyqwt/Manifest
@@ -0,0 +1,3 @@
+DIST PyQwt-5.2.0.tar.gz 2670893 BLAKE2B bcd0e0c427abcc5713c3c7af8e3cb39511708b7219af99de0bf31c47117f7e5a3a9e45a1ae19ed6b5bd81d279c2332117ebfa5aee689d873320967f4c4164e54 SHA512 8c409ee228d91d625bf9bd8a5704c3d41f70613b420bc8f1527312dd1ebb686b8482bd68c4b3d1a72edd80673533a4f5a39378221967bea70f389c9dde14f265
+EBUILD pyqwt-5.2.0-r2.ebuild 1908 BLAKE2B ad606e22fb8f7a84857f6efa8a68902fbc51fc546c453000aee52096708893788107ce1a580cf4f4e4528802202e1393a5ff75e1d9ea175bf61c1d54978c1215 SHA512 dbb4f839326ebe507a3fd40837a2ad19052e70f5a8c6964c1d07bf99cfd7435d31c6bd8f8b5770f057d8010b724e2055aa53cec515d74c43c09d60f9d78e2f57
+MISC metadata.xml 662 BLAKE2B 62958f01cf277a49926891023f0fd5a693fe6197b4be0ce57d24006bf62239f01fa76281a13e7589f7b3d5addc9143fce46fab0f8018f03f2f5a9d59131a00a5 SHA512 dd9c021d0b2bc9b51d1952643bd7ca475786914fc1ddf125212cfb2450cf1fb930491e47cd0182521a10f975f30770d109f5bdf5c53ae8648257b2a485119fb4
diff --git a/dev-python/pyqwt/metadata.xml b/dev-python/pyqwt/metadata.xml
new file mode 100644
index 000000000000..7f74fabb62c0
--- /dev/null
+++ b/dev-python/pyqwt/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ PyQwt is a set of Python bindings for the Qwt C++ class library which
+ extends the Qt framework with widgets for scientific and engineering
+ applications. It provides a widget to plot 2-dimensional data and
+ various widgets to display and control bounded or unbounded floating
+ point values.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">pyqwt</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyqwt/pyqwt-5.2.0-r2.ebuild b/dev-python/pyqwt/pyqwt-5.2.0-r2.ebuild
new file mode 100644
index 000000000000..5f7e7a760269
--- /dev/null
+++ b/dev-python/pyqwt/pyqwt-5.2.0-r2.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit flag-o-matic python-r1 qmake-utils
+
+DESCRIPTION="Python bindings for the Qwt library"
+HOMEPAGE="http://pyqwt.sourceforge.net/"
+MY_P="PyQwt-${PV}"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+SLOT="5"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ~arm ia64 x86"
+IUSE="debug doc examples svg"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/PyQt4[${PYTHON_USEDEP},compat(+)]
+ dev-python/sip[${PYTHON_USEDEP}]
+ x11-libs/qwt:5[svg?]"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+S=${WORKDIR}/${MY_P}/configure
+
+src_prepare() {
+ sed -i -e "s|configuration.qt_dir, 'bin'|'$(qt4_get_bindir)'|" configure.py || die
+ python_copy_sources
+ append-flags -fPIC
+}
+
+src_configure() {
+ configuration() {
+ local myconf=()
+ use debug && myconf+=( --debug )
+
+ cd "${BUILD_DIR}" || die
+ # '-j' option can be buggy.
+ "${PYTHON}" configure.py \
+ --extra-cflags="${CFLAGS}" \
+ --extra-cxxflags="${CXXFLAGS}" \
+ --extra-lflags="${LDFLAGS}" \
+ --disable-numarray \
+ --disable-numeric \
+ -I/usr/include/qwt5 \
+ -lqwt \
+ ${myconf[@]} \
+ || die "configure.py failed"
+
+ # Avoid stripping of the libraries.
+ sed -i -e "/strip/d" {iqt5qt4,qwt5qt4}/Makefile || die "sed failed"
+ }
+ python_foreach_impl configuration
+}
+
+src_compile() {
+ compilation() {
+ cd "${BUILD_DIR}" || die
+ default
+ }
+ python_foreach_impl compilation
+
+ if use doc; then
+ cd "${S}"/../sphinx || die
+ emake
+ fi
+}
+
+src_install() {
+ installation() {
+ cd "${BUILD_DIR}" || die
+ emake DESTDIR="${D}" install
+ }
+ python_foreach_impl installation
+
+ cd "${S}"/.. || die
+
+ dodoc ANNOUNCEMENT-${PV} README
+
+ use doc && dodoc -r sphinx/build/.
+ if use examples; then
+ docinto examples
+ dodoc -r qt4examples/.
+ fi
+}