summaryrefslogtreecommitdiff
path: root/dev-python/pyqtgraph
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-07 10:35:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-07 10:35:35 +0100
commita0e773d57146b0a0ec25567af504a10e6f187811 (patch)
tree09e8f87aa02b56f14f16e82522b625cfeccb1103 /dev-python/pyqtgraph
parent1ccef27203b03f1fa900c9b44dc425df27e49452 (diff)
gentoo auto-resync : 07:09:2022 - 10:35:34
Diffstat (limited to 'dev-python/pyqtgraph')
-rw-r--r--dev-python/pyqtgraph/Manifest2
-rw-r--r--dev-python/pyqtgraph/pyqtgraph-0.12.4.ebuild11
2 files changed, 9 insertions, 4 deletions
diff --git a/dev-python/pyqtgraph/Manifest b/dev-python/pyqtgraph/Manifest
index d54691768832..ca8318104be4 100644
--- a/dev-python/pyqtgraph/Manifest
+++ b/dev-python/pyqtgraph/Manifest
@@ -1,4 +1,4 @@
DIST pyqtgraph-0.12.4.tar.gz 1333052 BLAKE2B 4208787d1d203904d841493e10b2f1d23357b60475c9e1cfff733fe772973d4dd619ca84941049bd60299912f3077fb18c27a90fa3c0c0e712a3715b5be1d071 SHA512 8402b38fe1abaaf55d6dbc26775093993b9f642d7a9da59d2780ed38562c8653ab872c588d2e66373434491b8f397533cb3c222382065c812a28cf6b9ce34960
DIST pyqtgraph-test-data-8.tar.gz 306068 BLAKE2B f3aa418dfaf2e74950fa880da4b6dfb4ef5dbd46346b78065d885c1f9fc06fc3de86756af17e27035d4cd47d98cc7ce58c036b493837b568086a4ebceb230c78 SHA512 07ef414f2b57e00589f8c18459e88ab16001c7cc3766164cdfcd69faa26cbc90ed64611fd0c5e3b401dc6a3f1a6e9e4ce6a7d9fa96ebcc4360e03fa9fbb856d2
-EBUILD pyqtgraph-0.12.4.ebuild 2359 BLAKE2B d00c3416b25a7301a2dbc5b500cc826e44e05036f5d3cfdba672ce0a2d7c27ec4e44e05f1f0ed6604c836e7507e74247a49f3b31879cdabefeb8e82870ffc68e SHA512 235a5c6d2a4b81e5b2a8154eb166a275aae7dc5d4303cc1448b2b7070976fdb528d37b57118877b928d85fe305f55e430472091ffad2fa5f38a306a7b02d6d03
+EBUILD pyqtgraph-0.12.4.ebuild 2384 BLAKE2B a3727ce4e29721fdf9405cbe7a28e6b91910ab3d30b5432850f4a9f2be0c231f8736ee89ade82535ae96e1b735af913319f71df1832f36382c73fe95071ee2b4 SHA512 94d370f2df103c3f8a09e171e713b67f913c31cd32ea36a7174763384a0848fcf3ea3162dec324a40e2f54db343bdcf0b82adefe759665d7d45d63f9f79b63f5
MISC metadata.xml 775 BLAKE2B 08f1417793ef0b57d978cab5b4c03e43e756a43625d8e6173a8b74d3c9dcce0547934485d192546cf81b8da03bdf21e4c800bb25e0bec452fe092ab3772a518f SHA512 b03a0aa3f6e6183ef2d81b9d0bb22f576661b353986a802f01cb670f9ae0487d84d3e91fd0a4add41e3dd830dbbc0414f4d556bc05bb89a768be9e5c2cee4ce4
diff --git a/dev-python/pyqtgraph/pyqtgraph-0.12.4.ebuild b/dev-python/pyqtgraph/pyqtgraph-0.12.4.ebuild
index c7a36040467f..5d15ae1e159f 100644
--- a/dev-python/pyqtgraph/pyqtgraph-0.12.4.ebuild
+++ b/dev-python/pyqtgraph/pyqtgraph-0.12.4.ebuild
@@ -10,13 +10,18 @@ inherit distutils-r1 multiprocessing
TEST_DATA_TAG=test-data-8
DESCRIPTION="A pure-python graphics and GUI library built on PyQt and numpy"
-HOMEPAGE="https://www.pyqtgraph.org/ https://pypi.org/project/pyqtgraph/"
+HOMEPAGE="
+ https://www.pyqtgraph.org/
+ https://github.com/pyqtgraph/pyqtgraph/
+ https://pypi.org/project/pyqtgraph/
+"
SRC_URI="
https://github.com/pyqtgraph/pyqtgraph/archive/${P}.tar.gz
test? (
https://github.com/pyqtgraph/test-data/archive/${TEST_DATA_TAG}.tar.gz
-> ${PN}-${TEST_DATA_TAG}.tar.gz
- )"
+ )
+"
S=${WORKDIR}/${PN}-${P}
LICENSE="MIT"
@@ -68,7 +73,7 @@ python_test() {
'pyqtgraph/examples/test_examples.py::testExamples[ designerExample.py - PySide2 ]'
)
- epytest -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+ epytest -p xvfb -n "$(makeopts_jobs)"
}
src_test() {