summaryrefslogtreecommitdiff
path: root/dev-python/pyqtgraph
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
commit8d5dbd847cbc704a6a06405856e94b461011afe3 (patch)
tree4d26462d027b14926335894749d2e01d982234d0 /dev-python/pyqtgraph
parent5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (diff)
gentoo resync : 27.03.2021
Diffstat (limited to 'dev-python/pyqtgraph')
-rw-r--r--dev-python/pyqtgraph/Manifest3
-rw-r--r--dev-python/pyqtgraph/pyqtgraph-0.12.0.ebuild86
2 files changed, 89 insertions, 0 deletions
diff --git a/dev-python/pyqtgraph/Manifest b/dev-python/pyqtgraph/Manifest
index 69f071bc09c2..a242f6c20969 100644
--- a/dev-python/pyqtgraph/Manifest
+++ b/dev-python/pyqtgraph/Manifest
@@ -1,4 +1,7 @@
AUX pyqtgraph-0.11.0-qt5_only.patch 361 BLAKE2B 5c4f904df6b19bcf29c9e44a623400015b1ebe4cac8b797a50478e75c82ac964cb05ca4c67dfa73332528e4f232f612d2f9a9bf439dbaf63765fb1f6d650bd77 SHA512 34600cdbb1e361288393fecfd8740b147ef16dfcd0719f0eed62a93201eb5fd54b09aebb86201effe6a791a6b5be934ece07a07756284ae0b2bbde4aaee137dd
DIST pyqtgraph-0.11.0_rc0.tar.gz 755973 BLAKE2B 845c57a16c71d449419cca452ac70468eb21f198b3aebe39204e8ac1408ebd4471a95b24cbd91cd4c745439c17a805738e50a29f8690de5d84f86c2597310aea SHA512 6eb5573b19c7fc0bc263bdc5d75a9a7a5d86d5ce525e406fcbd8f4215a8b2a0a9a7d4839d177fb10ff62a5feacdf088347828900daa9f60ae84e54824b98f470
+DIST pyqtgraph-0.12.0.tar.gz 893557 BLAKE2B a5fab600adad7b71d63602ed075ecdfba96316ffd1205a11c6551c132055c40f81bbac4a51e9abcfdb877365f1e95d1f05d0fdcc7131cf5f0646f641512e70aa SHA512 a30c7cab0a8a1efff697271fdcc27b1aef55a2766a90562191adc4d6e5ed6fb71da73b4b25ea4e16b7eff33876eb47468c27bc8bcdf1a0abaefa2b6c202c8739
+DIST pyqtgraph-test-data-8.tar.gz 306068 BLAKE2B f3aa418dfaf2e74950fa880da4b6dfb4ef5dbd46346b78065d885c1f9fc06fc3de86756af17e27035d4cd47d98cc7ce58c036b493837b568086a4ebceb230c78 SHA512 07ef414f2b57e00589f8c18459e88ab16001c7cc3766164cdfcd69faa26cbc90ed64611fd0c5e3b401dc6a3f1a6e9e4ce6a7d9fa96ebcc4360e03fa9fbb856d2
EBUILD pyqtgraph-0.11.0_rc0.ebuild 1075 BLAKE2B 03f8186ab7c17281ce435eab83956fa9704cf98463fbf40c8b4fd7ac12b23d9387446b824a869b53b5dc456de53f5c29aaaabaf9259974dd7bfb04b433ee218f SHA512 a8d81391d3237a5e4cf11693e43ff95fc484508253865e3866e14812dffabd682d72e320f68e36203c7e4c849bc7158a2286d6fe780ef32803503639049afbac
+EBUILD pyqtgraph-0.12.0.ebuild 2359 BLAKE2B a72971bea42435e05b1f2d0f8b2d796799e986673fdc8a0e4f7040984770141484414b0c7876f0f313f7db886dab2b606fc0dabade850cf4aad7bbb0624a56f7 SHA512 d5db8d675c909012745377df381ba513876fcda75fd4d3c3a598f103a3b3903abbdc2015b4191cbc91d2599206680288f9c6df6688fde774c4034a474f629109
MISC metadata.xml 750 BLAKE2B 2382ebf2081e2cc83e363f6716a5af4932dc7fc67b19c06af77fc9557e6e4052a882c79f734c4e96a3d1d49e1c9c7c10d3d1d1872cd1b54f86e943c0cbcdbb0c SHA512 1debda41c5945a1b1a55bb93a8220b17c2078216415195d75e5052571c340ac0e1a43d63f77c6818e69b57ca8cbd2d9a753a749c36dd6bcf803418c10e225301
diff --git a/dev-python/pyqtgraph/pyqtgraph-0.12.0.ebuild b/dev-python/pyqtgraph/pyqtgraph-0.12.0.ebuild
new file mode 100644
index 000000000000..1ebdf584d19a
--- /dev/null
+++ b/dev-python/pyqtgraph/pyqtgraph-0.12.0.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1 multiprocessing virtualx
+
+TEST_DATA_TAG=test-data-8
+DESCRIPTION="A pure-python graphics and GUI library built on PyQt and numpy"
+HOMEPAGE="http://www.pyqtgraph.org/ https://pypi.org/project/pyqtgraph/"
+SRC_URI="
+ https://github.com/pyqtgraph/pyqtgraph/archive/${P}.tar.gz
+ test? (
+ https://github.com/pyqtgraph/test-data/archive/${TEST_DATA_TAG}.tar.gz
+ -> ${PN}-${TEST_DATA_TAG}.tar.gz
+ )"
+S=${WORKDIR}/${PN}-${P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples opengl svg"
+
+RDEPEND="
+ >=dev-python/numpy-1.17[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/PyQt5[gui,widgets,opengl=,svg=,${PYTHON_USEDEP}]
+ opengl? ( dev-python/pyopengl[${PYTHON_USEDEP}] )"
+BDEPEND="
+ test? (
+ dev-python/h5py[${PYTHON_USEDEP}]
+ dev-python/PyQt5[svg,testlib,${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+distutils_enable_sphinx doc/source
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ if use test; then
+ mkdir "${HOME}"/.pyqtgraph || die
+ mv "${WORKDIR}/test-data-${TEST_DATA_TAG}" \
+ "${HOME}"/.pyqtgraph/test-data || die
+ cd "${HOME}"/.pyqtgraph/test-data || die
+ # we need to fake a git repo
+ git config --global user.email "you@example.com"
+ git config --global user.name "Your Name"
+ git init -q || die
+ git commit -q --allow-empty -m "dummy commit" || die
+ git tag "${TEST_DATA_TAG}" || die
+ cd - >/dev/null || die
+ fi
+ if ! use opengl; then
+ rm -r pyqtgraph/opengl || die
+ fi
+}
+
+python_test() {
+ local deselect=(
+ # apparently fragile
+ --deselect pyqtgraph/tests/test_reload.py::test_reload
+
+ # pyside2 is normally skipped if not installed but these two
+ # fail if it is installed
+ # TODO: this could be due to USE flags, revisit when pyside2
+ # gains py3.9
+ --deselect
+ 'examples/test_examples.py::testExamples[ DateAxisItem_QtDesigner.py - PySide2 ]'
+ --deselect
+ 'examples/test_examples.py::testExamples[ designerExample.py - PySide2 ]'
+ )
+
+ distutils_install_for_testing
+ virtx epytest "${deselect[@]}" \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+python_install_all() {
+ use examples && DOCS+=( examples/ )
+ distutils-r1_python_install_all
+}