summaryrefslogtreecommitdiff
path: root/dev-python/pyqtgraph
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pyqtgraph
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pyqtgraph')
-rw-r--r--dev-python/pyqtgraph/Manifest4
-rw-r--r--dev-python/pyqtgraph/files/pyqtgraph-0.10.0-qt5.patch10
-rw-r--r--dev-python/pyqtgraph/metadata.xml18
-rw-r--r--dev-python/pyqtgraph/pyqtgraph-0.10.0-r1.ebuild47
4 files changed, 79 insertions, 0 deletions
diff --git a/dev-python/pyqtgraph/Manifest b/dev-python/pyqtgraph/Manifest
new file mode 100644
index 000000000000..ad1ed91c7f39
--- /dev/null
+++ b/dev-python/pyqtgraph/Manifest
@@ -0,0 +1,4 @@
+AUX pyqtgraph-0.10.0-qt5.patch 439 BLAKE2B 8c0b5f766adf64d67800873145223ed8f9dda75ce1d5d62784129d827c4dfb9d44bd5532b44dbe42abc6bd67d5b13082c1691d8796c3a53b4ea873faaa2d7f00 SHA512 792a739e1cdc2c7c1ce059945c4a5280f1187a88dd767669fee83fbbdb5c315c022b99c5312c9c53d88afc6d24767fcb93426f6e05b9a5d08db084ba3110cc93
+DIST pyqtgraph-0.10.0.tar.gz 704972 BLAKE2B cb1295608536b06de32ea72503b2df2be7f4ae3065b42431542539feec5eb37412e3a7697e2ee97309594b9aecc19c692ef7b45f843f37bd50148a3c0b6e1d31 SHA512 d995da7b4f13ae0009582aebe3f753dc78566dc50ba9314d3a2d37ad4ed8f2fd8bb497a01bb8b37b6d96bf14c071aad018bcbc7224d9dd9b47589a7b5b640d30
+EBUILD pyqtgraph-0.10.0-r1.ebuild 1232 BLAKE2B bdfbca1ce80d8746e57aeb0eac1e7923b74956527fd7f3acf5315b9fb0fb15848bac69807ba55252aab4dbfe5de47631f3983fc0ee1962bf58b4070e34a264dc SHA512 fa0485238d438cd016f85bac3d4d3ec9f467ec85a75cdac279460bdb220555b87ab6e43230d9aeb5b3157a6336bf282be85d9d76284f27228aca68a36a3bfeb7
+MISC metadata.xml 725 BLAKE2B 0126a36d5645e5fa0ddcbc46924f78284cb03de5632f84a790415278a91ab650b2e3c7994467e106a0bc4e900f98b0f40ca70416ea2d515b15d4f74320600e70 SHA512 51fdf4a875bc629230c1040ae34cc6b37225dcd18c04a23d3bb6b5da30c79dd7d4c10ee46fd671941d86ee15d548e7a0303bcb48e7796b20036ebb928ebd9078
diff --git a/dev-python/pyqtgraph/files/pyqtgraph-0.10.0-qt5.patch b/dev-python/pyqtgraph/files/pyqtgraph-0.10.0-qt5.patch
new file mode 100644
index 000000000000..b74df26df5d3
--- /dev/null
+++ b/dev-python/pyqtgraph/files/pyqtgraph-0.10.0-qt5.patch
@@ -0,0 +1,10 @@
+diff -r -U2 pyqtgraph-0.10.0.orig/pyqtgraph/Qt.py pyqtgraph-0.10.0/pyqtgraph/Qt.py
+--- pyqtgraph-0.10.0.orig/pyqtgraph/Qt.py 2016-10-17 23:22:41.000000000 +0700
++++ pyqtgraph-0.10.0/pyqtgraph/Qt.py 2018-01-23 22:52:19.503525554 +0700
+@@ -25,5 +25,5 @@
+ ## is already imported. If not, then attempt to import PyQt4, then PySide.
+ if QT_LIB is None:
+- libOrder = [PYQT4, PYSIDE, PYQT5]
++ libOrder = [PYQT5]
+
+ for lib in libOrder:
diff --git a/dev-python/pyqtgraph/metadata.xml b/dev-python/pyqtgraph/metadata.xml
new file mode 100644
index 000000000000..3f66bf396f36
--- /dev/null
+++ b/dev-python/pyqtgraph/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription>
+ PyQtGraph is a pure-python graphics and GUI library built on PyQt and numpy.
+ It is intended for use in mathematics / scientific / engineering applications.
+ Despite being written entirely in python, the library is very fast
+ due to its heavy leverage of numpy for number crunching
+ and Qt's GraphicsView framework for fast display.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">pyqtgraph/pyqtgraph</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyqtgraph/pyqtgraph-0.10.0-r1.ebuild b/dev-python/pyqtgraph/pyqtgraph-0.10.0-r1.ebuild
new file mode 100644
index 000000000000..6c2525df7676
--- /dev/null
+++ b/dev-python/pyqtgraph/pyqtgraph-0.10.0-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="A pure-python graphics and GUI library built on PyQt and numpy"
+HOMEPAGE="http://www.pyqtgraph.org/ https://pypi.org/project/pyqtgraph/"
+SRC_URI="http://www.pyqtgraph.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc examples opengl svg"
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ dev-python/PyQt5[gui,widgets,opengl=,svg=,${PYTHON_USEDEP}]
+ opengl? ( dev-python/pyopengl[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+PATCHES=( "${FILESDIR}"/${P}-qt5.patch )
+S=${WORKDIR}/${PN}-${P}
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ # fix distutils warning
+ sed -i 's/install_requires/requires/' setup.py || die
+
+ if ! use opengl; then
+ rm -r pyqtgraph/opengl || die
+ fi
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}