summaryrefslogtreecommitdiff
path: root/dev-python/pyqtgraph
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/pyqtgraph
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/pyqtgraph')
-rw-r--r--dev-python/pyqtgraph/Manifest5
-rw-r--r--dev-python/pyqtgraph/metadata.xml11
-rw-r--r--dev-python/pyqtgraph/pyqtgraph-0.10.0.ebuild52
3 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/pyqtgraph/Manifest b/dev-python/pyqtgraph/Manifest
new file mode 100644
index 000000000000..cd958915eb9c
--- /dev/null
+++ b/dev-python/pyqtgraph/Manifest
@@ -0,0 +1,5 @@
+DIST pyqtgraph-0.10.0.tar.gz 704972 SHA256 4c851deec81c1dd1ecb4468ff6d5b035349b167cc1b4e4bb724b4b410945d20b SHA512 d995da7b4f13ae0009582aebe3f753dc78566dc50ba9314d3a2d37ad4ed8f2fd8bb497a01bb8b37b6d96bf14c071aad018bcbc7224d9dd9b47589a7b5b640d30 WHIRLPOOL a3435da48e68a4d1dfadfcb3a07f58056291cfac09b09c6459520b781717005cf52037354e2062ad4d81ed4f734ed7acf8f55d2638df720bf22f3723424ceebb
+EBUILD pyqtgraph-0.10.0.ebuild 1222 SHA256 fa1f1691b517114a4ede4655237235d79966078e96e9587f8fdd3168cd4c571d SHA512 8bd56a0d401ac1bc1d5ed34e258d912cfac4dfce5ee5f483710716de73bc072c9f94a342478bfc77c50140b3bd90bc4fc0141dcdd568c5aa3fd7a6d4aa58bff8 WHIRLPOOL f872fe9d4fd1a776da5ef55a8aab6672f12fc5edb6692ae19b1cd7884cca6bb97fa705119eb1f8c2d7f7d83a3469343f2cb9e25d3f1d7b465fd4c8480adda5ee
+MISC ChangeLog 2883 SHA256 acdb8520999112df7f0ed04e58f2ea4137050bb81a63928bf1075283920c4eaa SHA512 433cb7dca164f86ee5025faa7821cb7df2ebe7e741ac7616b6fd3f9f74211c5ef57e4b7706d80bca27eacd24e1cb492f706961423209437677c3a6f8dd87b355 WHIRLPOOL 22335c4c4766fcf2ec4ef3ae644a76e6fb39f14f521f787465e9314d62d3af567a708801faa5468265250a9b5c45ef604e305d0cf1c6986dc7f26d93622d16ed
+MISC ChangeLog-2015 886 SHA256 4dc55cf1e879e4b5edd700fb49f4aa53042762675b29a20772d22272055cafcd SHA512 9a796f002f4518dfda8ff79d012613022cc73cc0239dbda642d59490b81e2a6084d614986d3c9b6283d53e071594a4ee97e31a07ac3807957c9248a3024d29f0 WHIRLPOOL 303adf4e8e02298c4c9b53b3edd2a3fd978389d33b6c3327b658d3728507b749ce7e6515139d5661550965d828567ccbc3fcc832ac0ea40059de3027e31d43b6
+MISC metadata.xml 334 SHA256 643e68544e00133611e303f4dedd087b7f8a88bb02a84b46e8053b0ef8da0a70 SHA512 0508e3e04125aa9ec46c82dd47593ad3055ed8769d4d1499d892986db40deb9f5405a57546e48f06149c0298bd44582efb53b4b21d67d15e8c3b3fb3aee63eba WHIRLPOOL a680e6ab6c03df3e147a0b1dbdd3f4cf120692571fd3f8c642f4735e495e4d3ac7fcf7dbeafe5dfbba9941aa18978f773ca61e24e9249a08c1ada20807bdab4d
diff --git a/dev-python/pyqtgraph/metadata.xml b/dev-python/pyqtgraph/metadata.xml
new file mode 100644
index 000000000000..1dffaf00842a
--- /dev/null
+++ b/dev-python/pyqtgraph/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">pyqtgraph/pyqtgraph</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyqtgraph/pyqtgraph-0.10.0.ebuild b/dev-python/pyqtgraph/pyqtgraph-0.10.0.ebuild
new file mode 100644
index 000000000000..dea43636c817
--- /dev/null
+++ b/dev-python/pyqtgraph/pyqtgraph-0.10.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="a pure-python graphics and GUI library built on PyQt/PySide and numpy"
+HOMEPAGE="http://www.pyqtgraph.org/ https://github.com/pyqtgraph/pyqtgraph"
+SRC_URI="https://github.com/pyqtgraph/${PN}/archive/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc examples opengl"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ || (
+ dev-python/PyQt5[${PYTHON_USEDEP}]
+ dev-python/PyQt4[${PYTHON_USEDEP}]
+ dev-python/pyside[${PYTHON_USEDEP}]
+ )
+ opengl? ( dev-python/pyopengl[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+
+S=${WORKDIR}/${PN}-${P}
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ # fix distutils warning
+ sed -i 's/install_requires/requires/' setup.py || die
+
+ if ! use opengl; then
+ rm -r pyqtgraph/opengl || die
+ fi
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}