summaryrefslogtreecommitdiff
path: root/dev-python/pyqtgraph
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/pyqtgraph
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/pyqtgraph')
-rw-r--r--dev-python/pyqtgraph/Manifest2
-rw-r--r--dev-python/pyqtgraph/pyqtgraph-0.12.4.ebuild93
2 files changed, 95 insertions, 0 deletions
diff --git a/dev-python/pyqtgraph/Manifest b/dev-python/pyqtgraph/Manifest
index 1ba50d8b645c..8702d14fe3e4 100644
--- a/dev-python/pyqtgraph/Manifest
+++ b/dev-python/pyqtgraph/Manifest
@@ -1,4 +1,6 @@
DIST pyqtgraph-0.12.3.tar.gz 1317230 BLAKE2B d9a7a86f976fd7d778b0f038b24e80d6cbbdb98f6cda7de0461d1e3bbac0a99745dc3cccc63f38c24128018a2f41f3a0da7437bf9ddbd3f4091fd826ae4ea915 SHA512 13f1ff4bcce7ab8c133ebb99101d300bb3abcd6ea8b7321f3aa646d6992b6988db17d478dcec52339dd380f7c6e487f47b95b9f9de616b7ff2dab35ca5f0cc30
+DIST pyqtgraph-0.12.4.tar.gz 1333052 BLAKE2B 4208787d1d203904d841493e10b2f1d23357b60475c9e1cfff733fe772973d4dd619ca84941049bd60299912f3077fb18c27a90fa3c0c0e712a3715b5be1d071 SHA512 8402b38fe1abaaf55d6dbc26775093993b9f642d7a9da59d2780ed38562c8653ab872c588d2e66373434491b8f397533cb3c222382065c812a28cf6b9ce34960
DIST pyqtgraph-test-data-8.tar.gz 306068 BLAKE2B f3aa418dfaf2e74950fa880da4b6dfb4ef5dbd46346b78065d885c1f9fc06fc3de86756af17e27035d4cd47d98cc7ce58c036b493837b568086a4ebceb230c78 SHA512 07ef414f2b57e00589f8c18459e88ab16001c7cc3766164cdfcd69faa26cbc90ed64611fd0c5e3b401dc6a3f1a6e9e4ce6a7d9fa96ebcc4360e03fa9fbb856d2
EBUILD pyqtgraph-0.12.3.ebuild 2440 BLAKE2B 8bbe7be0cef092b32282cc411989376d94c12a6803728fe271977f86efd8c4fed248875f23ec77f3f76081297bade8e9b592bab3f9bdfd84d08408672ee988a9 SHA512 4d62a0bcabde7f28d8bb6eec58f6b41eeff4a6c0bae1d703d02379d634a8d6b783a958f2efbb2a6647039b0201b805ce4b64113ceebf5a49ab19a5d122b02ea0
+EBUILD pyqtgraph-0.12.4.ebuild 2466 BLAKE2B f54222cd4856556ebfc8180286f5bd727aff2da7ab8e1e5928fb663e5ca3657d4088df15877bfbec8a9ab290750604bf9f1b641329445185766e8c292a2d2bd8 SHA512 c9637613181e1349fcd8976bcca7ba98b75b96a42687ba2df0e2a3f8932009a094c426206409b9eb23c879539a53ff4a42f6e7d840255ddb1298f3886a1174e1
MISC metadata.xml 775 BLAKE2B 08f1417793ef0b57d978cab5b4c03e43e756a43625d8e6173a8b74d3c9dcce0547934485d192546cf81b8da03bdf21e4c800bb25e0bec452fe092ab3772a518f SHA512 b03a0aa3f6e6183ef2d81b9d0bb22f576661b353986a802f01cb670f9ae0487d84d3e91fd0a4add41e3dd830dbbc0414f4d556bc05bb89a768be9e5c2cee4ce4
diff --git a/dev-python/pyqtgraph/pyqtgraph-0.12.4.ebuild b/dev-python/pyqtgraph/pyqtgraph-0.12.4.ebuild
new file mode 100644
index 000000000000..5c5065d886e1
--- /dev/null
+++ b/dev-python/pyqtgraph/pyqtgraph-0.12.4.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 multiprocessing
+
+TEST_DATA_TAG=test-data-8
+DESCRIPTION="A pure-python graphics and GUI library built on PyQt and numpy"
+HOMEPAGE="https://www.pyqtgraph.org/ https://pypi.org/project/pyqtgraph/"
+SRC_URI="
+ https://github.com/pyqtgraph/pyqtgraph/archive/${P}.tar.gz
+ test? (
+ https://github.com/pyqtgraph/test-data/archive/${TEST_DATA_TAG}.tar.gz
+ -> ${PN}-${TEST_DATA_TAG}.tar.gz
+ )"
+S=${WORKDIR}/${PN}-${P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples opengl svg"
+REQUIRED_USE="test? ( opengl svg )"
+
+RDEPEND="
+ >=dev-python/numpy-1.17[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/PyQt5[gui,widgets,opengl=,svg=,${PYTHON_USEDEP}]
+ opengl? ( dev-python/pyopengl[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ test? (
+ dev-python/h5py[${PYTHON_USEDEP}]
+ dev-python/PyQt5[testlib,${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/pytest-xvfb[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+distutils_enable_sphinx doc/source
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ if ! use opengl; then
+ rm -r pyqtgraph/opengl || die
+ fi
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # apparently fragile
+ tests/test_reload.py::test_reload
+
+ # TODO
+ tests/graphicsItems/test_ROI.py::test_PolyLineROI
+
+ # pyside2 is normally skipped if not installed but these two
+ # fail if it is installed
+ # TODO: this could be due to USE flags, revisit when pyside2
+ # gains py3.9
+ 'pyqtgraph/examples/test_examples.py::testExamples[ DateAxisItem_QtDesigner.py - PySide2 ]'
+ 'pyqtgraph/examples/test_examples.py::testExamples[ designerExample.py - PySide2 ]'
+ )
+
+ epytest -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+src_test() {
+ mkdir "${HOME}"/.pyqtgraph || die
+ mv "${WORKDIR}/test-data-${TEST_DATA_TAG}" \
+ "${HOME}"/.pyqtgraph/test-data || die
+ cd "${HOME}"/.pyqtgraph/test-data || die
+ # we need to fake a git repo
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ git init -q || die
+ git commit -q --allow-empty -m "dummy commit" || die
+ git tag "${TEST_DATA_TAG}" || die
+ cd - >/dev/null || die
+
+ distutils-r1_src_test
+}
+
+python_install_all() {
+ use examples && DOCS+=( examples/ )
+ distutils-r1_python_install_all
+}