summaryrefslogtreecommitdiff
path: root/dev-python/pypy3_10-exe
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-21 14:46:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-21 14:46:21 +0100
commitd3f42b1ace45210af6c1b0c1970d626d411b15e0 (patch)
tree247085c9b7eb4f9b76c091d65482f26262c9b924 /dev-python/pypy3_10-exe
parent7c334a9594ae315e537bf98259b95bafc60d479c (diff)
gentoo auto-resync : 21:07:2023 - 14:46:21
Diffstat (limited to 'dev-python/pypy3_10-exe')
-rw-r--r--dev-python/pypy3_10-exe/Manifest2
-rw-r--r--dev-python/pypy3_10-exe/pypy3_10-exe-7.3.12_p2.ebuild127
2 files changed, 129 insertions, 0 deletions
diff --git a/dev-python/pypy3_10-exe/Manifest b/dev-python/pypy3_10-exe/Manifest
index 913c8ea42dc0..19cfaa3d1a84 100644
--- a/dev-python/pypy3_10-exe/Manifest
+++ b/dev-python/pypy3_10-exe/Manifest
@@ -1,4 +1,6 @@
DIST pypy3.10-gentoo-patches-7.3.12.tar.xz 3736 BLAKE2B 9283b05e84b385289900a07a8591d830589c5ae9cb77dc5350cb0c6a4c8f71118ed13d270060d900079ec8f7d57c256a973f55016299d001e8be585ba2a2ad30 SHA512 9ec7d8d6e16719971d43cc37cf3fdfaf76b1a707ae37b02681b0a07d17c60df503e926fa8034c9f4866d46136089a0059ee165a0c222f56f2537f374e915b3ca
+DIST pypy3.10-gentoo-patches-7.3.12_p2.tar.xz 7184 BLAKE2B dae373bee65ede20c1e8bc29faedd5413c832bd105045d6953c8c1eca99955de1bab5dfcddacc612874616dabbb58921bebddc2a62177edc822247e6c2eba9c7 SHA512 b4476dc96dfd79a15218e2b7b60f289abeb10605e01a96746c04b9449c201aa8ee032dc3145c36b0b64d07e3948e828b49a874132d595b26e4dd95140d428942
DIST pypy3.10-v7.3.12-src.tar.bz2 23009064 BLAKE2B ad45d90de9ae51803ebcfa202763889f92f7e5c2939331433a496e53ca67dd6eeaf9c61e16cb648945409dff3c6dd6b8a2a01dfe1bed6cd6a9df98f112bff181 SHA512 080520c7de267e17a2823f06cd0a15c108a2c32fc296d6e24782050eb546fa74852d948ede2c381dba110774121b20efc3a07b553acd0ac0db4a844dfc09069e
EBUILD pypy3_10-exe-7.3.12.ebuild 2640 BLAKE2B 98ba684d125a3fd67324f8e90a91e073332e882f4c5d5fdc4694c27fae1127b480dd2db54993da210f1f39e0d8254c428048f41e92eea262bfc3c8a63b5f78a4 SHA512 c70f9183c3e30f3f61c7722e13fcabf0c7ef21553e45d9a68d519f70307a07ba99b7d6318e82054fade2a49079553b1f0072e15c3c2bc58d3d9a559f8dba8fb0
+EBUILD pypy3_10-exe-7.3.12_p2.ebuild 2640 BLAKE2B c07cd82f2347246b4a9932f1579ff97ba8bfbe352eaad0de73060484d9c1e9c8e3dfdf5bb4db72a6dc965050cef95561deb217b5bfb34bd9f3efa93da89e6a83 SHA512 030317b7de10bd8b5efad925e9cabaeab1cb8b02e0e5b3cda5b743836247c8b7612e521b8e7349a09d183b6b2e3260713920391532625bfb097f067ebcc43fbb
MISC metadata.xml 498 BLAKE2B 8dbcdb7c3a4a2fa5d1a922fd5197fb5e3337adcaec1e7d382f25f8696c80726e5b79843477bf8e5ce131aecde6e2c4c283548c5b337e54cb58aaa066013c445a SHA512 8a9bb514bbf3bf328aa63734e1fdc106f6aaf5ccb88c29ad8a686ab2724f3d1f4727163500013dd16e7b34232b881cf47d2f174212b5428ee076af27cf43628d
diff --git a/dev-python/pypy3_10-exe/pypy3_10-exe-7.3.12_p2.ebuild b/dev-python/pypy3_10-exe/pypy3_10-exe-7.3.12_p2.ebuild
new file mode 100644
index 000000000000..a9b71592d810
--- /dev/null
+++ b/dev-python/pypy3_10-exe/pypy3_10-exe-7.3.12_p2.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit check-reqs pax-utils toolchain-funcs
+
+PYPY_PV=${PV%_p*}
+PYVER=3.10
+MY_P="pypy${PYVER}-v${PYPY_PV/_}"
+PATCHSET="pypy${PYVER}-gentoo-patches-${PV}"
+
+DESCRIPTION="PyPy3 executable (build from source)"
+HOMEPAGE="https://www.pypy.org/"
+SRC_URI="
+ https://buildbot.pypy.org/pypy/${MY_P}-src.tar.bz2
+ https://dev.gentoo.org/~mgorny/dist/python/${PATCHSET}.tar.xz
+"
+S="${WORKDIR}/${MY_P}-src"
+
+LICENSE="MIT"
+SLOT="${PYPY_PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+jit low-memory ncurses cpu_flags_x86_sse2"
+
+RDEPEND="
+ app-arch/bzip2:0=
+ dev-libs/expat:0=
+ dev-libs/libffi:0=
+ >=sys-libs/zlib-1.1.3:0=
+ virtual/libintl:0=
+ ncurses? ( sys-libs/ncurses:0= )
+ !dev-python/pypy3-exe-bin:${SLOT}
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ dev-python/pypy
+"
+
+check_env() {
+ if use low-memory; then
+ CHECKREQS_MEMORY="1750M"
+ use amd64 && CHECKREQS_MEMORY="3500M"
+ else
+ CHECKREQS_MEMORY="3G"
+ use amd64 && CHECKREQS_MEMORY="6G"
+ fi
+
+ check-reqs_pkg_pretend
+}
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && check_env
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && check_env
+}
+
+src_prepare() {
+ local PATCHES=(
+ "${WORKDIR}/${PATCHSET}"
+ )
+ default
+}
+
+src_configure() {
+ tc-export CC
+
+ local jit_backend
+ if use jit; then
+ jit_backend='--jit-backend='
+
+ # We only need the explicit sse2 switch for x86.
+ # On other arches we can rely on autodetection which uses
+ # compiler macros. Plus, --jit-backend= doesn't accept all
+ # the modern values...
+
+ if use x86; then
+ if use cpu_flags_x86_sse2; then
+ jit_backend+=x86
+ else
+ jit_backend+=x86-without-sse2
+ fi
+ else
+ jit_backend+=auto
+ fi
+ fi
+
+ local args=(
+ --no-shared
+ $(usex jit -Ojit -O2)
+
+ ${jit_backend}
+
+ pypy/goal/targetpypystandalone
+ --withmod-bz2
+ $(usex ncurses --with{,out}mod-_minimal_curses)
+ )
+
+ local interp=( pypy )
+ if use low-memory; then
+ local -x PYPY_GC_MAX_DELTA=200MB
+ interp+=( --jit loop_longevity=300 )
+ fi
+
+ # translate into the C sources
+ # we're going to build them ourselves since otherwise pypy does not
+ # free up the unneeded memory before spawning the compiler
+ set -- "${interp[@]}" rpython/bin/rpython --batch --source "${args[@]}"
+ echo -e "\033[1m${@}\033[0m"
+ "${@}" || die "translation failed"
+}
+
+src_compile() {
+ emake -C "${T}"/usession*-0/testing_1
+}
+
+src_install() {
+ cd "${T}"/usession*-0 || die
+ newbin "testing_1/pypy${PYVER}-c" "pypy${PYVER}-c-${PYPY_PV}"
+ insinto "/usr/include/pypy${PYVER}/${PYPY_PV}"
+ doins *.h
+ pax-mark m "${ED}/usr/bin/pypy${PYVER}-c-${PYPY_PV}"
+}