summaryrefslogtreecommitdiff
path: root/dev-python/pypy3_10-exe
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-21 23:10:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-21 23:10:38 +0000
commit51a01b0f2371b8dfc39f2747ecafd7d5f083ecb4 (patch)
tree55d5c62353eb98ea2809ea087e9fc4b215c53563 /dev-python/pypy3_10-exe
parent46de1a2f454a1465026d681f5dfe8db7dde5b126 (diff)
gentoo auto-resync : 21:11:2023 - 23:10:38
Diffstat (limited to 'dev-python/pypy3_10-exe')
-rw-r--r--dev-python/pypy3_10-exe/Manifest2
-rw-r--r--dev-python/pypy3_10-exe/pypy3_10-exe-7.3.13_p2.ebuild127
2 files changed, 129 insertions, 0 deletions
diff --git a/dev-python/pypy3_10-exe/Manifest b/dev-python/pypy3_10-exe/Manifest
index 635b33efee2a..bdf9ccce3a9e 100644
--- a/dev-python/pypy3_10-exe/Manifest
+++ b/dev-python/pypy3_10-exe/Manifest
@@ -1,4 +1,6 @@
DIST pypy3.10-gentoo-patches-7.3.13.tar.xz 4776 BLAKE2B 9f0ef159c8aa2d3edb5ee0e14be694c4a7c1165d70b16e9b13b6e59da7334354cc8593186a2ff47d4a0ce8c76abdf4a3c12ec3ffdd7a90cc4f30b39c259c3ee7 SHA512 86bfbf7f26f259c0850074c9062544ee091f7a65359cb17dae3ec287841e7a812d7185cb552f3546acdde3965efe0e6c0fb728c30b64779fca10be2f7c4d634f
+DIST pypy3.10-gentoo-patches-7.3.13_p2.tar.xz 7948 BLAKE2B 3978db108a1ab3e471f878e3480d4419262c34137f43c2e11168c85704f8c72769bea5bca9613ba5fb762b7f88c77f55070dc6a28e8a92ffa6f95d74fb5891ad SHA512 dd8c0f74f22f45608addaf362ef0dc8acee3c5a02bed7c557883ca97d4e2bdfe47dbf6621a4da01cc97956550aa252622237b85c642fb33100065237689c2abb
DIST pypy3.10-v7.3.13-src.tar.bz2 23067819 BLAKE2B 6e2bfd83bcf16feef006dad39ab6d8f452418ee6bc4043edaa590db702f39275e775004bdba762736a901da94cb5274cd34f2811461048d46ac0f4af04158702 SHA512 16fbc76558152b3eadca999d56197a6bf906cbb7bb75035ccd3501372af0f0c22533d22ba231a40b7c02afa11f0d692a6ae85ba6d5e1607b737b8c68209b7c43
EBUILD pypy3_10-exe-7.3.13.ebuild 2638 BLAKE2B a6b9999c39184fa147bba761c6ac332faac94aee06063a9c042c6e8c8bd0a118fe5f617686878bfb334a713dc6eae2052b453d7a936a9c015f130785e0a040d0 SHA512 b02f3c5dfa9ec42443ca971c585a7b3525df8ca04af957e939f8032d5e35492aa8b45de179ebdfdcb691a9fbeedc8bb927f12f44cfbd13ce0317ee2a39cc490c
+EBUILD pypy3_10-exe-7.3.13_p2.ebuild 2640 BLAKE2B c07cd82f2347246b4a9932f1579ff97ba8bfbe352eaad0de73060484d9c1e9c8e3dfdf5bb4db72a6dc965050cef95561deb217b5bfb34bd9f3efa93da89e6a83 SHA512 030317b7de10bd8b5efad925e9cabaeab1cb8b02e0e5b3cda5b743836247c8b7612e521b8e7349a09d183b6b2e3260713920391532625bfb097f067ebcc43fbb
MISC metadata.xml 498 BLAKE2B 8dbcdb7c3a4a2fa5d1a922fd5197fb5e3337adcaec1e7d382f25f8696c80726e5b79843477bf8e5ce131aecde6e2c4c283548c5b337e54cb58aaa066013c445a SHA512 8a9bb514bbf3bf328aa63734e1fdc106f6aaf5ccb88c29ad8a686ab2724f3d1f4727163500013dd16e7b34232b881cf47d2f174212b5428ee076af27cf43628d
diff --git a/dev-python/pypy3_10-exe/pypy3_10-exe-7.3.13_p2.ebuild b/dev-python/pypy3_10-exe/pypy3_10-exe-7.3.13_p2.ebuild
new file mode 100644
index 000000000000..a9b71592d810
--- /dev/null
+++ b/dev-python/pypy3_10-exe/pypy3_10-exe-7.3.13_p2.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit check-reqs pax-utils toolchain-funcs
+
+PYPY_PV=${PV%_p*}
+PYVER=3.10
+MY_P="pypy${PYVER}-v${PYPY_PV/_}"
+PATCHSET="pypy${PYVER}-gentoo-patches-${PV}"
+
+DESCRIPTION="PyPy3 executable (build from source)"
+HOMEPAGE="https://www.pypy.org/"
+SRC_URI="
+ https://buildbot.pypy.org/pypy/${MY_P}-src.tar.bz2
+ https://dev.gentoo.org/~mgorny/dist/python/${PATCHSET}.tar.xz
+"
+S="${WORKDIR}/${MY_P}-src"
+
+LICENSE="MIT"
+SLOT="${PYPY_PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+jit low-memory ncurses cpu_flags_x86_sse2"
+
+RDEPEND="
+ app-arch/bzip2:0=
+ dev-libs/expat:0=
+ dev-libs/libffi:0=
+ >=sys-libs/zlib-1.1.3:0=
+ virtual/libintl:0=
+ ncurses? ( sys-libs/ncurses:0= )
+ !dev-python/pypy3-exe-bin:${SLOT}
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ dev-python/pypy
+"
+
+check_env() {
+ if use low-memory; then
+ CHECKREQS_MEMORY="1750M"
+ use amd64 && CHECKREQS_MEMORY="3500M"
+ else
+ CHECKREQS_MEMORY="3G"
+ use amd64 && CHECKREQS_MEMORY="6G"
+ fi
+
+ check-reqs_pkg_pretend
+}
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && check_env
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && check_env
+}
+
+src_prepare() {
+ local PATCHES=(
+ "${WORKDIR}/${PATCHSET}"
+ )
+ default
+}
+
+src_configure() {
+ tc-export CC
+
+ local jit_backend
+ if use jit; then
+ jit_backend='--jit-backend='
+
+ # We only need the explicit sse2 switch for x86.
+ # On other arches we can rely on autodetection which uses
+ # compiler macros. Plus, --jit-backend= doesn't accept all
+ # the modern values...
+
+ if use x86; then
+ if use cpu_flags_x86_sse2; then
+ jit_backend+=x86
+ else
+ jit_backend+=x86-without-sse2
+ fi
+ else
+ jit_backend+=auto
+ fi
+ fi
+
+ local args=(
+ --no-shared
+ $(usex jit -Ojit -O2)
+
+ ${jit_backend}
+
+ pypy/goal/targetpypystandalone
+ --withmod-bz2
+ $(usex ncurses --with{,out}mod-_minimal_curses)
+ )
+
+ local interp=( pypy )
+ if use low-memory; then
+ local -x PYPY_GC_MAX_DELTA=200MB
+ interp+=( --jit loop_longevity=300 )
+ fi
+
+ # translate into the C sources
+ # we're going to build them ourselves since otherwise pypy does not
+ # free up the unneeded memory before spawning the compiler
+ set -- "${interp[@]}" rpython/bin/rpython --batch --source "${args[@]}"
+ echo -e "\033[1m${@}\033[0m"
+ "${@}" || die "translation failed"
+}
+
+src_compile() {
+ emake -C "${T}"/usession*-0/testing_1
+}
+
+src_install() {
+ cd "${T}"/usession*-0 || die
+ newbin "testing_1/pypy${PYVER}-c" "pypy${PYVER}-c-${PYPY_PV}"
+ insinto "/usr/include/pypy${PYVER}/${PYPY_PV}"
+ doins *.h
+ pax-mark m "${ED}/usr/bin/pypy${PYVER}-c-${PYPY_PV}"
+}