summaryrefslogtreecommitdiff
path: root/dev-python/pypy3/pypy3-7.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
commitfc637fb28da700da71ec2064d65ca5a7a31b9c6c (patch)
tree326613a08f25851c388715e205576a2e7d25dc4f /dev-python/pypy3/pypy3-7.1.1.ebuild
parentb24bd25253fe093f722ab576d29fdc41d04cb1ee (diff)
gentoo resync : 18.08.2019
Diffstat (limited to 'dev-python/pypy3/pypy3-7.1.1.ebuild')
-rw-r--r--dev-python/pypy3/pypy3-7.1.1.ebuild25
1 files changed, 23 insertions, 2 deletions
diff --git a/dev-python/pypy3/pypy3-7.1.1.ebuild b/dev-python/pypy3/pypy3-7.1.1.ebuild
index f0f7cdf74a2a..344f0da4013e 100644
--- a/dev-python/pypy3/pypy3-7.1.1.ebuild
+++ b/dev-python/pypy3/pypy3-7.1.1.ebuild
@@ -17,7 +17,8 @@ LICENSE="MIT"
# pypy3 -c 'import sysconfig; print(sysconfig.get_config_var("SOABI"))'
SLOT="0/71-py36"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="bzip2 gdbm +jit libressl low-memory ncurses sandbox sqlite tk"
+IUSE="bzip2 cpu_flags_x86_sse2 gdbm +jit libressl low-memory ncurses
+ sandbox sqlite tk"
RDEPEND=">=sys-libs/zlib-1.1.3:0=
virtual/libffi:0=
@@ -103,12 +104,32 @@ src_prepare() {
src_configure() {
tc-export CC
+ local jit_backend
+ if use jit; then
+ jit_backend='--jit-backend='
+
+ # We only need the explicit sse2 switch for x86.
+ # On other arches we can rely on autodetection which uses
+ # compiler macros. Plus, --jit-backend= doesn't accept all
+ # the modern values...
+
+ if use x86; then
+ if use cpu_flags_x86_sse2; then
+ jit_backend+=x86
+ else
+ jit_backend+=x86-without-sse2
+ fi
+ else
+ jit_backend+=auto
+ fi
+ fi
+
local args=(
--shared
$(usex jit -Ojit -O2)
$(usex sandbox --sandbox '')
- --jit-backend=auto
+ ${jit_backend}
pypy/goal/targetpypystandalone
)