summaryrefslogtreecommitdiff
path: root/dev-python/pypy3-exe
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-24 19:11:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-24 19:11:10 +0000
commit73f18fd49d6fabbb1dc8721e38adaa18d55b8c95 (patch)
treecbf8d9cc42f02646bddfb5b06d3a9591e8df3ad5 /dev-python/pypy3-exe
parentc92d0cd2b34d17bce6d5bb4e3a4fc00af4193c99 (diff)
gentoo auto-resync : 24:11:2022 - 19:11:10
Diffstat (limited to 'dev-python/pypy3-exe')
-rw-r--r--dev-python/pypy3-exe/Manifest3
-rw-r--r--dev-python/pypy3-exe/pypy3-exe-7.3.10_rc3.ebuild158
2 files changed, 161 insertions, 0 deletions
diff --git a/dev-python/pypy3-exe/Manifest b/dev-python/pypy3-exe/Manifest
index 28c8008a13a9..ca9d06ecb693 100644
--- a/dev-python/pypy3-exe/Manifest
+++ b/dev-python/pypy3-exe/Manifest
@@ -1,4 +1,7 @@
+DIST pypy3.9-gentoo-patches-7.3.10rc3.tar.xz 8712 BLAKE2B 65c5461b4830cd8ee29512d9ce5f7ac9e629710b5177a568f52657e92eefe7d7f1ba3321bd3ee91e94bbccd090ae9b14180617b059b761b0497b1825d66e65f6 SHA512 61fe98885fdd17c03c16316930f277f804dd6a2aa70a9c51ac5287d16c0b53eac58d0db2a55b28bdea1b0ac2a04d9a408343e321f44c57037b747dd76569d3a2
DIST pypy3.9-gentoo-patches-7.3.9_p6.tar.xz 13740 BLAKE2B 0200eb697f4efb0ee47f7ba053f5d8fe45cad317a665637cad8a429327f084e1d4366c44ead4eeb0c4ead1e3d284bee39b1f3b9665de5882004ca8b0f0b90a64 SHA512 961b79074fc1c37e13b8a6cd370b716103fbc942163e2030475317d966c3bedf73876b23751da82dbd759324ff64e06348a167a1ef84adb4b444b2ff1a5b742e
+DIST pypy3.9-v7.3.10rc3-src.tar.bz2 23453446 BLAKE2B eefedc5d49602f19c9d39f20f060ddb4f00bd49681fee64fa98a7c7a3856df7f4ae4e17e51a3fa37137d049b463855ce7e2c95abd9878665b66fc9b90a91ec6c SHA512 d831c8c716f40514e54845ec7ab6b3ecf1af74bc66504196dda251d66feff4e206c77535484ef1747dc390db2bdc2be38e9be3401831b321ea043016e42c2a27
DIST pypy3.9-v7.3.9-src.tar.bz2 26976726 BLAKE2B bf1ed21c575901abac020120aaff07ab57f1404713211b19cbd1eb4d6ffc675b7933be8c6fffc2b69ab467963d6598534cd5aa90c02feddad596611d2a6b6581 SHA512 83f8a6a2da351c190d2d224242cbc35e35529c7a8e8d842eaf5c945cbce2e172b02a340f32af3d49df8d5288370d794d5bc95fc12dd4a13d817c925abf06198a
+EBUILD pypy3-exe-7.3.10_rc3.ebuild 3533 BLAKE2B b46b781ffffa86a6c3802533489154f0599ac204dfa64908a5dd6c763a407572c080ba072165481cd87dbb34042995665d4996baf65bbacc71e129411ff90e13 SHA512 7f88f21375aeb4189b2d40def0183adbd90727b9cd45a45e54f5384e766ac2015654567b451ba20d837cde40281e212aa12e5f4e2152fff1f3cf0d71e86fdbb5
EBUILD pypy3-exe-7.3.9_p3.ebuild 3586 BLAKE2B 6b9920e9197e2926e88c38244bf2a1280ec9492cc08317a109c3143e94e85c230599d31d795e8ea0b05a0be3fcaaaf6cb00b2a1282603e113f019f7ffbe72188 SHA512 d271c300a8af93854a396eb1ecc1c390887dc597a6956512ea77759a7abdad4245530d11ffb434d5511cd81319b18e301fc8c29399afc253b189192950f36a2c
MISC metadata.xml 498 BLAKE2B 8dbcdb7c3a4a2fa5d1a922fd5197fb5e3337adcaec1e7d382f25f8696c80726e5b79843477bf8e5ce131aecde6e2c4c283548c5b337e54cb58aaa066013c445a SHA512 8a9bb514bbf3bf328aa63734e1fdc106f6aaf5ccb88c29ad8a686ab2724f3d1f4727163500013dd16e7b34232b881cf47d2f174212b5428ee076af27cf43628d
diff --git a/dev-python/pypy3-exe/pypy3-exe-7.3.10_rc3.ebuild b/dev-python/pypy3-exe/pypy3-exe-7.3.10_rc3.ebuild
new file mode 100644
index 000000000000..805ec9fcf901
--- /dev/null
+++ b/dev-python/pypy3-exe/pypy3-exe-7.3.10_rc3.ebuild
@@ -0,0 +1,158 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# pypy3 needs to be built using python 2
+PYTHON_COMPAT=( python2_7 )
+inherit check-reqs pax-utils python-any-r1 toolchain-funcs
+
+PYPY_PV=${PV%_p*}
+MY_P=pypy3.9-v${PYPY_PV/_}
+PATCHSET="pypy3.9-gentoo-patches-${PV/_}"
+
+DESCRIPTION="PyPy3 executable (build from source)"
+HOMEPAGE="https://www.pypy.org/"
+SRC_URI="
+ https://buildbot.pypy.org/pypy/${MY_P}-src.tar.bz2
+ https://dev.gentoo.org/~mgorny/dist/python/${PATCHSET}.tar.xz
+"
+S="${WORKDIR}/${MY_P}-src"
+
+LICENSE="MIT"
+SLOT="3.9-${PYPY_PV}"
+KEYWORDS=""
+IUSE="+jit low-memory ncurses cpu_flags_x86_sse2"
+
+RDEPEND="
+ app-arch/bzip2:0=
+ dev-libs/expat:0=
+ dev-libs/libffi:0=
+ >=sys-libs/zlib-1.1.3:0=
+ virtual/libintl:0=
+ ncurses? ( sys-libs/ncurses:0= )
+ !dev-python/pypy3-exe-bin:${SLOT}
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ low-memory? ( dev-python/pypy )
+ !low-memory? (
+ || (
+ dev-python/pypy
+ dev-lang/python:2.7
+ )
+ )
+"
+
+check_env() {
+ if use low-memory; then
+ CHECKREQS_MEMORY="1750M"
+ use amd64 && CHECKREQS_MEMORY="3500M"
+ else
+ CHECKREQS_MEMORY="3G"
+ use amd64 && CHECKREQS_MEMORY="6G"
+ fi
+
+ check-reqs_pkg_pretend
+}
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && check_env
+}
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ check_env
+
+ # unset to allow forcing pypy below :)
+ use low-memory && EPYTHON=
+ if [[ ! ${EPYTHON} || ${EPYTHON} == pypy ]] &&
+ { has_version -b dev-python/pypy ||
+ has_version -b dev-python/pypy-bin; }
+ then
+ einfo "Using PyPy to perform the translation."
+ EPYTHON=pypy
+ else
+ einfo "Using ${EPYTHON:-python2} to perform the translation. Please note that upstream"
+ einfo "recommends using PyPy for that. If you wish to do so, please install"
+ einfo "dev-python/pypy and ensure that EPYTHON variable is unset."
+ python-any-r1_pkg_setup
+ fi
+ fi
+}
+
+src_prepare() {
+ local PATCHES=(
+ "${WORKDIR}/${PATCHSET}"
+ )
+ default
+}
+
+src_configure() {
+ tc-export CC
+
+ local jit_backend
+ if use jit; then
+ jit_backend='--jit-backend='
+
+ # We only need the explicit sse2 switch for x86.
+ # On other arches we can rely on autodetection which uses
+ # compiler macros. Plus, --jit-backend= doesn't accept all
+ # the modern values...
+
+ if use x86; then
+ if use cpu_flags_x86_sse2; then
+ jit_backend+=x86
+ else
+ jit_backend+=x86-without-sse2
+ fi
+ else
+ jit_backend+=auto
+ fi
+ fi
+
+ local args=(
+ --no-shared
+ $(usex jit -Ojit -O2)
+
+ ${jit_backend}
+
+ pypy/goal/targetpypystandalone
+ --withmod-bz2
+ $(usex ncurses --with{,out}mod-_minimal_curses)
+ )
+
+ local interp=( "${EPYTHON}" )
+ if use low-memory; then
+ interp=( env PYPY_GC_MAX_DELTA=200MB
+ "${EPYTHON}" --jit loop_longevity=300 )
+ fi
+
+ if [[ ${EPYTHON} != pypy ]]; then
+ # reuse bundled pycparser to avoid external dep
+ mkdir -p "${T}"/pymod || die
+ cp -r lib_pypy/cffi/_pycparser "${T}"/pymod/pycparser || die
+ local -x PYTHONPATH=${T}/pymod:${PYTHONPATH}
+ fi
+
+ # translate into the C sources
+ # we're going to build them ourselves since otherwise pypy does not
+ # free up the unneeded memory before spawning the compiler
+ set -- "${interp[@]}" rpython/bin/rpython --batch --source "${args[@]}"
+ echo -e "\033[1m${@}\033[0m"
+ "${@}" || die "translation failed"
+}
+
+src_compile() {
+ emake -C "${T}"/usession*-0/testing_1
+}
+
+src_install() {
+ cd "${T}"/usession*-0 || die
+ newbin testing_1/pypy3.9-c pypy3.9-c-${PYPY_PV}
+ insinto /usr/include/pypy3.9/${PYPY_PV}
+ doins *.h
+ pax-mark m "${ED}/usr/bin/pypy3.9-c-${PYPY_PV}"
+}