summaryrefslogtreecommitdiff
path: root/dev-python/pypy-exe
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-24 19:11:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-24 19:11:10 +0000
commit73f18fd49d6fabbb1dc8721e38adaa18d55b8c95 (patch)
treecbf8d9cc42f02646bddfb5b06d3a9591e8df3ad5 /dev-python/pypy-exe
parentc92d0cd2b34d17bce6d5bb4e3a4fc00af4193c99 (diff)
gentoo auto-resync : 24:11:2022 - 19:11:10
Diffstat (limited to 'dev-python/pypy-exe')
-rw-r--r--dev-python/pypy-exe/Manifest3
-rw-r--r--dev-python/pypy-exe/pypy-exe-7.3.10_rc3.ebuild185
2 files changed, 188 insertions, 0 deletions
diff --git a/dev-python/pypy-exe/Manifest b/dev-python/pypy-exe/Manifest
index 29ce4efbf085..0637fb8fdb5e 100644
--- a/dev-python/pypy-exe/Manifest
+++ b/dev-python/pypy-exe/Manifest
@@ -1,4 +1,7 @@
+DIST pypy2.7-gentoo-patches-7.3.10rc3.tar.xz 5324 BLAKE2B 83675b7d2aa0eaace337308e9d818e1d745471a72bd67f269265b06b40a2fb62e26aedd2489ceaf02eb15dd655277dcf8fc3fe280d83d636afb0a69eb2b35795 SHA512 7fdf4fc2f7fdd8accd8af6f8713c6db55510be7a129e608ef0a7c30cd8db74f2711ded41daae3d2d698e394a146996cf699d87147a5d433a2321bcb7682c15b7
DIST pypy2.7-gentoo-patches-7.3.9_p1.tar.xz 7832 BLAKE2B d04fc46ab9dc8b212ed3783c1ce49d72f96dfde754da67cc97ea0c193e7ad7f5f8fdd68561b93ef0b22dde86ec3f848ee8ec8a3d78d925b6d96abd2d88d34c14 SHA512 b9d2ccccab34a5027f68e1429ff6862a0172cf8cc9eaef5e4eaa3eb091d9c2751701dbe1f61481fd84d08cb3d5bafb40a5c753906c17dc2a57bfc28acd673e1a
+DIST pypy2.7-v7.3.10rc3-src.tar.bz2 19776339 BLAKE2B a6866a0ff7a7b4bb3e1815fdc741cc95ff7945f6271e0189b6d16d1efc64c72a75a1400c3859a5b8c5f5b176217463a446b3449093572df59e13df15a207828f SHA512 097d57862728197e648cf38380ce4a60d6192bc9f2c0c2cf6840717af0320acd8cf42e344513428be60f60e136d830a0bb5d6295e7909cd7f3a42bac992c780a
DIST pypy2.7-v7.3.9-src.tar.bz2 23328628 BLAKE2B 50d015439b6a6f15dd24eb4524726a2054f0d8e7ef209b54dc4eb9365b41b333f3dad525422316af3ff19e6ffb5866859db4455e05fc1529a81ce3b6e7c621db SHA512 8d7513d4efe924f2456dd65a45a82dd16171f7962c81ba90f2a168c332cdad78ceffa3ed1af379c09e61082b39d5c2a8385cd77c89b698c47cc75e9df1bb4d2a
+EBUILD pypy-exe-7.3.10_rc3.ebuild 4267 BLAKE2B 7ac8a62309e49b4cdb7e8e63df2f561a162e821afefb29e0ce3a8389b2bceaac8630c36e603900f98fc3c32fbcf1fb22df04635ce1822b2fbd93ea23b24a02b8 SHA512 b495f6771e909358e30efc1d2dc686f08ed0163493cd231a99cd91471d1c94c820915f6197fe60317846c382e44fc080b829fccaa15138c2fd0fa32a328ecef0
EBUILD pypy-exe-7.3.9.ebuild 4317 BLAKE2B ac746e40592066d98eef14f51360fda83e94395feeb2681fa833dfd9136d9e526d9939c1448f59674e1eb744bd95e19215199fcfdc7095f9419ec5dda832981b SHA512 78d8dd56fb7722f3e5bde06e5c2e9079198258912c1657d7bee0e2f013ca4963018b8978c0faeb2a674ea3c743b82d1aa2dcae39b76ee6737bf1545023d282cd
MISC metadata.xml 498 BLAKE2B 8dbcdb7c3a4a2fa5d1a922fd5197fb5e3337adcaec1e7d382f25f8696c80726e5b79843477bf8e5ce131aecde6e2c4c283548c5b337e54cb58aaa066013c445a SHA512 8a9bb514bbf3bf328aa63734e1fdc106f6aaf5ccb88c29ad8a686ab2724f3d1f4727163500013dd16e7b34232b881cf47d2f174212b5428ee076af27cf43628d
diff --git a/dev-python/pypy-exe/pypy-exe-7.3.10_rc3.ebuild b/dev-python/pypy-exe/pypy-exe-7.3.10_rc3.ebuild
new file mode 100644
index 000000000000..e5db7a520127
--- /dev/null
+++ b/dev-python/pypy-exe/pypy-exe-7.3.10_rc3.ebuild
@@ -0,0 +1,185 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python2_7 )
+inherit check-reqs pax-utils python-any-r1 toolchain-funcs
+
+PYPY_PV=${PV%_p*}
+MY_P=pypy2.7-v${PYPY_PV/_}
+PATCHSET="pypy2.7-gentoo-patches-${PV/_}"
+
+DESCRIPTION="PyPy executable (build from source)"
+HOMEPAGE="https://www.pypy.org/"
+SRC_URI="
+ https://buildbot.pypy.org/pypy/${MY_P}-src.tar.bz2
+ https://dev.gentoo.org/~mgorny/dist/python/${PATCHSET}.tar.xz
+"
+S="${WORKDIR}/${MY_P}-src"
+
+LICENSE="MIT"
+SLOT="${PYPY_PV}"
+KEYWORDS=""
+IUSE="bzip2 +jit low-memory ncurses cpu_flags_x86_sse2"
+
+RDEPEND="
+ >=sys-libs/zlib-1.1.3:0=
+ dev-libs/libffi:0=
+ virtual/libintl:0=
+ dev-libs/expat:0=
+ bzip2? ( app-arch/bzip2:0= )
+ ncurses? ( sys-libs/ncurses:0= )
+ !dev-python/pypy-exe-bin:${PYPY_PV}
+"
+# don't enforce the dep on pypy with USE=low-memory since it's going
+# to cause either collisions or circular dep on itself
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ !low-memory? (
+ || (
+ dev-python/pypy
+ dev-lang/python:2.7
+ )
+ )
+"
+
+check_env() {
+ if use low-memory; then
+ if ! has_version -b dev-python/pypy &&
+ ! has_version -b dev-python/pypy-bin
+ then
+ eerror "USE=low-memory requires a (possibly old) version of dev-python/pypy"
+ eerror "being installed. Please install it using e.g.:"
+ eerror
+ eerror " $ emerge -1v dev-python/pypy dev-python/pypy-exe-bin"
+ eerror
+ eerror "before attempting to build dev-python/pypy-exe[low-memory]."
+ die "dev-python/pypy needs to be installed for USE=low-memory"
+ fi
+
+ CHECKREQS_MEMORY="1750M"
+ use amd64 && CHECKREQS_MEMORY="3500M"
+ else
+ CHECKREQS_MEMORY="3G"
+ use amd64 && CHECKREQS_MEMORY="6G"
+ fi
+
+ check-reqs_pkg_pretend
+}
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && check_env
+}
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ check_env
+
+ use low-memory && EPYTHON=
+ if [[ ! ${EPYTHON} || ${EPYTHON} == pypy ]] &&
+ { has_version -b dev-python/pypy ||
+ has_version -b dev-python/pypy-bin; }
+ then
+ einfo "Using already-installed PyPy to perform the translation."
+ EPYTHON=pypy
+ else
+ einfo "Using ${EPYTHON} to perform the translation. Please note that upstream"
+ einfo "recommends using PyPy for that. If you wish to do so, please unset"
+ einfo "the EPYTHON variable."
+ python-any-r1_pkg_setup
+ fi
+ fi
+}
+
+src_prepare() {
+ local PATCHES=(
+ "${WORKDIR}/${PATCHSET}"
+ )
+ default
+}
+
+src_configure() {
+ tc-export CC
+
+ local jit_backend
+ if use jit; then
+ jit_backend='--jit-backend='
+
+ # We only need the explicit sse2 switch for x86.
+ # On other arches we can rely on autodetection which uses
+ # compiler macros. Plus, --jit-backend= doesn't accept all
+ # the modern values...
+
+ if use x86; then
+ if use cpu_flags_x86_sse2; then
+ jit_backend+=x86
+ else
+ jit_backend+=x86-without-sse2
+ fi
+ else
+ jit_backend+=auto
+ fi
+ fi
+
+ local args=(
+ --no-shared
+ $(usex jit -Ojit -O2)
+
+ ${jit_backend}
+
+ pypy/goal/targetpypystandalone
+ )
+
+ # Avoid linking against libraries disabled by use flags
+ local opts=(
+ bzip2:bz2
+ ncurses:_minimal_curses
+ )
+
+ local opt
+ for opt in "${opts[@]}"; do
+ local flag=${opt%:*}
+ local mod=${opt#*:}
+
+ args+=(
+ $(usex ${flag} --withmod --withoutmod)-${mod}
+ )
+ done
+
+ local interp=( "${EPYTHON}" )
+ if use low-memory; then
+ interp=( env PYPY_GC_MAX_DELTA=200MB
+ "${EPYTHON}" --jit loop_longevity=300 )
+ fi
+
+ if [[ ${EPYTHON} != pypy ]]; then
+ # reuse bundled pycparser to avoid external dep
+ mkdir -p "${T}"/pymod/cffi || die
+ : > "${T}"/pymod/cffi/__init__.py || die
+ cp -r lib_pypy/cffi/_pycparser "${T}"/pymod/cffi/ || die
+ local -x PYTHONPATH=${T}/pymod:${PYTHONPATH}
+ fi
+
+ # translate into the C sources
+ # we're going to build them ourselves since otherwise pypy does not
+ # free up the unneeded memory before spawning the compiler
+ set -- "${interp[@]}" rpython/bin/rpython --batch --source "${args[@]}"
+ echo -e "\033[1m${@}\033[0m"
+ "${@}" || die "translation failed"
+}
+
+src_compile() {
+ emake -C "${T}"/usession*-0/testing_1
+}
+
+src_install() {
+ local dest=/usr/lib/pypy2.7
+ exeinto "${dest}"
+ newexe "${T}"/usession*-0/testing_1/pypy-c pypy-c-${PYPY_PV}
+ insinto "${dest}"/include/${PYPY_PV}
+ doins include/pypy_*
+ pax-mark m "${ED}${dest}/pypy-c-${PYPY_PV}"
+}