summaryrefslogtreecommitdiff
path: root/dev-python/pypugjs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
commit2fd57282f0262ca084e05b0f2c63fbada395d02b (patch)
tree4e0f23cea9ce9fd972e70ebc5214bf36fed465cc /dev-python/pypugjs
parentc3bc61051d7f12b4c682efa7a5460bbc8815649e (diff)
gentoo resync : 16.01.2021
Diffstat (limited to 'dev-python/pypugjs')
-rw-r--r--dev-python/pypugjs/Manifest2
-rw-r--r--dev-python/pypugjs/pypugjs-5.9.10.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/pypugjs/Manifest b/dev-python/pypugjs/Manifest
index 449bd5ce7d2f..c41880a433b6 100644
--- a/dev-python/pypugjs/Manifest
+++ b/dev-python/pypugjs/Manifest
@@ -1,3 +1,5 @@
+DIST pypugjs-5.9.10.tar.gz 48890 BLAKE2B 474a7d4bffaac17e282d7cd910cafc58d9d25d2d1250159cafe454e6a706eaaa9937c31129061c96b8a1f5eb008344e446ea3d86d0e9f02cefc614653ce6cdfe SHA512 f7bfe3567c40f485e048710c31d40ed008a85353f48169056a6f5e48907bf7999b0142b32b45ff413e08aef81811039af9384c86c259adb4d8458cbca422eefb
DIST pypugjs-5.9.9.tar.gz 49022 BLAKE2B 26bdad4bd951eb8e515a0c181a56f68a8fdf8131dbd9e61c32c266bd91575143006f3cb6c2f477a2406110b22ed279a1167821a1b1f403a73bb333013173db2a SHA512 f34fab60e4f9d0680a36e5d2a28c5f99668c13b296a1bb70778dced235d223c592d49adbadc2f70b1a7e350f28a2f29dbce8febe2b8e99d60a0e050254180c71
+EBUILD pypugjs-5.9.10.ebuild 1117 BLAKE2B 4b3a9425c683be947ac5421d8c2dbc43f664ba330bf9f5e8ad597aa40060b8b2b7259858b0dbb0167f3e14949f78a047a0e0648db337ee6b3ae212d3e793eb2d SHA512 c06c1af016fd843fc302b7ececafd967a084a8728df63529cbb0a459f9633f479f2e325b1e15a4382e49adf2c9c086009cb0996ec17da8ae002b87f15cbb46f5
EBUILD pypugjs-5.9.9.ebuild 1117 BLAKE2B 81d4c83a00f438b23a5e3e969291309d61185b5c7559f626c5d53746a0c6161d84fb5451321bf533bae5b94cabfae48fbb1ee48867f8c5ede4ccbd8e0cfd81da SHA512 1e3894ecafdaa82d6af1c928f026e3711186e2344def94c791bd5022163935fa0dbed8ab6040986ce3640bf6f8b29b7f3d22bd8c36989d24f1d69a2b69157080
MISC metadata.xml 755 BLAKE2B 9ff779edea415203b9433d398d03a465465e53dd1cf767914d870b1e0388f691d40e30eab978485373835a959d2104e41d1918c99bceb09063b671566149e4c1 SHA512 a8b75ce0bfa50bdfa05ed7744e1600c1e427f5b850fadcb2631d041d78beb48291726e87c981cc0594e8d56ef7a53255db4a32cb32c4965a4f9ba6f558c49618
diff --git a/dev-python/pypugjs/pypugjs-5.9.10.ebuild b/dev-python/pypugjs/pypugjs-5.9.10.ebuild
new file mode 100644
index 000000000000..d56f4b88fa06
--- /dev/null
+++ b/dev-python/pypugjs/pypugjs-5.9.10.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Pug (Jade) syntax adapter for Django, Jinja2 and Mako templates"
+HOMEPAGE="https://github.com/kakulukia/pypugjs"
+SRC_URI="https://github.com/kakulukia/pypugjs/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests nose
+
+src_prepare() {
+ # Remove pyramid backend as pyramid isn't packaged
+ rm -r pypugjs/ext/pyramid || die
+ distutils-r1_src_prepare
+}
+
+pkg_postinst() {
+ optfeature "converting to Django output" dev-python/django
+ optfeature "converting to Jinja2 output" dev-python/jinja
+ optfeature "converting to Mako output" dev-python/mako
+ optfeature "converting to Tornado output" www-servers/tornado
+}