summaryrefslogtreecommitdiff
path: root/dev-python/pypugjs/pypugjs-5.9.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-14 06:50:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-14 06:50:14 +0000
commitafa8da78d8135ca28150730e9c60af9d875f0a5b (patch)
tree65e94479f29d7591a1bc1d09d1fc1913d785fe6b /dev-python/pypugjs/pypugjs-5.9.11.ebuild
parent4828c25c25aacf399de429d381288982fd7e0d0e (diff)
gentoo auto-resync : 14:11:2022 - 06:50:13
Diffstat (limited to 'dev-python/pypugjs/pypugjs-5.9.11.ebuild')
-rw-r--r--dev-python/pypugjs/pypugjs-5.9.11.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/pypugjs/pypugjs-5.9.11.ebuild b/dev-python/pypugjs/pypugjs-5.9.11.ebuild
deleted file mode 100644
index b2806c1c31a9..000000000000
--- a/dev-python/pypugjs/pypugjs-5.9.11.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1 optfeature
-
-DESCRIPTION="Pug (Jade) syntax adapter for Django, Jinja2 and Mako templates"
-HOMEPAGE="https://github.com/kakulukia/pypugjs"
-SRC_URI="https://github.com/kakulukia/pypugjs/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~riscv"
-
-RDEPEND="
- >=dev-python/six-1.15.0[${PYTHON_USEDEP}]
- >=dev-python/chardet-4.0.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/django[${PYTHON_USEDEP}]
- >=dev-python/jinja-3.1.1[${PYTHON_USEDEP}]
- >=dev-python/mako-1.1.3[${PYTHON_USEDEP}]
- >=dev-python/tornado-6.0.4[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests nose
-
-src_prepare() {
- # Remove pyramid backend as pyramid isn't packaged
- rm -r pypugjs/ext/pyramid || die
- distutils-r1_src_prepare
-}
-
-pkg_postinst() {
- optfeature "converting to Django output" dev-python/django
- optfeature "converting to Jinja2 output" dev-python/jinja
- optfeature "converting to Mako output" dev-python/mako
- optfeature "converting to Tornado output" dev-python/tornado
-}