summaryrefslogtreecommitdiff
path: root/dev-python/pyptlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pyptlib
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pyptlib')
-rw-r--r--dev-python/pyptlib/Manifest3
-rw-r--r--dev-python/pyptlib/metadata.xml11
-rw-r--r--dev-python/pyptlib/pyptlib-0.0.6.ebuild29
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pyptlib/Manifest b/dev-python/pyptlib/Manifest
new file mode 100644
index 000000000000..71cf93866f65
--- /dev/null
+++ b/dev-python/pyptlib/Manifest
@@ -0,0 +1,3 @@
+DIST pyptlib-0.0.6.tar.gz 239316 BLAKE2B 117851d5ce59e1eed4b37beef4b6b18135d693670fe50d70fddcd72ea3da2ad9eeca7c1002ff4ea0b0a3aab8e1414c63134e022c78f69dea6e6016aa368bdd91 SHA512 f54ee3ae51f2d6884b0157f8cec3e9af267f926e50728478b961551d069fc6c4a2840d59e74d5b0f93b4bb305d9f91f31b91fa4425d1931688ffc5783f6192f9
+EBUILD pyptlib-0.0.6.ebuild 745 BLAKE2B f8794636165add86b0958dbf2346775ed604a34e7c8e9ea39cad026c47310dc60f3688309ed3f3df49ad4287a58bfcf4525256f8ea6c7103b674e8a8e3bcc5f5 SHA512 177b0d47cb34619141b9185ea11e9aec03136265784ec8dfe4e92919f1fbf63e02f619c7c88561cd77861c1ebeed892b7185c556e81a84a740e9edcc302e3a14
+MISC metadata.xml 332 BLAKE2B 3a6cfed2be64b20bbf40950f4e40933ea66688d5e6fa80b8c5021356991dc1cfa779f468a32aa20db40dcfe6ec7bddb2dbb8b39ca8e628f3bf9e7d3bb05bb883 SHA512 d60850dcff84f4105ca91f7675403c64e3ec14e11f186282239623b0d58b47c0379cf3af19e0f440b2564d037a80d52c8abe89a4e415b5eaf43b66c6b1748a1f
diff --git a/dev-python/pyptlib/metadata.xml b/dev-python/pyptlib/metadata.xml
new file mode 100644
index 000000000000..c298cbef539c
--- /dev/null
+++ b/dev-python/pyptlib/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pyptlib</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyptlib/pyptlib-0.0.6.ebuild b/dev-python/pyptlib/pyptlib-0.0.6.ebuild
new file mode 100644
index 000000000000..a5195aa22f60
--- /dev/null
+++ b/dev-python/pyptlib/pyptlib-0.0.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for tor's pluggable transport managed-proxy protocol"
+HOMEPAGE="https://gitweb.torproject.org/pluggable-transports/pyptlib.git"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~x86"
+IUSE="doc examples"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DOCS=( README.rst TODO )
+
+python_test() {
+ "${PYTHON}" -m unittest discover || die "tests failed"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}