summaryrefslogtreecommitdiff
path: root/dev-python/pyptlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/pyptlib
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/pyptlib')
-rw-r--r--dev-python/pyptlib/Manifest5
-rw-r--r--dev-python/pyptlib/metadata.xml11
-rw-r--r--dev-python/pyptlib/pyptlib-0.0.6.ebuild29
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/pyptlib/Manifest b/dev-python/pyptlib/Manifest
new file mode 100644
index 000000000000..1b6ce4274cc1
--- /dev/null
+++ b/dev-python/pyptlib/Manifest
@@ -0,0 +1,5 @@
+DIST pyptlib-0.0.6.tar.gz 239316 SHA256 b98472e3d9e8f4689d3913ca8f89afa5e6cc5383dcd8686987606166f9dac607 SHA512 f54ee3ae51f2d6884b0157f8cec3e9af267f926e50728478b961551d069fc6c4a2840d59e74d5b0f93b4bb305d9f91f31b91fa4425d1931688ffc5783f6192f9 WHIRLPOOL 1144479085e6f9a762638e6b0adee886b7446362233e246a494523ef53afeb394f6d00db0d5cb425491ae1f2e2db60499c05d03a162079e6357deb224bb938ef
+EBUILD pyptlib-0.0.6.ebuild 745 SHA256 cd9c096e5f4983483093b3d240f27e24d11ab418842d343039da6bc4b21e82e7 SHA512 177b0d47cb34619141b9185ea11e9aec03136265784ec8dfe4e92919f1fbf63e02f619c7c88561cd77861c1ebeed892b7185c556e81a84a740e9edcc302e3a14 WHIRLPOOL 1e3616acefdd5a013669256ec6bc569a17a8a508df3d90f790a0c7aab1d8f65cf262e38f52c4ef6aed0a22e42f7d308975fbcf9a2ffc462f5b2de7012fbc3ea2
+MISC ChangeLog 2178 SHA256 842c0563fcd974956ce523650fdd00a035f1f4f22ca0ececc38cb43d270e305d SHA512 92d4f8ff1af67769443c4b428f1fc5421bea8697174547cd790ef42d58725ab50c344ba56fa52c85ca48041f279eba45ea3138f22ec5f42975c9347394c7577c WHIRLPOOL aa300fe223a11502ac73a1148c97bb8cbdfeeeedf11a79d36b8f5648143c2b3b76e27f37acbe7d6bbc2a738ad2f6e83b7886c8000679836957afbf4212381759
+MISC ChangeLog-2015 795 SHA256 f1a36e42246e95710d5231bd57bb31ff0823544c2e1d4a5f126f81f63554c5a3 SHA512 96782a297810a0904e07ce00c1ea9c85762110603e08115e5f4bc3a975b05ad1f4f412e4f16c2e46f0ae7d38dbd4229ed8c9ff7eebcc40fa12831853f6237022 WHIRLPOOL 84ad24600175a69c29049a195e7ea179926d3bfc00ab8f6dc5cec4cf71a521dd76be459094dd68947f25db7ecb2efe86a654ffbc475df75dab2ef570f6fe2d34
+MISC metadata.xml 332 SHA256 3fcad420aed9f4632933e56e19e4a24d37129b049c15957247290d84fb6f18cb SHA512 d60850dcff84f4105ca91f7675403c64e3ec14e11f186282239623b0d58b47c0379cf3af19e0f440b2564d037a80d52c8abe89a4e415b5eaf43b66c6b1748a1f WHIRLPOOL a9d11aa4d19f1f19817fa7192fb46b33176ffd04159c166114c2424c565f9e13e9fe6f8c909f9521e55bd8446cfe0314da8553b4fb65f0a77c01c673f277159a
diff --git a/dev-python/pyptlib/metadata.xml b/dev-python/pyptlib/metadata.xml
new file mode 100644
index 000000000000..c298cbef539c
--- /dev/null
+++ b/dev-python/pyptlib/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pyptlib</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyptlib/pyptlib-0.0.6.ebuild b/dev-python/pyptlib/pyptlib-0.0.6.ebuild
new file mode 100644
index 000000000000..a5195aa22f60
--- /dev/null
+++ b/dev-python/pyptlib/pyptlib-0.0.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for tor's pluggable transport managed-proxy protocol"
+HOMEPAGE="https://gitweb.torproject.org/pluggable-transports/pyptlib.git"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~x86"
+IUSE="doc examples"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DOCS=( README.rst TODO )
+
+python_test() {
+ "${PYTHON}" -m unittest discover || die "tests failed"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}