summaryrefslogtreecommitdiff
path: root/dev-python/pyproject2setuppy/pyproject2setuppy-17.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-29 10:15:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-29 10:15:54 +0100
commit9aa80713372911cec499b3adb2cd746790920916 (patch)
treeb8e99dc5dd60ac2094a27cc52f74aada8df38f05 /dev-python/pyproject2setuppy/pyproject2setuppy-17.ebuild
parentb4d43e8c611df4a8061b6f88d9e9f6b1e3c83903 (diff)
gentoo resync : 29.06.2021
Diffstat (limited to 'dev-python/pyproject2setuppy/pyproject2setuppy-17.ebuild')
-rw-r--r--dev-python/pyproject2setuppy/pyproject2setuppy-17.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pyproject2setuppy/pyproject2setuppy-17.ebuild b/dev-python/pyproject2setuppy/pyproject2setuppy-17.ebuild
new file mode 100644
index 000000000000..bc478cc41369
--- /dev/null
+++ b/dev-python/pyproject2setuppy/pyproject2setuppy-17.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=manual
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Cheap setup.py hack to install flit & poetry-based projects"
+HOMEPAGE="https://github.com/mgorny/pyproject2setuppy"
+SRC_URI="
+ https://github.com/mgorny/pyproject2setuppy/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest