summaryrefslogtreecommitdiff
path: root/dev-python/pyproject-fmt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-30 08:57:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-30 08:57:14 +0000
commit552fc3ba95eab5c2c1a8b2b55ab432a1019739a0 (patch)
treeadad36adc624e114d5b985e392ac40a7b94d8ac6 /dev-python/pyproject-fmt
parent61966498b463d88a09132a9a22c68c0c37159e41 (diff)
gentoo auto-resync : 30:01:2023 - 08:57:13
Diffstat (limited to 'dev-python/pyproject-fmt')
-rw-r--r--dev-python/pyproject-fmt/Manifest2
-rw-r--r--dev-python/pyproject-fmt/pyproject-fmt-0.6.0.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pyproject-fmt/Manifest b/dev-python/pyproject-fmt/Manifest
index 8f3649e60995..8c41d79f30f2 100644
--- a/dev-python/pyproject-fmt/Manifest
+++ b/dev-python/pyproject-fmt/Manifest
@@ -1,5 +1,7 @@
DIST pyproject-fmt-0.4.1.gh.tar.gz 14853 BLAKE2B e06e3602290fdc4df00fb48dfe9d6d516a623ef29eaa535ab3b11754a577385611313172f207966b121f072a5b453774afcbf5e8699a0b7fd4426f5332e48e5a SHA512 f00999470e66e7f11e9299a902b686342fbad27a07634206011ff7712c7c422f9962d8a4eeffae6a6263712620b787bbdcd78c2129cb4b164631b56a45910363
DIST pyproject-fmt-0.5.0.gh.tar.gz 14906 BLAKE2B f75482988c8e10fbfcffaa518e6004f0e96b922e8bf929e43c7be26cf16149b3fa97a3070fabfbb90641ee3d953ab17bd854ba2e107b776f65f6bc802980bd54 SHA512 58ec7975f7c69990b1d2a0ee8a29681731d7143e59754343dc64e52e135cc5d280adf3c31b6818f042982697a7221a36aa0842ffba1ede28b57cefad77bf065c
+DIST pyproject-fmt-0.6.0.gh.tar.gz 15082 BLAKE2B 9ec7126530c98b984c5346bfd65fa817967dc7def60d16eb93e63ff690eaad53209d49483e19b5e87caf7b879f6661862a68606a0adb3b4513ff119262ff99a6 SHA512 50c9dcb468213de62e86edd500ae001815a83d8374ac1d36467fd7c560a5774862b001414f687d588fc0622ba5896c83338d6833ac4c248d2b4aa111fefe33ce
EBUILD pyproject-fmt-0.4.1.ebuild 864 BLAKE2B 8427fc3294f2f73ecedee5653a9077259f9f2e0f8860804396e877970cf65c859400b997bd89d11d04ce9fe657711899ce972f98f413de145abf774fa03c38cf SHA512 d95e86a7d3ded2fbc783a574313ba3af960f023fb7164a43a5583ba5f6f441c808019f1d633575f296d0ae3d0a8c13f8fe0f385ac7e57c2cc7ca0a51240ad1d7
EBUILD pyproject-fmt-0.5.0.ebuild 872 BLAKE2B 96641bb2330b5e1c929ca678171726efe2cb45ff7eabe9522b26863ff49b7730d200cbb9a17da5e107d0288a57f16f559ec43877a8830a0f1023be1a6404e778 SHA512 e9039e7b77ec6db80c5d7a7177e08bf702a454411b4bd21cb3f51a6dabb8fdbfa9c44bce0ae4d6c61b7de11a0c0e69ac1e489c61a72bef33c822eb3d28cde7df
+EBUILD pyproject-fmt-0.6.0.ebuild 869 BLAKE2B a0539489724d2079740af64ef020f0e69d50851c4bedcb0ab7dac5c41418391ff5f4d973e71ef71ba16109667d2168cfdd425970e99a7db413d0d2950388f3b0 SHA512 b6f4da4bbc9187e8843408b0b83704bed7547f03627aa957f99508aa1329789fc4d0188245b3e57994b38a0f1e3f1fdd4885aacbd043c9e77b9f01fda3028543
MISC metadata.xml 380 BLAKE2B f139b3f6c22d40d7c91b9b35db262813e299d1a3c1a1f8d6129e457fac62e3e7029a05315a3bddd9c4542764a33160c89b58b3b62f457efb088a7ae7cd86a936 SHA512 38bd0633defb67ee1831480c8b3896e158d0735ec74057b13b3c389cf26bd6ecb878f21d172f83293789d81ca2c30afedab8eaeb4ab1774b39972fdd5f805a81
diff --git a/dev-python/pyproject-fmt/pyproject-fmt-0.6.0.ebuild b/dev-python/pyproject-fmt/pyproject-fmt-0.6.0.ebuild
new file mode 100644
index 000000000000..a802c14c305f
--- /dev/null
+++ b/dev-python/pyproject-fmt/pyproject-fmt-0.6.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Format your pyproject.toml file"
+HOMEPAGE="
+ https://github.com/tox-dev/pyproject-fmt/
+ https://pypi.org/project/pyproject-fmt/
+"
+SRC_URI="
+ https://github.com/tox-dev/pyproject-fmt/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-23[${PYTHON_USEDEP}]
+ >=dev-python/tomlkit-0.11.6[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/pytest-mock-3.10[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}