summaryrefslogtreecommitdiff
path: root/dev-python/pyproject-fmt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-02 11:00:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-02 11:00:10 +0000
commit4c506c69909bdb43fda5e36c79b165e404d3b86b (patch)
treeb0f9d49fd462021c82f6ebbbbafb92e1a0eae3da /dev-python/pyproject-fmt
parent81f73a84efe20818880d8c52c55a3bd067115b06 (diff)
gentoo auto-resync : 02:12:2023 - 11:00:10
Diffstat (limited to 'dev-python/pyproject-fmt')
-rw-r--r--dev-python/pyproject-fmt/Manifest2
-rw-r--r--dev-python/pyproject-fmt/pyproject-fmt-1.5.3.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pyproject-fmt/Manifest b/dev-python/pyproject-fmt/Manifest
index f7aea5b5ab14..571166b56aaf 100644
--- a/dev-python/pyproject-fmt/Manifest
+++ b/dev-python/pyproject-fmt/Manifest
@@ -1,5 +1,7 @@
DIST pyproject_fmt-1.5.1.tar.gz 15639 BLAKE2B b625504295fce9fee9cfb09c821654edad8aa8e0537777f268f759ed8aeb6d2dd49e00b63c0e35e1d2a6946702c025ed5c15282ca8d2de5f479d373720273eef SHA512 12c3734ed2fab66f01c9cd2f5335cb4f925657f7c1f2cb8f7a3f9fdc73ec0746dd6b634cc1799b4dc4760d5b8061b4b30a06ae7030f94494792070674a2da338
DIST pyproject_fmt-1.5.2.tar.gz 15649 BLAKE2B 0765d072f0effbe805197e8c0ca082d8eb252ae2ea0d8965787eb746195f9420a2ce8c781b54c6e8300a3a3f5208f621aebea84623ecdf0ee6e7f9ce7a01ed35 SHA512 75c703cf05290cb3ee61bac581bf99100db7d8468f2a51c4a7d30ce572eeb13dbec61a87ff8eaedd07754b4eb4bdfa5f3565d96fcae8dc2187cd7dbf7225e6ab
+DIST pyproject_fmt-1.5.3.tar.gz 15678 BLAKE2B 624cfc0e62285c59fdb1a3315d1f419cbb8c41430957b9a5eeed2521899a66fa15a1aae476d2986e18d990e4f5fc901312a70df819765cf8b4e077cf3678d8dc SHA512 3f269525b5e3e818cea5ef7b90644c7ced9e37a1dff4a514782ebf7769f6f5a53887cb831b488ed34d059f197a9d90fccc887146f5180c58c5a702c37ae9d79b
EBUILD pyproject-fmt-1.5.1.ebuild 1037 BLAKE2B 7d49de346ada61178c1bff076053a7bd33904061648aefecaebd46c145693a5f3500252284fb5cd90393e2ca0840e1a1ce38ee7a7e7c599011a338f32ba84e28 SHA512 67bd92d4815b87884561c6bc2091bdc1214cae827e5c588e1bbff739a47475473a3e0454f2f8d5913eb15c0c5e8c7336a3100f0be8aa74ae815f6b32215135a3
EBUILD pyproject-fmt-1.5.2.ebuild 1045 BLAKE2B c914ab4658ff849055a10ab9bba136073dee119897ef3d74cf04f5583c2858bb00b63a16efdc713d57986be2dc869ab1ca555a03eb7cb3f210653edd777b68ee SHA512 65cc1ed712b09bdeb88bf4ed5bc4e5208d63a34db06999484cb436fc3178fc782cdd7c8b2466979fe40bd94f39abd1bd79bdf2334fc5fa2b83b9b0afef8bff50
+EBUILD pyproject-fmt-1.5.3.ebuild 1045 BLAKE2B c914ab4658ff849055a10ab9bba136073dee119897ef3d74cf04f5583c2858bb00b63a16efdc713d57986be2dc869ab1ca555a03eb7cb3f210653edd777b68ee SHA512 65cc1ed712b09bdeb88bf4ed5bc4e5208d63a34db06999484cb436fc3178fc782cdd7c8b2466979fe40bd94f39abd1bd79bdf2334fc5fa2b83b9b0afef8bff50
MISC metadata.xml 380 BLAKE2B f139b3f6c22d40d7c91b9b35db262813e299d1a3c1a1f8d6129e457fac62e3e7029a05315a3bddd9c4542764a33160c89b58b3b62f457efb088a7ae7cd86a936 SHA512 38bd0633defb67ee1831480c8b3896e158d0735ec74057b13b3c389cf26bd6ecb878f21d172f83293789d81ca2c30afedab8eaeb4ab1774b39972fdd5f805a81
diff --git a/dev-python/pyproject-fmt/pyproject-fmt-1.5.3.ebuild b/dev-python/pyproject-fmt/pyproject-fmt-1.5.3.ebuild
new file mode 100644
index 000000000000..c440d098979a
--- /dev/null
+++ b/dev-python/pyproject-fmt/pyproject-fmt-1.5.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Format your pyproject.toml file"
+HOMEPAGE="
+ https://github.com/tox-dev/pyproject-fmt/
+ https://pypi.org/project/pyproject-fmt/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/natsort[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/tomlkit[${PYTHON_USEDEP}]
+"
+# tox is called as a subprocess, to get targets from tox.ini
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/pytest-mock-3.10[${PYTHON_USEDEP}]
+ dev-python/tox
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # upstream lower bounds are completely meaningless and copying them
+ # to the ebuild is a horrible waste of time
+ sed -i -e 's:>=[0-9.]*::' pyproject.toml || die
+ distutils-r1_src_prepare
+}