summaryrefslogtreecommitdiff
path: root/dev-python/pyproj
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /dev-python/pyproj
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'dev-python/pyproj')
-rw-r--r--dev-python/pyproj/Manifest2
-rw-r--r--dev-python/pyproj/pyproj-3.1.0.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/pyproj/Manifest b/dev-python/pyproj/Manifest
index 2b0171424d2f..f46f7aaf4ab2 100644
--- a/dev-python/pyproj/Manifest
+++ b/dev-python/pyproj/Manifest
@@ -1,3 +1,5 @@
DIST pyproj-3.0.1.tar.gz 168962 BLAKE2B 3271d604148c122f4dfdd68c4237e1911f30da7cc858128d644b6b6807c3e49450e0b42c385d37bbe1cfa5ab80d635e7f620d41bf5089af6b49a542eb9b3fcd0 SHA512 f5ae0ede1deaa93757cb98cc680d6e47a19b9f5c0ce5e357c2ecfe96f764ff59ec7285c606162da38573123d21f12f1df82354f1d2205149970af2d7d63c2689
+DIST pyproj-3.1.0.tar.gz 182603 BLAKE2B d4e95f62b10b282e7bbfcb7a2059a11a489e53402cbb1760b7da73248dfc05de6be8ca820e55d34c9270eea38178f1fb934bd5ffc389833b3734b87b79991187 SHA512 21a5d08207676d8d9722cb5e3b13ed68f03b1a2aa034c20c61bb8dab5d204dd968ba9a3df1b0c43ed174e082725c7624efb75a0c9c3df920808cbcb44f4d170a
EBUILD pyproj-3.0.1.ebuild 1454 BLAKE2B baa1dd99d0e3c02662f1ea337583912d1d1978f4577dd548f1c7d12c6d7d539098324525d63bcaecc7eed9e2cbcc87bd0c80df36430e28d071897f5cf8b7a455 SHA512 45244a36fb061eb99c8fd56ab3e44aa047689e48e9279c2df2e26ad1f10271d2e67ed5eaf335d61e108e8e0ad86d9ad92ce2fc8cb7f8d2fead5f1f6e4faa750c
+EBUILD pyproj-3.1.0.ebuild 1440 BLAKE2B f9892cf54aff4df9d9972c91e0000118bba97814f19e95341fc8b3f5536fb52c1b055b4b20811b44109228f769f54e2b9ebd4e4787ac84e435cdaa2dcebcd929 SHA512 3def949e83675186e4620b8a87bce6438711622abcca7a48d67b9bfd2a7b573f1b4925d29ffc9bd59ae11277ee9c16804d16035fa86780bdbe8b3823c580c321
MISC metadata.xml 414 BLAKE2B 37b554706874ecf474f6fde6c09e4d7e466f2a22527e2851d3766518d0044dbbd2211f291851564541394a4d8f7d37f8216ae1c50cab8f662d3335d58c1ea142 SHA512 c117112962969a1cee0a9c3c7ec86942bfca1ef3eb9859b079ebdac743b691a954d7dc55ec729e141336c253abff8e0c7fcf1625279990cb87da87d732efe881
diff --git a/dev-python/pyproj/pyproj-3.1.0.ebuild b/dev-python/pyproj/pyproj-3.1.0.ebuild
new file mode 100644
index 000000000000..6061e44b117b
--- /dev/null
+++ b/dev-python/pyproj/pyproj-3.1.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Python interface to the PROJ library"
+HOMEPAGE="https://github.com/pyproj4/pyproj"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P/_p/.post}.tar.gz"
+S="${WORKDIR}/${P/_p/.post}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+
+RDEPEND=">=sci-libs/proj-7.2.0:="
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/xarray[${PYTHON_USEDEP}]
+ sci-libs/shapely[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
+distutils_enable_tests --install pytest
+
+python_test() {
+ local deselect=(
+ # TODO
+ test/test_datum.py
+ test/test_transformer.py::test_transform_wgs84_to_alaska
+ test/test_transformer.py::test_repr__conditional
+ test/test_transformer.py::test_transformer_group__unavailable
+ test/test_transformer.py::test_transformer_group__network_disabled
+ test/test_transformer.py::test_transformer_group__download_grids__directory
+ test/crs/test_crs.py::test_coordinate_operation_grids__alternative_grid_name
+ )
+
+ distutils_install_for_testing
+ cp -r test "${BUILD_DIR}" || die
+ cd "${BUILD_DIR}" || die
+ epytest --import-mode=append -m "not network" \
+ ${deselect[@]/#/--deselect } test
+}