summaryrefslogtreecommitdiff
path: root/dev-python/pyproj
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/pyproj
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/pyproj')
-rw-r--r--dev-python/pyproj/Manifest2
-rw-r--r--dev-python/pyproj/pyproj-3.3.1.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/pyproj/Manifest b/dev-python/pyproj/Manifest
index 86bceb7876f7..f4d748835bcb 100644
--- a/dev-python/pyproj/Manifest
+++ b/dev-python/pyproj/Manifest
@@ -1,3 +1,5 @@
DIST pyproj-3.3.0.tar.gz 217539 BLAKE2B 14e2332ffdf3d67e531bb4809cd50fd4902828b0cc3d2427921624d56cf05bdc0f3d5b17ea0516b3f428ad82bc57df840e4bd2dde1232870c9b959c34998c254 SHA512 9e8429a4fbec1950bf72a8c582d4a944a6707ac54a107a7837bf7fe44f8c2e29f1f6d0dcd9f5ff3ef511f3d31016389745cc2dfc14e2089756e6e72fe6074c47
+DIST pyproj-3.3.1.gh.tar.gz 238373 BLAKE2B 7996d253a35e3d64a343141179a88d2ab97e88f96447f3daf14c9f8d731099b506228c163fe460d3be30ae69c87e908879b3c0fe31eb7624c3bb8da157838337 SHA512 7175479f4ec526ada830d178bea77552d66aace4c7f6cde584aebef5fc4c6b7a46272eea2bd95f71910411c9ac8d8832d350891ffffda8a86eabb5449177a5eb
EBUILD pyproj-3.3.0.ebuild 871 BLAKE2B 35550104ff8397b2b3df3353d473380ed270cf647bfc1038d31a0219977234e63220e1b6290edc328c583b8e3fea5377e6e1b7dbacfb8612351c02823b96fa36 SHA512 937e8b3efbaae0c5ab3febf7f5cde40db467506782dc8d68fd3a2f59cb3b056467237d2846c71d31537d3f2a9cdf6171a529d0d57b6dc022e9360e2c5c5d3dba
+EBUILD pyproj-3.3.1.ebuild 916 BLAKE2B 3579603416efd60f95665faaac0a8971f197c9b69691225b1ba4ad9705aac9ddbf8e1a58e7d2be82291e4b7858353b25ff59df7539d7f0d67e9127525121d591 SHA512 c21acafeae00354553ee440375015957c26d31f21face9a7a987731f0d5b34c7fd7b7719e6b0bd26e389df983d9dad7cf20a9306e85e06d8eed729f71969ea64
MISC metadata.xml 415 BLAKE2B 4f3ab70bc72ca97a428c357257d3a59591b410f12276a42e141cd0a43072b79107529c95c6a313906129e8893c75b63a6ef11ddc2f3842a7f5e5e7f7349ec38e SHA512 7ca8a01534471dff67c42a96c524d166278e26da309b2c4d766045e38086cc0e52ccc990881ebed7ca81219d705d9e4a9c16e86b052a50867bb032457e354903
diff --git a/dev-python/pyproj/pyproj-3.3.1.ebuild b/dev-python/pyproj/pyproj-3.3.1.ebuild
new file mode 100644
index 000000000000..c8ba64083b68
--- /dev/null
+++ b/dev-python/pyproj/pyproj-3.3.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to the PROJ library"
+HOMEPAGE="
+ https://github.com/pyproj4/pyproj/
+ https://pypi.org/project/pyproj/
+"
+SRC_URI="
+ https://github.com/pyproj4/pyproj/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+
+RDEPEND="
+ >=sci-libs/proj-8.0.0:=
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/xarray[${PYTHON_USEDEP}]
+ sci-libs/shapely[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+python_test() {
+ rm -rf pyproj || die
+ epytest -m "not network" test
+}