summaryrefslogtreecommitdiff
path: root/dev-python/pyproj
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
commit7218e1b46bceac05841e90472501742d905fb3fc (patch)
tree56fae051db521b8fce8014cbc8b11484885b14b3 /dev-python/pyproj
parent6d691ad5b6239929063441bbd14c489e92e7396e (diff)
gentoo resync : 12.03.2021
Diffstat (limited to 'dev-python/pyproj')
-rw-r--r--dev-python/pyproj/Manifest2
-rw-r--r--dev-python/pyproj/pyproj-3.0.1.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/pyproj/Manifest b/dev-python/pyproj/Manifest
index e170f9da069a..e4a6ae079732 100644
--- a/dev-python/pyproj/Manifest
+++ b/dev-python/pyproj/Manifest
@@ -1,4 +1,6 @@
AUX pyproj-2.6.1_p1-tests.patch 2132 BLAKE2B 6d516cddb5b5bab0778a68d12025726e37871f49d34d7136905ecc17120d8436d5ef8f5304f1ea5ed35d25468a0116b72db01f0c3c627e9c4338ec57b58e22b2 SHA512 3678c9ae5c0793d0c33f64ebf473dc051e49437db1cad35b21ec11861ef19c1164987eaf8fe11e7883ebd28d5a81e073550bba380c5282cee6e44fd54cb9b2ee
DIST pyproj-2.6.1.post1.tar.gz 545482 BLAKE2B ba87cbbe93dad357c1fc4f333c7d3f02b632e6f2a00821b3875e73965f36fd7ea958f24705c125c3ae43dc8edac1b53a20578c46bc55bcbf335a9457d193d493 SHA512 43a885dbbf4ba54839c3b697d2582700e2b30172ef34acf6297b5e4ddba9b3148aeab83b3a515f1ce975898828c77ad457b6f6460e91083189f66a2fde6d77b7
+DIST pyproj-3.0.1.tar.gz 168962 BLAKE2B 3271d604148c122f4dfdd68c4237e1911f30da7cc858128d644b6b6807c3e49450e0b42c385d37bbe1cfa5ab80d635e7f620d41bf5089af6b49a542eb9b3fcd0 SHA512 f5ae0ede1deaa93757cb98cc680d6e47a19b9f5c0ce5e357c2ecfe96f764ff59ec7285c606162da38573123d21f12f1df82354f1d2205149970af2d7d63c2689
EBUILD pyproj-2.6.1_p1.ebuild 1252 BLAKE2B 7592e15a884fc7da5d2e49908f7aaec16b2e649a1346b86ebaf905cabcb7187120491ee2f70fff0a0574783516398972a8b0e5f148a74ba8f1d535e93e5de3cc SHA512 231cdc338240645051c972740a7424d145a51732d9556051004bc429685a7a5d8444642e320d510f7c406c0e4b5529db6ab31073b6a0aa5fb2ea750ad663b80d
+EBUILD pyproj-3.0.1.ebuild 1456 BLAKE2B 3807d40ff44314a5cf231267dcaf3b4e26d99c8510e8f4d31f790f39c6cf3e6221bcc83668e23f5c85362540f2be390fd499dfb507fa410b502f971bc4bcc16d SHA512 97471be094eb91888631c09079ffec12c5ccafb655a2920debf85c8a309e1eb7c5c5f36e962f3ef064a328be4e81ea9b9586f91617fa4e3636fb53dbef6bfd8f
MISC metadata.xml 414 BLAKE2B 37b554706874ecf474f6fde6c09e4d7e466f2a22527e2851d3766518d0044dbbd2211f291851564541394a4d8f7d37f8216ae1c50cab8f662d3335d58c1ea142 SHA512 c117112962969a1cee0a9c3c7ec86942bfca1ef3eb9859b079ebdac743b691a954d7dc55ec729e141336c253abff8e0c7fcf1625279990cb87da87d732efe881
diff --git a/dev-python/pyproj/pyproj-3.0.1.ebuild b/dev-python/pyproj/pyproj-3.0.1.ebuild
new file mode 100644
index 000000000000..af1f8f54b07d
--- /dev/null
+++ b/dev-python/pyproj/pyproj-3.0.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Python interface to the PROJ library"
+HOMEPAGE="https://github.com/pyproj4/pyproj"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P/_p/.post}.tar.gz"
+S="${WORKDIR}/${P/_p/.post}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+
+RDEPEND=">=sci-libs/proj-7.2.0:="
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/xarray[${PYTHON_USEDEP}]
+ sci-libs/shapely[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
+distutils_enable_tests --install pytest
+
+python_test() {
+ local deselect=(
+ # TODO
+ test/test_datum.py
+ test/test_transformer.py::test_transform_wgs84_to_alaska
+ test/test_transformer.py::test_repr__conditional
+ test/test_transformer.py::test_transformer_group__unavailable
+ test/test_transformer.py::test_transformer_group__network_disabled
+ test/test_transformer.py::test_transformer_group__download_grids__directory
+ test/crs/test_crs.py::test_coordinate_operation_grids__alternative_grid_name
+ )
+
+ distutils_install_for_testing
+ pytest -vv --import-mode=append -m "not network" \
+ ${deselect[@]/#/--deselect } test ||
+ die "Tests failed with ${EPYTHON}"
+}