summaryrefslogtreecommitdiff
path: root/dev-python/pyproj/pyproj-2.4.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/pyproj/pyproj-2.4.2-r1.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/pyproj/pyproj-2.4.2-r1.ebuild')
-rw-r--r--dev-python/pyproj/pyproj-2.4.2-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pyproj/pyproj-2.4.2-r1.ebuild b/dev-python/pyproj/pyproj-2.4.2-r1.ebuild
new file mode 100644
index 000000000000..df41d38524cc
--- /dev/null
+++ b/dev-python/pyproj/pyproj-2.4.2-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Python < 3.6 requires https://pypi.org/project/aenum/
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to the PROJ library"
+HOMEPAGE="https://github.com/jswhit/pyproj"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux"
+IUSE="doc"
+
+RDEPEND=">=sci-libs/proj-6.2.0:="
+DEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/Shapely[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=( "${FILESDIR}"/${P}-conftest.patch )
+
+distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+python_test() {
+ PROJ_LIB="${EPREFIX}/usr/share/proj" pytest -ra || die
+}