summaryrefslogtreecommitdiff
path: root/dev-python/pyproj/pyproj-2.4.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-python/pyproj/pyproj-2.4.2-r1.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-python/pyproj/pyproj-2.4.2-r1.ebuild')
-rw-r--r--dev-python/pyproj/pyproj-2.4.2-r1.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/pyproj/pyproj-2.4.2-r1.ebuild b/dev-python/pyproj/pyproj-2.4.2-r1.ebuild
deleted file mode 100644
index 2a90bfb128a2..000000000000
--- a/dev-python/pyproj/pyproj-2.4.2-r1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# Python < 3.6 requires https://pypi.org/project/aenum/
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python interface to the PROJ library"
-HOMEPAGE="https://github.com/pyproj4/pyproj"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux"
-IUSE="doc"
-
-RDEPEND=">=sci-libs/proj-6.2.0:="
-DEPEND="${RDEPEND}
- dev-python/cython[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- sci-libs/Shapely[${PYTHON_USEDEP}]
- )"
-
-PATCHES=( "${FILESDIR}"/${P}-conftest.patch )
-
-distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
-distutils_enable_tests pytest
-
-python_test() {
- PROJ_LIB="${EPREFIX}/usr/share/proj" pytest -ra || die
-}