summaryrefslogtreecommitdiff
path: root/dev-python/pyprof2calltree
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /dev-python/pyprof2calltree
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'dev-python/pyprof2calltree')
-rw-r--r--dev-python/pyprof2calltree/Manifest4
-rw-r--r--dev-python/pyprof2calltree/metadata.xml2
-rw-r--r--dev-python/pyprof2calltree/pyprof2calltree-1.4.5.ebuild19
3 files changed, 24 insertions, 1 deletions
diff --git a/dev-python/pyprof2calltree/Manifest b/dev-python/pyprof2calltree/Manifest
index 5289ae32d552..ff14fa03bbee 100644
--- a/dev-python/pyprof2calltree/Manifest
+++ b/dev-python/pyprof2calltree/Manifest
@@ -1,3 +1,5 @@
DIST pyprof2calltree-1.4.4.tar.gz 8797 BLAKE2B 0929728d3a6de1cc40e54bd4581bb4b64875a4d7f3ccef725300d40d2b3fd175d8ff462591357e32a471e5c3a4c5c51ac7e9c81c2e857050745a748bc4117d8a SHA512 7ffc228e542a568cb421394035660623415495472b5b3659a35b02c7ccccb7f578dc872d2bb1daf4fdfcd44134e1ad9b5ce3a18f49b15dd4aeb3b5f1201a28d8
+DIST pyprof2calltree-1.4.5.tar.gz 8806 BLAKE2B 3a8a838a8b03294504c64dbe1d0caee2606a1ec53005222dfe6c3692bacd0801041ce199fedb9c38e4f6edc91e210116d9c1e034e0aa283cafebb19bf6303fed SHA512 2fcda74ae67dc3a8abb5dc153864ef59f96cc62b1c9359d02be12e83966c17738f5aa4a3d1c6e2ff81614dc963fc4b2faf375bbbb1ad15650a6817e493cdde39
EBUILD pyprof2calltree-1.4.4.ebuild 521 BLAKE2B 21fa38d3f12296ef186deea2a283ca3941fc160ed0c2324a49e7a2aee6543eee6c64dfabda3bd65675a80a72ece0afebaf50a9539176f10c4fefbadfac3e699d SHA512 ad036ea4f4587a70cc5032436403433535606ea4711a975b4904561559a2f3ae729bbf97bbdf4c27c0544211ea4bdb0ce4f8b1d3f6605a1542abddc656f5da11
-MISC metadata.xml 318 BLAKE2B 9a8c3c56c2987bb1de47d374f81d25eee0aec15c00432bfd1585dadd5c57aae4ba8453739ad12dbcb8b44c54de4c5042a41da9458585387e1000ec6e97b9a267 SHA512 7a75d6efb9f11a6e1ce086cf53e5038b12815fe8110bf16c9b6e781c31cb721ec8694fb6fb0d4d131f9581cb130cecbceadf0e10b1528717cb8f4ab977514372
+EBUILD pyprof2calltree-1.4.5.ebuild 523 BLAKE2B c2239bd998950e0c0e1767d648ba57b2a70c888111c21221d8fc98fd78fea4ccf96fe67eb0aa093c2d4e53101eee93391e0318abbf6f96263a6c25da83d6cd12 SHA512 522600044510804fccf8811e8586e355cdac99caa8417fabe60c5db82b6a205d3e42bc04f35c18c3c6f9291862c9ea5cd271543e031431909b59b0ee434c8c9d
+MISC metadata.xml 405 BLAKE2B 7b39e1665882c1198da2774f0340c6bc711ecfd681785805cf4e3b53d9843c4abed05e43fc9f6ddf828c5a17a3d1af61307e7469115b078d971993ab71118ba8 SHA512 38fe7a3a85ffd1c35e175ffeffc30fea8f0c6fe9055c7df7c675cc02c822800fef06fdfb3f5b04c2e29e421ac3d0efb932570152a81ee9e6d358ffb66afab062
diff --git a/dev-python/pyprof2calltree/metadata.xml b/dev-python/pyprof2calltree/metadata.xml
index ae7e9c912476..40994ad78507 100644
--- a/dev-python/pyprof2calltree/metadata.xml
+++ b/dev-python/pyprof2calltree/metadata.xml
@@ -5,7 +5,9 @@
<email>python@gentoo.org</email>
<name>Python</name>
</maintainer>
+ <stabilize-allarches/>
<upstream>
<remote-id type="pypi">pyprof2calltree</remote-id>
+ <remote-id type="github">pwaller/pyprof2calltree</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/pyprof2calltree/pyprof2calltree-1.4.5.ebuild b/dev-python/pyprof2calltree/pyprof2calltree-1.4.5.ebuild
new file mode 100644
index 000000000000..5b5cbe820dbc
--- /dev/null
+++ b/dev-python/pyprof2calltree/pyprof2calltree-1.4.5.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="convert python profile data to kcachegrind calltree form"
+HOMEPAGE="https://pypi.org/project/pyprof2calltree/"
+# pypi tarball lacks tests
+SRC_URI="https://github.com/pwaller/pyprof2calltree/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests setup.py